cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


1662
Views
0
Helpful
2
Replies
RussMcIntire
Beginner

Port changes from Access to Trunk

I have several Layer 2 small business switches hosting several VLAN's. All routing is done on our firewall.

 

With the exception of a few phones, all other VLAN's are working as they should.

 

All end point, switch ports, are set up as Access ports, and all ports between switches are trunk ports.

The issue I have is with a few, not all of our Polycom phones.

Each Polycom phone has 2 ports. 1 port for the phone and 1 port to connect a PC. In this particular instance, the PC is plugged into the phone and the phone is plugged into the wall.

 

From the CLI, if I run

 

Sh MAC-Address-table dynamic

 

I can see the MAC address of the phone and PC assigned to the appropriate port on the switch.

I run the following commands to assign the the port to the new VLAN

switch# Conf t

switch (config)#int gi26

switch (config-if)#switchport mode access

switch (config-if)#shut

switch (config-if)#switchport access VLAN5

switch (config-if)#no shut

switch (config-if)#

At his point, I look at DHCP to make sure they pick up an address. No address appears. I look in the GUI of the switch and I see the port has been changed to a trunk port. I have had this issue with a few other phones and most of the time, if I change the port back to an access port and re-run the above commands, it it takes.

 

This is not isolated to just one switch. I have seen it on at least 3 different switches. An SG300, SG350, and SG500.

 

All switches are up to date, running the latest firmware. 

I do save the running config when I am done and the switches do not reboot over night. Not sure what is prompting this behavior.

 

Any help would be appreciated.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Glenn Martin
Cisco Employee

HI Russ,

information I've gathered hopefully will help. 

Disable SmartPort (it's enabled by default)

In Console

in global config mode - "no macro auto"

or per interface "no macro auto smartport"

...and see if that helps. LEt me know how it goes.

 

 

 

View solution in original post

2 REPLIES 2
Glenn Martin
Cisco Employee

HI Russ,

information I've gathered hopefully will help. 

Disable SmartPort (it's enabled by default)

In Console

in global config mode - "no macro auto"

or per interface "no macro auto smartport"

...and see if that helps. LEt me know how it goes.

 

 

 

Glenn,

 

This worked. Any Idea why this happens? It is inconsistent across my switches.

Create
Recognize Your Peers
Polls
How would you describe your level of technical expertise?