06-24-2014 07:46 AM
Hello,
Im trying to setup an EtherChannel between my 3750 stack and my 2960S stack.
I have 2 3750x in stack form. (2 switches).
I have 4 2960s in stack form. (4 switches).
I need to create a 2GB channel between them. My core is the 3750, and my 4 stack 2960s is on another floor, so I want to create a 2GB pipe between them.
I know you can create a PO between them, but what I want to do is create a 2GB pipe between them that run at the same time, active on both 1GB ports.
Is that possible and how? This is my current setup so far:
Switch Stack 3750
interface Port-channel10
description ETHSW04-1.5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree guard loop
spanning-tree cost 15
interface Port-channel11
description BRP-Uplink to ETHSW04-1.5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree guard loop
spanning-tree cost 1
interface GigabitEthernet1/0/39
description Uplink to ETHSW04-1.5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree guard loop
channel-protocol lacp
channel-group 10 mode active
interface GigabitEthernet1/0/40
description Uplink to ETHSW04-1.5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree guard loop
channel-protocol lacp
channel-group 10 mode active
interface GigabitEthernet2/0/39
description Uplink to BRP-Uplink to ETHSW04-1.5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree guard loop
channel-protocol lacp
channel-group 11 mode active
interface GigabitEthernet2/0/40
description Uplink to BRP-Uplink to ETHSW04-1.5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree guard loop
channel-protocol lacp
channel-group 11 mode active
---------------------------------------------------------------------------------
Switch stack 2960s
interface Port-channel1
description Uplink to CORE01
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree guard loop
spanning-tree cost 15
interface Port-channel2
description BRP-Uplink to CORE02
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree guard loop
spanning-tree cost 1
interface GigabitEthernet1/0/47
description CORE1-G1/0/39
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree guard loop
channel-protocol lacp
channel-group 1 mode active
interface GigabitEthernet1/0/48
description CORE1-G1/0/40
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree guard loop
channel-protocol lacp
channel-group 1 mode active
interface GigabitEthernet4/0/47
description BRP-CORE2-G2/0/39
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree portfast
spanning-tree guard loop
channel-protocol lacp
channel-group 2 mode active
!
interface GigabitEthernet4/0/48
description BRP-CORE2-G2/0/40
switchport trunk allowed vlan 1,210,220,214,216,220,306,406
switchport mode trunk
snmp trap mac-notification change added
snmp trap mac-notification change removed
spanning-tree portfast
spanning-tree guard loop
channel-protocol lacp
channel-group 2 mode active
Thanks...
Solved! Go to Solution.
06-25-2014 10:17 AM
Not possible AFAIK.
LACP will provide load balancing and redundancy which is pretty good for most use cases.
Other then that, you would have to look at 10GB uplinks between switches for more bandwidth.
06-25-2014 10:17 AM
Not possible AFAIK.
LACP will provide load balancing and redundancy which is pretty good for most use cases.
Other then that, you would have to look at 10GB uplinks between switches for more bandwidth.
06-25-2014 10:46 AM
Arent there different kinds of etherchannels you can setup? for LACP...
I thought you can setup redundant, passive passive, passive active, etc. How would I do that.
Thanks...
06-25-2014 01:13 PM
The modes for Etherchannel are just the negotiation protocol that is in use.
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected
Beyond that, you can configure the load balancing method.
06-25-2014 01:32 PM
Can you please explain the load balancing method?
Thanks....
06-25-2014 01:47 PM
Please refer to this guide for detailed info on configuring LACP and Load Balancing.
Basically, you can define manual weights for each link.
You can also configure the hashing method used to determine which link to use for communications.
http://www.cisco.com/c/en/us/td/docs/ios/cether/configuration/guide/ce_lnkbndl.html
06-25-2014 10:46 AM
Arent there different kinds of etherchannels you can setup? for LACP...
I thought you can setup redundant, passive passive, passive active, etc. How would I do that.
Thanks...
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide