02-24-2015 08:57 AM - edited 03-07-2019 10:49 PM
I am stumped on this one. I have a PoE 2960 that connects a few phone/workstation pairs to the network. All of them work correctly except for one...
For example, the good / working configs look like this on the interfaces:
interface GigabitEthernet1/0/45
description _X211
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
And.....
interface GigabitEthernet1/0/38
description _X208
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
The port that is not passing DHCP info onto the client is this one:
interface GigabitEthernet1/0/12
description _X209
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
What am I missing? This worked fine until last week when this site was connected via a trunk to another site (they used to connect via IPSec tunnel, but now have a dedicate link). As far as I can tell, that should not have effected this...and if it did effect this why didn't it effect any of the other ports?
The complete show run:
Building configuration...
Current configuration : 10102 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ...
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 ...
enable password 7 ...
!
!
!
no aaa new-model
clock timezone EST -5
switch 1 provision ws-c2960s-48lpd-l
!
!
ip name-server 10.1.0.10
ip name-server 10.0.0.10
vtp domain ...
vtp mode transparent
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
vlan 8,16,21,48,52,100-101,104,112,120,128,500,900,999
!
!
!
interface Port-channel1
description ...
switchport access vlan 500
!
interface FastEthernet0
no ip address
!
interface GigabitEthernet1/0/1
description PHONE_x204
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/2
description PHONE_x212
switchport access vlan 16
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/3
description voice vlan 52
switchport access vlan 16
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/4
description RUCKUS_WAP
switchport trunk native vlan 104
switchport mode trunk
!
interface GigabitEthernet1/0/5
switchport mode trunk
!
interface GigabitEthernet1/0/6
description PHONE_x205
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/7
switchport access vlan 16
!
interface GigabitEthernet1/0/8
switchport access vlan 21
switchport mode access
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
spanning-tree portfast
!
interface GigabitEthernet1/0/9
description PHONE_x206
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/10
switchport access vlan 16
!
interface GigabitEthernet1/0/11
switchport access vlan 16
!
interface GigabitEthernet1/0/12
description ..._X209
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/13
description PHONE_x208
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/14
description HP_OFFICEJET_PRO_8600
switchport access vlan 21
switchport mode access
!
interface GigabitEthernet1/0/15
switchport access vlan 16
!
interface GigabitEthernet1/0/16
description PHONE_x203
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/17
switchport access vlan 16
!
interface GigabitEthernet1/0/18
description PHONE_x202
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/19
switchport access vlan 16
!
interface GigabitEthernet1/0/20
switchport access vlan 16
!
interface GigabitEthernet1/0/21
switchport access vlan 16
!
interface GigabitEthernet1/0/22
description ..._X212
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/23
switchport access vlan 16
!
interface GigabitEthernet1/0/24
switchport access vlan 16
!
interface GigabitEthernet1/0/25
switchport access vlan 16
!
interface GigabitEthernet1/0/26
switchport access vlan 16
!
interface GigabitEthernet1/0/27
switchport access vlan 500
channel-group 1 mode on
!
interface GigabitEthernet1/0/28
switchport access vlan 16
!
interface GigabitEthernet1/0/29
switchport access vlan 500
channel-group 1 mode on
!
interface GigabitEthernet1/0/30
switchport access vlan 16
!
interface GigabitEthernet1/0/31
description SNAPBACK
switchport access vlan 500
!
interface GigabitEthernet1/0/32
switchport access vlan 16
!
interface GigabitEthernet1/0/33
switchport access vlan 16
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/34
switchport access vlan 16
!
interface GigabitEthernet1/0/35
description PHONE_x201
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/36
description PRINTER__OFFICES
switchport access vlan 21
!
interface GigabitEthernet1/0/37
switchport access vlan 16
!
interface GigabitEthernet1/0/38
description ..._X208
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/39
switchport access vlan 16
!
interface GigabitEthernet1/0/40
switchport access vlan 16
!
interface GigabitEthernet1/0/41
switchport access vlan 16
!
interface GigabitEthernet1/0/42
description CARD_ACCESS_SYSTEM
switchport access vlan 48
!
interface GigabitEthernet1/0/43
description SIP_PHONE
switchport access vlan 52
!
interface GigabitEthernet1/0/44
description PANASONIC_PHONE
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/45
description TECH_TBD_PHONE_X211
switchport trunk native vlan 16
switchport mode trunk
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
spanning-tree portfast
!
interface GigabitEthernet1/0/46
switchport access vlan 16
switchport mode access
!
interface GigabitEthernet1/0/47
description RUCKUS_WAP
switchport trunk native vlan 104
switchport mode trunk
!
interface GigabitEthernet1/0/48
description site-to-site-link
switchport mode trunk
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface TenGigabitEthernet1/0/1
!
interface TenGigabitEthernet1/0/2
!
interface Vlan1
ip address 10.0.1.254 255.255.255.0
!
interface Vlan48
ip address 10.0.48.254 255.255.255.0
!
interface Vlan52
ip address 10.0.52.254 255.255.255.0
!
interface Vlan101
ip address 10.0.101.254 255.255.255.0
!
interface Vlan128
no ip address
!
interface Vlan500
ip address 10.1.0.7 255.255.255.128 secondary
ip address 10.0.0.126 255.255.255.128
!
ip default-gateway 10.0.101.1
no ip http server
no ip http secure-server
logging 10.1.0.10
banner login ^CC
***************************************
UNAUTHORIZED LOGIN PROHIBITED
***************************************
^C
!
line con 0
exec-timeout 15 0
password 7 ...
logging synchronous
login
line vty 0 4
exec-timeout 15 0
password 7 ...
logging synchronous
login
length 0
line vty 5 15
exec-timeout 15 0
password 7 ...
logging synchronous
login
!
ntp clock-period 22519016
ntp server 198.60.73.8
end
02-24-2015 09:07 AM
Hi I am looking for an interface vlan 16 in your config but couldn't find it could this be the problem?
02-24-2015 09:13 AM
Your observation is correct, there is no int VLAN 16...however I do not think this is the issue because all of the other ports that include the VLAN 16 reference are working normally. I have just taken over this switch, I did not configure it so I am still figuring out all of the prior engineers setup.
02-24-2015 09:18 AM
So for this particular port I noticed that it is a trunk, I was looking for the vlan16 interface because it was the native vlan, so what are you connecting to this port and is it dhcp for all the vlans that is not passing or just one vlan.
02-24-2015 09:28 AM
This port has a workstation connect to it (VLAN 1) and a phone (VLAN 52). I am not sure why VLAN 16 is configured on any of these ports...could be something I am missing.
DHCP is handled by a MS server (10.1.0.10), it does not have a scope for VLAN 16 either. It does hand out VLAN 1 and 52 DHCP info correctly however.
02-24-2015 09:35 AM
Well the native vlan should be vlan 1 to pass untagged traffic to the workstation, and the phone will need to be configured for vlan 52.
02-24-2015 10:13 AM
I removed the line:
switchport trunk native vlan 16
From that port, but I am still not receiving DHCP info on the client.
As a workaround I have set a static IP on the phone. I am still unable to get the workstation (in this case a laptop) to get on the network even setting a static address. I put it onto the wireless for now to get them up and running.
This is quite odd. Any idea what I could try to adjust on that port?
02-24-2015 10:27 AM
since the port is a trunk the laptop will not understand tagged traffic, the laptop should be accessing vlan 1 to get an ip address so you will need to set the native vlan as vlan 1 on the port this will pass untagged traffic to the laptop for vlan 1.
interface GigabitEthernet1/0/12
switchport trunk native vlan 1
02-24-2015 10:00 AM
Hate to ask an obvious question but is the scope on the MS server full?
You said another site connected to this site, did they eat up all the scope?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide