cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
552
Views
0
Helpful
2
Replies

1811 will not do NAT

umbernaut
Level 1
Level 1

(I hope this is the proper place to post a NAT/routing question; if not, please move or let me know)

Some time back, I successfully configured a 2811 to do NAT.  I am having difficulty with an 1811 router using the same config.

Here is the 2811 config that successfully performed NAT from our private to public:

(I've removed everything except the critical information)

interface FastEthernet0/0

ip address [public ip] 255.255.255.240

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex half

speed auto

no mop enabled

!

ip nat pool [name] [public ip] [public ip] prefix-length 30

ip nat inside source list 1 pool [name] overload

ip route 0.0.0.0 0.0.0.0 [public gateway]

!

access-list 1 permit 192.168.1.0 0.0.0.255

Here is the 1811 config that will not do NAT:

interface FastEthernet0

ip address [public ip] 255.255.255.240

ip nat outside

ip virtual-reassembly

speed auto

half-duplex

!

interface FastEthernet1

ip address 172.16.1.1 255.255.255.224

ip nat inside

ip virtual-reassembly

speed auto

half-duplex

!

ip route 0.0.0.0 0.0.0.0 [public gateway]

!

ip nat pool [name] [public ip] [public ip] prefix-length 30

ip nat inside source list 1 pool [name] overload

!

access-list 1 permit 172.16.1.1 0.0.0.31

IOS version on the 1811 is:

Version 12.3(8r)YH12

Any help/advice is appreciated

2 Replies 2

jaimedrq1
Level 1
Level 1

Hi Umbernaut,

Why you don't try instead of using a pool the next command:

ip nat inside source list 1 interface fa 0 overload

If you have only one direction the pool is not needed.

Check the ip address where you are doing the connection, it should be between 172.16.1.1 and 172.16.1.30

I hope this helps

Cheers

Jaime.

umbernaut
Level 1
Level 1

I made the change you recommended, but it still wouldn't work.  I changed the duplex on both interfaces from "half-duplex" to "duplex auto" and it works now!

Review Cisco Networking for a $25 gift card