cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2371
Views
0
Helpful
3
Replies

2921 Vlan issues

Shaun McCloud
Beginner
Beginner

I am trying to set up a 2921 router to handle the vlans for the network.

I have added the vlans on the switch vlans 10-100 (counting by 10s), but i can not get the router to talk within the vlans.

everything that I read says to configer interface vlan but my router does not recognize the vlan command on the interface.

router show run:

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

vlan ifdescr detail

multilink bundle-name authenticated

!

!

!

!

license udi pid CISCO2911/K9 sn FGL1617130G

!

!

!

redundancy

!

!

!

!

!

!

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/1

description Internal Network

ip address 10.40.0.1 255.255.255.0

ip virtual-reassembly

duplex auto

speed auto

!

interface GigabitEthernet0/1.1

encapsulation dot1Q 3

!

interface GigabitEthernet0/2

description Connection to T1 Router

ip address 10.40.250.2 255.255.255.0

duplex auto

speed auto

!

!

router rip

network 10.0.0.0

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.4.253.41

!

!

control-plane

!

!

end

1 Accepted Solution

Accepted Solutions

glen.grant
Advisor
Advisor

  I believe the router will only use SVI's if the router has a mutli port switchcard installed which yours does not appear to have so your only option is to subinterface the router  and runn all traffic down a single interface to the router and set trunking on the switch side.

router side

int g0/1

desc vlan 10

int g0/1.10

encapsulation dot1q 10

ip address 192.168.10.1 255.255.255.0

int g0/1.20

desc vlan 20

encapsulation dot1q 20

ip add     192.168.20.1 255.255.255.0

and so on  for each subnet. Of course sunstitute the addresses shown with whatever you are using.  Switch side just setup as switchport mode trunk and encapsulation dot1q .

View solution in original post

3 Replies 3

glen.grant
Advisor
Advisor

  I believe the router will only use SVI's if the router has a mutli port switchcard installed which yours does not appear to have so your only option is to subinterface the router  and runn all traffic down a single interface to the router and set trunking on the switch side.

router side

int g0/1

desc vlan 10

int g0/1.10

encapsulation dot1q 10

ip address 192.168.10.1 255.255.255.0

int g0/1.20

desc vlan 20

encapsulation dot1q 20

ip add     192.168.20.1 255.255.255.0

and so on  for each subnet. Of course sunstitute the addresses shown with whatever you are using.  Switch side just setup as switchport mode trunk and encapsulation dot1q .

With this configuration how does the dhcp server know what subnet belongs to which vlan?

Where is the DHCP server and how will DHCP requests get to it? The config that you show us does not have any DHCP scopes configured on the router and there are no helper addresses to forward requests to a DHCP server. The exact answer of how the DHCP server will know which subnet depends a bit on where the server is and how the request got to the server. But in general the answer is that the DHCP server will know the subnet from which the request came if it is directly connected or the request will have the gateway address if the request was forwarded and the server will use this information to identify the correct scope.

HTH

Rick

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: