cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
332
Views
0
Helpful
6
Replies
baselzind
Contributor

3560G-24PS wont boot from new ios

i was upgrading my 3560G-24PS when one of them failed and would keep booting and then restarting , i have upgraded another exact same switch in the same rack with no issue but this one wont boot successfully from the new ios , i have to use rommon to boot from the old one in order to get it online

old ios:c3560-ipbase-mz.122-25.SEB2.bin

new ios:c3560-ipbasek9-mz.122-55.SE10.bin

i have attached what is appearing on the console when it failed to boot

6 REPLIES 6
johnd2310
Collaborator

Hi,

I think your switch has some hardware fault, maybe a fault with the memory.Open a tac case.

Thanks

John

**Please rate posts you find helpful**

The output doesn't look good stating memory corruption but its strange then you can still boot it back to the old ios if it was fully hardware failure

Have you confirmed the IOS that you uploaded didn't get corrupted somehow and the md5 hash is the same as the website

if you get a fresh copy ios and its still the same or you try another version like SE9 if its still the same something may have gone in hardware alright and you may need to RMA it if still supported

yes checked md5 twice and it was the same value , should i try a much older version like"12.2.35-SE5" or should i try SE9???

if the md5 is ok the ios is probably ok , all ios are 128/16 in dram and flash for that platform  so any image should work on it really theres no specific jump versions required on this series, as a last resort you could try SE9 its an main deployment release or something else but if its not booting SE10 and the md5 is ok it probably wont work either unfortunately but maybe worth a shot

the dump is not good as it showing memory failure and a trackback outputs , if its not able to upgrade its software something's gone in hardware only TAC will be able to say what exactly but they will probably just recommend an RMA

i tried yesterday to upgrade to "12.2.35-SE5" then to c3560-ipbasek9-mz.122-55.SE10.bin , it worked but just as the switch booted it initiated a restart after it went into the cli normally , i thought that was it , but i found when i came today it reverted to the old ios , it is showing this under show ver

System returned to ROM by error - Debug Exception (Could be NULL pointer dereference) Exception (0x2000)!, PC 0x1BA213C

what does this means?

should i try to upgrade again to 12.2.35-SE5 then to a previous version like 122-55.SE9?

It could be this below but your already on the higher image , you could try SE9 see if it will stay stable with that , its risky but you could remove the old image so it cant go back to it force SE9 or another IOS , but then you could put the switch into rommon if it fails on SE9 as it will have no fallback image

Cisco Bug: CSCsa72400 - Cat3560/Cat3750 inline power switch reset

Last Modified

Feb 29, 2016

Product

Cisco Catalyst 3560 Series Switches

Known Affected Releases

12.2(20)SE4

Description (partial)

Symptom:
A Catalyst 3560 reloads with the following error message:
Debug Exception (Could be NULL pointer dereference) Exception (0x2000)!

Conditions:
The Catalyst 3560 switch is running Cisco IOS 12.2(20)SE4 (and later) 
and PD is detected/classified as "overcurrent class". This problem won't happen
with latest images starting from 12.2(25)SEA

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.