cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
529
Views
0
Helpful
7
Replies

3650-48pq-E switch Trunking issue

dhill52975
Beginner
Beginner

I am fairly new at this, very new to cisco products. I'm what you would call a nub.

So my question is, I have 3650-48pq-E switch and g1/0/48 set up as a trunk port. When I issue a [show interface g1/0/48 trunk] it shows; vlans allowed on trunk as none, in fact it shows none for all fields. If I do a [show run interface g1/0/48] it shows switchport trunk allowed vlan 1-6,10 it shows the switchport mode as trunk and I also have it set for nonegotigate. If I do a [show interfaces g1/0/48 switchport] It shows the port as enabled, Admin mode = trunking, it shows the trunking vlans enabled 1-6,10. So why is it not showing that any vlans are allowed over the trunk port with the show interface trunk comand? what am I missing? It also shows the g1/0/48 port as being in vlan 1 when I do a [show vlan brief]

 

1 Accepted Solution

Accepted Solutions

Thanks for the update. I am glad that my suggestion pointed you in the right direction. It is quite nice when sometimes our solutions are quite simple. This community is an excellent place to ask questions and to learn about networking. I hope to see you continue to be active in the community.

HTH

Rick

View solution in original post

7 Replies 7

Reza Sharifi
Hall of Fame Expert Hall of Fame Expert
Hall of Fame Expert

Can you post the output of "sh run" and "sh interface trunk"?

HTH

Thanks for your response. You had caught me after I had left work for the day.
As you asked I have attached the SHOW RUN and SHOW INTERFACES TRUNK outputs

You say you attached the outputs but I do not see them. In addition to those outputs would you also post the output of show vlan and of show interface status?

HTH

Rick

Ok I just pasted everything into the email and not through a attachment this time.
I also Included the [SHOW INT G1/0/48 TRUNK] which is where I'm not seeing my vlans showing up.


CiscoPPN#sh run
Building configuration...

Current configuration : 6287 bytes
!
! Last configuration change at 18:31:45 UTC Wed Apr 15 2020
!
version 16.6
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname CiscoPPN
!
!
vrf definition Mgmt-vrf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
enable password 26516
!
no aaa new-model
switch 1 provision ws-c3650-48pq
!
!
ip domain name ITS.us
!
!
crypto pki trustpoint TP-self-signed-3715099769
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3715099769
revocation-check none
rsakeypair TP-self-signed-3715099769
!
!
crypto pki certificate chain TP-self-signed-3715099769
!
!
!
diagnostic bootup level minimal
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
username ITS password 0 26516
!
redundancy
mode sso
!
!
transceiver type all
monitoring
!
!
class-map match-any system-cpp-police-topology-control
description Topology control
class-map match-any system-cpp-police-sw-forward
description Sw forwarding, L2 LVX data, LOGGING
class-map match-any system-cpp-default
description DHCP Snooping, EWLC control, EWCL data
class-map match-any system-cpp-police-sys-data
description Learning cache ovfl, Crypto Control, Exception, EGR Exception, NFL SAMPLED DATA, RPF Failed
class-map match-any system-cpp-police-punt-webauth
description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
description L2 LVX control packets
class-map match-any system-cpp-police-forus
description Forus Address resolution and Forus traffic
class-map match-any system-cpp-police-multicast-end-station
description MCAST END STATION
class-map match-any system-cpp-police-multicast
description Transit Traffic and MCAST Data
class-map match-any system-cpp-police-l2-control
description L2 control
class-map match-any system-cpp-police-dot1x-auth
description DOT1X Auth
class-map match-any system-cpp-police-data
description ICMP redirect, ICMP_GEN and BROADCAST
class-map match-any system-cpp-police-stackwise-virt-control
description Stackwise Virtual
class-map match-any non-client-nrt-class
class-map match-any system-cpp-police-routing-control
description Routing control
class-map match-any system-cpp-police-protocol-snooping
description Protocol snooping
class-map match-any system-cpp-police-system-critical
description System Critical and Gold
!
policy-map system-cpp-policy
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
no ip address
shutdown
speed 1000
negotiation auto
!
interface GigabitEthernet1/0/1
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/2
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/3
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/4
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/5
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/6
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/7
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/8
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/9
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/10
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/11
switchport mode access
!
interface GigabitEthernet1/0/12
switchport mode access
!
interface GigabitEthernet1/0/13
switchport mode access
!
interface GigabitEthernet1/0/14
switchport mode access
!
interface GigabitEthernet1/0/15
switchport mode access
!
interface GigabitEthernet1/0/16
switchport mode access
!
interface GigabitEthernet1/0/17
switchport mode access
!
interface GigabitEthernet1/0/18
switchport mode access
!
interface GigabitEthernet1/0/19
switchport mode access
!
interface GigabitEthernet1/0/20
switchport mode access
!
interface GigabitEthernet1/0/21
switchport mode access
!
interface GigabitEthernet1/0/22
switchport mode access
!
interface GigabitEthernet1/0/23
switchport mode access
!
interface GigabitEthernet1/0/24
switchport mode access
!
interface GigabitEthernet1/0/25
switchport mode access
!
interface GigabitEthernet1/0/26
switchport mode access
!
interface GigabitEthernet1/0/27
switchport mode access
!
interface GigabitEthernet1/0/28
switchport mode access
!
interface GigabitEthernet1/0/29
switchport mode access
!
interface GigabitEthernet1/0/30
switchport mode access
!
interface GigabitEthernet1/0/31
switchport mode access
!
interface GigabitEthernet1/0/32
switchport mode access
!
interface GigabitEthernet1/0/33
switchport mode access
!
interface GigabitEthernet1/0/34
switchport mode access
!
interface GigabitEthernet1/0/35
switchport mode access
!
interface GigabitEthernet1/0/36
switchport mode access
!
interface GigabitEthernet1/0/37
switchport mode access
!
interface GigabitEthernet1/0/38
switchport mode access
!
interface GigabitEthernet1/0/39
switchport mode access
!
interface GigabitEthernet1/0/40
switchport mode access
!
interface GigabitEthernet1/0/41
switchport mode access
!
interface GigabitEthernet1/0/42
switchport mode access
!
interface GigabitEthernet1/0/43
switchport mode access
!
interface GigabitEthernet1/0/44
switchport mode access
!
interface GigabitEthernet1/0/45
switchport mode access
!
interface GigabitEthernet1/0/46
switchport mode access
!
interface GigabitEthernet1/0/47
switchport mode access
!
interface GigabitEthernet1/0/48
switchport trunk allowed vlan 1-6,10
switchport mode trunk
switchport nonegotiate
!
interface TenGigabitEthernet1/1/1
!
interface TenGigabitEthernet1/1/2
!
interface TenGigabitEthernet1/1/3
!
interface TenGigabitEthernet1/1/4
!
interface Vlan1
ip address 10.50.0.100 255.255.252.0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
control-plane
service-policy input system-cpp-policy
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login local
transport input ssh
line vty 5 15
login local
transport input ssh
!
mac address-table notification mac-move
!
end




CiscoPPN#
CiscoPPN#
CiscoPPN#sh int trunk
CiscoPPN#
CiscoPPN#
CiscoPPN#
CiscoPPN#show interfaces trunk
CiscoPPN#sh
CiscoPPN#show int
CiscoPPN#show interfaces tru
CiscoPPN#show interfaces trunk
CiscoPPN#
CiscoPPN#




CiscoPPN#sh vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi1/0/11, Gi1/0/12, Gi1/0/13
Gi1/0/14, Gi1/0/15, Gi1/0/16
Gi1/0/17, Gi1/0/18, Gi1/0/19
Gi1/0/20, Gi1/0/21, Gi1/0/22
Gi1/0/23, Gi1/0/24, Gi1/0/25
Gi1/0/26, Gi1/0/27, Gi1/0/28
Gi1/0/29, Gi1/0/30, Gi1/0/31
Gi1/0/32, Gi1/0/33, Gi1/0/34
Gi1/0/35, Gi1/0/36, Gi1/0/37
Gi1/0/38, Gi1/0/39, Gi1/0/40
Gi1/0/41, Gi1/0/42, Gi1/0/43
Gi1/0/44, Gi1/0/45, Gi1/0/46
Gi1/0/47, Gi1/0/48, Te1/1/1
Te1/1/2, Te1/1/3, Te1/1/4
2 camera active
3 fire active
4 sec/aiphone active
5 control active
6 cardaccess active
10 mccamera active Gi1/0/1, Gi1/0/2, Gi1/0/3
Gi1/0/4, Gi1/0/5, Gi1/0/6
Gi1/0/7, Gi1/0/8, Gi1/0/9
Gi1/0/10
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
3 enet 100003 1500 - - - - - 0 0
4 enet 100004 1500 - - - - - 0 0
5 enet 100005 1500 - - - - - 0 0
6 enet 100006 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------

CiscoPPN#



CiscoPPN#show interface status

Port Name Status Vlan Duplex Speed Type
Gi1/0/1 notconnect 10 auto auto 10/100/1000BaseTX
Gi1/0/2 notconnect 10 auto auto 10/100/1000BaseTX
Gi1/0/3 notconnect 10 auto auto 10/100/1000BaseTX
Gi1/0/4 notconnect 10 auto auto 10/100/1000BaseTX
Gi1/0/5 notconnect 10 auto auto 10/100/1000BaseTX
Gi1/0/6 notconnect 10 auto auto 10/100/1000BaseTX
Gi1/0/7 notconnect 10 auto auto 10/100/1000BaseTX
Gi1/0/8 notconnect 10 auto auto 10/100/1000BaseTX
Gi1/0/9 notconnect 10 auto auto 10/100/1000BaseTX
Gi1/0/10 notconnect 10 auto auto 10/100/1000BaseTX
Gi1/0/11 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/12 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/13 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/14 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/15 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/16 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/17 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/18 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/19 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/20 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/21 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/22 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/23 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/24 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/25 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/26 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/27 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/28 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/29 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/30 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/31 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/32 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/33 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/34 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/35 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/36 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/37 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/38 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/39 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/40 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/41 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/42 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/43 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/44 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/45 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/46 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/47 notconnect 1 auto auto 10/100/1000BaseTX
Gi1/0/48 notconnect trunk auto auto 10/100/1000BaseTX
Te1/1/1 notconnect 1 auto auto unknown
Te1/1/2 notconnect 1 auto auto unknown
Te1/1/3 notconnect 1 auto auto unknown
Te1/1/4 notconnect 1 auto auto unknown



CiscoPPN#sh int g1/0/48 trunk

Port Mode Encapsulation Status Native vlan
Gi1/0/48 on 802.1q other 1

Port Vlans allowed on trunk
Gi1/0/48 none

Port Vlans allowed and active in management domain
Gi1/0/48 none

Port Vlans in spanning tree forwarding state and not pruned
Gi1/0/48 none
CiscoPPN#



Thank you for the output. Here is what I see in the output that is important:

- 2 vlans have been configured, vlan 1 and vlan 10. Your trunk configuration lists vlans 2 through 6 but they are not present in the configuration. what are they supposed to be?

- Most important - you have no connected interfaces. Your trunk interface is not connected to anything. No vlan access port is connected to anything. With no connected interfaces both vlans will be down. When all vlans are down then the trunk will not have any vlans allowed on the trunk.

 

If you want the trunk to work you need to connect something to the trunk interface and it would be best is some access ports were also connected.

HTH

Rick

Thank you so very much. Connecting up the cables and assigning vlans to the other ports worked. I can't believe it was something that simple, but that is how it usually is.

Thanks for the update. I am glad that my suggestion pointed you in the right direction. It is quite nice when sometimes our solutions are quite simple. This community is an excellent place to ask questions and to learn about networking. I hope to see you continue to be active in the community.

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: