cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
244
Views
15
Helpful
8
Replies

3750G internet access on routed port but no other ports

AxL1971
Beginner
Beginner

I have a 3750G that has been reset to factory default and very basic setup done so far

 

Port 24 is set as no switchport and connected to my ISP router. I have so far set this port up as DHCP and gets IP address from the ISP router. From the switch I can ping the default gateway and 8.8.8.8

 

No other configuration done on the switch so no VLAN's setup for anything

 

Now when I plug in my laptop to another port on the switch I do not get a IP address thus no internet access

 

IP routing and default route has been setup (as you can see from my config)

 

I must be missing something here, as far as I am aware the ports on the switch will be on native VLAN 1. 

 

This is my config

 


Current configuration : 1345 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
switch 1 provision ws-c3750g-24t
ip subnet-zero
ip routing
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
no switchport
ip address dhcp
!
interface Vlan1
no ip address
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip http server
!
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end

8 Replies 8

balaji.bandi
VIP Guru VIP Guru
VIP Guru

This is a switch, this is not a router, This switch do not have any DHCP Server config to give you IP address for PC ?

what Router you have ? if you looking to get IP from ISP, then you need configure 

 

interface GigabitEthernet1/0/24  - as Layer 2 port, so Pc can IP address from ISP Router.

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Flavio Miranda
Advisor
Advisor

Hi

 In order for your laptop navegate on the internet you are going to need a DHCP escope and NAT confguration.

 

For DHCP:

!

vlan 10

!

Switch(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10
Switch(config)#ip dhcp pool test
Switch(dhcp-config)#network 192.168.1.0 255.255.255.0

 

For NAT, you need to identify which port do you get IP address. You can share the command "show ip int br" here.
Switch(dhcp-config)#default-router 192.168.1.1
Switch(dhcp-config)#dns-server 4.4.4.4
Switch(dhcp-config)#exit
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.1.5 255.255.255.0

 

Take on interface and plug you laptop:

int fastethernet 0/1

switchport mode access

switchport access vlan 10

 

 

 

 

There are at least 2 issues in the environment described in the original post. The first issue is that all the switch ports are in vlan 1 and there is not anything provided that will assign IP addresses to them. The suggestion of configuring DHCP on the switch is a good way to solve that issue.

The second issue is the need for NAT. The network is using a 3750G switch. And this switch does not have the ability to NAT. The OP tells us that "Port 24 is set as no switchport and connected to my ISP router" So there is not a customer router to provide NAT. The other alternative is to ask the ISP if they will provide NAT (but that might involve renegotiating the services provided).

 

HTH

Rick

I resolved the issue, as stated this is a L3 switch and can not do any NAT, so renabled the port 24 to a normal port and this then worked and laptop got IP from main router.

Glad you able to resolved, - this what we have suggested :

 

nterface GigabitEthernet1/0/24  - as Layer 2 port, so Pc can IP address from ISP Router.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Jitendra Kumar
Rising star
Rising star

Make the interface GigabitEthernet1/0/24 trunk with auto-nego and config management ip on vlan1 or other VLAN give their gateway. I think there is no need to configure DHCP on the switch if the ISP router provides an IP address.

 

switch needs to basic DORA request forward to the available DHCP server if you are reachable to the ISP gateway from the switch PC should get an IP address.

 

 

Thanks,
Jitendra

AxL1971
Beginner
Beginner

I have managed to aquire a 2951 router so will be replacing my ISP router with this one so will be fully Cisco kit at home from 2960 and 3750 switches to 2702I AP's

 

Will configure the 2951 as a DHCP server

 

As per your other comment, port G1/0/24 on the 3750 is a trunk port.

 

The 2951 should be fine for doing DHCP and NAT.

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers