Showing results for 
Search instead for 
Did you mean: 

3750x Stack is repeatedly showing error " %ADJ-3-RESOLVE_REQ : Adj resolve request: Failed to resolve <IP Address> <vlan ID>..


Good Morning,

I have a 3750x stack running  15.0(2)SE6.

Today I started seeing some weird problems in the logs

" %ADJ-3-RESOLVE_REQ : Adj resolve request: Failed to resolve <IP Address> <vlan ID>..

To my knowledge no changes have been made except updating the NTP and Timezone settings of the switch.

The problems is that before I rebooted a vmWare - Host all communication with said host worked like a champ. After reboot of said host, the only communications that work are from the host outward. Anyone have any ideas?  I would love to reboot, but as this is production hours that is not an option.

25 Replies 25

Cisco Employee
Cisco Employee



check this bug 



Hi Mtarawne. Do you suggest to install newer version of IOS, f.e. 15.4.... ?



In a Stack  3850 

repeatedly showing error  %ADJ-5-RESOLVE_REQ_FAIL: Adj resolve request failed for x.x.x.x

Base Ethernet MAC Address : f8:a5:c5:06:76:00
Motherboard Assembly Number : 73-15800-08
Motherboard Serial Number : FOC20484XUZ
Model Revision Number : AB0
Motherboard Revision Number : A0
Model Number : WS-C3850-48P
System Serial Number : FOC2048U14U

Switch Ports Model SW Version SW Image Mode
------ ----- ----- ---------- ---------- ----
* 1 56 WS-C3850-48P 03.07.03E cat3k_caa-universalk9 INSTALL
2 56 WS-C3850-48P 03.07.03E cat3k_caa-universalk9 INSTALL

Seems that if your logged in you can't search this bug. If you google it while your logged out google will come up with a hit and you can read the bug.

The the text under conditions does not make any sense to me. Nobody wants to see a log message every time the device needs to resolve an arp entry. You shouldn't have to disable something the makes the switch perform better just to avoid filling up the log with garbage.

The message interpreter tells you

Explanation    An internal software error occurred.

The details tell you to open a tac case.

Bottom line is..Will it be fixed, and in what code level will it be fixed.



If we are talking about 15.0(2)SE6 on 3750x you should try "no ip cef optimize neighbor resolution" - that should do the trick. (this option was disabled by default on 12.2 train, but enabled by default on 15.0) The other way is to try to hunt down all arp "incomplete" entries and check the issues with them - that would solve the problem with messages too.

Hello Tomasz,

i have the same problem on a 3750X Stack with 15.0(2)SE6.
This command solve the problem for me at the moment,

thanks, great post


Ran in this issue too after upgrading WS-C3750X-48P to c3750e-universalk9-mz.152-2.E4

no ip cef optimize neighbor resolution fixed the problem for me as well.

Tomaszu dobra robota ;)

I don't have this problem anymore, the command completely solves the problem,  thank you Tomasz.

Best Regards

Same problem here on a 3560G with same software version - 15.0(2)SE6

no ip cef optimize neighbor resolution fixed the problem for me as well.


This one is a winner, thanks.



Thanks! had a 3750X stack running 15.0(2)SE6 and the command stopped the logs.

Thank you Tomasz,

! have a 3750X stack running 15.0(2)SE6 and the command stopped the logs :-)

IOS Release: c3750e-universalk9-mz.150-2.SE6


Unit#1 WS-C3750X-12S-S

Unit#2 WS-C3750X-12S-S

Unit#3 WS-C3750X-24T-S

Unit#4 WS-C3750X-24T-S

Keep up the awesome work.


Thank very much for this post, I have tried and so far so good


I upgraded from 12.2 to 15.0(2)SE7 and I was seeing this log a lot... so default behaviour makes all sense to me :)


Best regards,

This was the direction I received from TAC after we experienced the same issue when moving to 15.0(2)SE6.

"no ip cef optimize neighbor resolution" 


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers