01-24-2013 04:31 AM - edited 03-07-2019 11:17 AM
Hi,
I have configured Cisco 871W with Wifi and Lan ports for user access . LAN ports seems to be working fine however SSID is not being broadcasted , following is configuration of my 871W
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CISCO-871-W
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
!
dot11 syslog
dot11 vlan-name MY-LAN vlan 2
!
dot11 ssid MY-WIRELESS
authentication open
guest-mode
!
ip source-route
!
!
!
ip dhcp pool LAN-CLIENTS
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1
!
ip dhcp pool WIFI-CLIENTS
network 192.168.4.0 255.255.255.0
default-router 192.168.4.1
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description **WAN INTERFACE**
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
no ip route-cache cef
no ip route-cache
!
ssid MY-WIRELESS
!
speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
ip address 192.168.3.1 255.255.255.0
!
interface BVI1
ip address 192.168.4.1 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
CISCO-871-W#show ip int br
Interface IP-Address OK? Method Status Protocol
BVI1 192.168.4.1 YES manual down down
Dot11Radio0 unassigned YES manual reset down
Dot11Radio0.1 unassigned YES unset reset down
FastEthernet0 unassigned YES unset up down
FastEthernet1 unassigned YES unset down down
FastEthernet2 unassigned YES unset up down
FastEthernet3 unassigned YES unset up down
FastEthernet4 10.0.0.1 YES manual up up
Vlan1 192.168.3.1 YES manual up down
01-24-2013 06:14 AM
Your BVI is configured incorrectly. You should not have an IP on VLAN 1 and you should use the "bridge-group 1" command on it. As it is the dot11radio0.1 interface is not connected to anything and as such is not coming up.
01-25-2013 09:12 AM
Also if you wanted to keep your wireless clients on a different subnet then your wired clients. You could always create a second SVI, say vlan 2, and put the wired ports in that other vlan.
01-25-2013 09:46 PM
Now i did this configuration, but i am unable to get IP address from DHCP on LAN & WLAN, when i manually configure IP address on host's wired lan, it does not work. but when i manually configure IP address on host's wireless lan interface it works perfect. i want my hosts on LAN & WLAN should get ip address from DHCP.
hostname Cisco-871w
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
!
no dot11 syslog
!
dot11 ssid MY-WIRELESS
authentication open
guest-mode
!
ip source-route
!
!
!
ip dhcp pool MY-CLIENTS
import all
network 172.16.142.0 255.255.255.0
dns-server 172.16.0.202
default-router 172.16.142.254
!
!
ip cef
ip domain name mynet.com
ip name-server 172.16.0.202
no ipv6 cef
!
multilink bundle-name authenticated
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description " WAN INTERFACE "
ip address 172.19.29.142 255.255.255.252
ip tcp adjust-mss 1300
duplex auto
speed auto
!
interface Dot11Radio0
ip address 172.16.142.254 255.255.255.0
no ip route-cache cef
no ip route-cache
!
ssid MY-WIRELESS
!
speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0
channel 2412
station-role root
antenna gain 0
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
!
interface BVI1
no ip address
!
!
ip default-gateway 172.16.142.254
ip forward-protocol nd
!
!
control-plane
!
bridge 1 protocol ieee
!
Cisco-871w#sh ip int br
Interface IP-Address OK? Method Status Protocol
BVI1 unassigned YES manual up up
Dot11Radio0 172.16.142.254 YES manual up up
FastEthernet0 unassigned YES unset down down
FastEthernet1 unassigned YES unset up down
FastEthernet2 unassigned YES unset up down
FastEthernet3 unassigned YES unset up down
FastEthernet4 172.19.29.142 YES manual up down
Vlan1 unassigned YES manual up down
01-27-2013 11:45 PM
now i did this configuration and i am able to get ip from DHCP on both LAN & WLAN segment but with different subnet.
now i want my clients on LAN & WLAN must get ip address of same segment.
Current configuration : 5012 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname BNC
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
aaa session-id common
!
resource policy
!
ip subnet-zero
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.142.1 172.16.142.10
ip dhcp excluded-address 172.16.142.254
ip dhcp excluded-address 172.16.241.1 172.16.241.10
!
ip dhcp pool b&c-department
import all
network 172.16.142.0 255.255.255.0
dns-server 172.16.0.202
default-router 172.16.142.254
! lease 7
!
ip dhcp pool VLAN20
import all
network 172.16.241.0 255.255.255.0
dns-server 172.16.0.202
default-router 172.16.241.1
lease 7
!
!
ip cef
ip name-server 172.16.0.202
no ipv6 cef
!
!
!
!
bridge irb
!
interface Loopback1
ip address 172.16.200.142 255.255.255.255
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description " WAN LINK "
ip address 172.19.29.142 255.255.255.252
ip tcp adjust-mss 1300
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
!
no encryption vlan 1 mode ciphers tkip
!
no encryption vlan 20 mode ciphers tkip
!
ssid GuestWLAN
vlan 20
authentication open
guest-mode
!
ssid InternalWLAN
vlan 1
authentication open
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
channel 2462
station-role root
no dot11 extension aironet
no cdp enable
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no snmp trap link-status
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.2
!
interface Dot11Radio0.20
description Guest wireless LAN - routed WLAN
encapsulation dot1Q 20
ip address 172.16.241.1 255.255.255.0
ip virtual-reassembly
!
interface Vlan1
description Internal Network
no ip address
ip virtual-reassembly
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
description Bridge to Internal Network
ip address 172.16.142.254 255.255.255.0
ip virtual-reassembly
router rip
version 2
network 172.16.0.0
network 192.168.142.0
network 172.16.241.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.142.20
ip route 172.19.29.0 255.255.255.0 172.19.29.141
ip http server
ip http secure-server
ip dns server
!
snmp-server community r3g10n RO
snmp-server location B&C
!
control-plane
!
bridge 1 route ip
!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide