cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
832
Views
0
Helpful
10
Replies
robertkwild
Beginner

adding new int to port channel

hi all,

i know how to add a port channel to a switch

config

int range gix/x/x-x

channel-group 1 mode auto OR active

int po1

switchport mode trunk
switchport trunk allowed vlan add OR remove <ID>

 

but how do i add a int port to it, is it like

int x

channel-group 1 mode auto OR active

or do i go int the int po1 and add it there

thanks,

rob

 

10 REPLIES 10
balaji.bandi
VIP Master

If the Guide lines met and they are same speed as per the guide lines

 

simple go to  new port ( add the same config as working interface, bot the side)

 

shutdown physical interface both side, do not connect any cable.

 

int x/x

channel-group 1 mode auto OR active

!

 

Once both the side configured as per the config, connect the Pysical cable and ssue bot the side physical interface no shutdown

 

and check show etherchannel 1 summary to verify.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

on my original port channel i get this, what does non candidate mean?

sh int Port-Channel 1

Load balancing: src-dst-mac.

Gathering information...
Channel Ports
------- -----
Po1 Active: gi52 Non-candidate: gi51

check the config of G151 ? what model of the switch ? what is other side of the switch ?

 

still issue , post  below output ?

 

show run inter port-cha 1

show run interfec gi52

show run interfec gi51

show interfec gi52

show nterfec gi51

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Seb Rupik
VIP Advisor

Hi there,

As you have it: go to the desired switch port and issue the relevant channel-group command, ensuring that the configuration of the switchport matches the port-channel it is being added and also that you have not exceed the platform limit for port-channel members.

 

cheers,

Seb.

show run inter port-cha 1
interface Port-channel1
spanning-tree link-type point-to-point
macro description switch
switchport trunk allowed vlan add 10,35,110,130,240,250
!next command is internal.
macro auto smartport dynamic_type switch
!
sg30052pDC01#show run int gi52
interface gigabitethernet52
channel-group 1 mode auto
!
sg30052pDC01#show run int gi51
interface gigabitethernet51
channel-group 1 mode auto

 

i can set the port channel to on rather than auto, would that make a difference?

You can set to ON, But the Port-channel go down and up, that is service interuption,  (how about other side switch ?)

 

If you doing cisco to cisco you ok, if you doing Cisco with other vendor, you need to follow other vendor guidelines too.

 

here is guide lines if you doing on SG Switches.

https://www.cisco.com/c/en/us/support/docs/smb/switches/cisco-550x-series-stackable-managed-switches/smb5848-configuring-lag-settings-on-a-switch-through-cli.html

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

sorry, im connecting a SG300 to a nexus 7000, in that case can i leave it set to auto, as you said its two ciscos

 

channel-group 1 mode auto

channel-group 1 mode on

on the 7000 side its set to active

If you terminate it from Nexus side on 2 Nexus switches, you need to create VPC for the PortChannel.

If you terminate it on single Nexus switch, then from the SG300 side you can leave it Auto while it is Active on Nexus.

Is the 7K in vPC or standalone (if that vPC with Dual chasis) - i take advantage of vPC, if that standalong. i use Auto standard port-channel. (since other side is active on Nexus 7L side)

 

Example config of vPC connecting to SG300 Switchs (this need to configure both nexus if they are vPC)

 

interface Ethernet1/1

  channel-group 20  < - this can change what ever number

interface port-channel20

  vpc 20

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

in the end i setup a new po11 on the 7000 with mode active and a new po1 on the sg300 with mode auto with 2 uplinks to/from the 7000 to the sg300 and now when i do a "sh int po1" both are coming up as active and i dont see "non candidate"