cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
306
Views
5
Helpful
2
Replies
Beginner

ADSL on 1841 - can you check my config pls

Hi all.

I've been away from configuring Cisco kit for a while and am a bit rusty. So if you could take a look at my config for me please and just point out where im going wrong that'd be great.

I've got an 1841 with the switchports on the back.

I've configured VLAN1 with the IP address 192.168.1.250 /24 (my laptop is plugged into fastethernet1)

I've configured my dialler, and i've got CD and PPP lights active.

I'm having trouble getting to the web. I cant ping any public IPs such as google or BBC. DNS isnt working either, but thats to be expected if im not getting to the web.

I run the PING command via interface VLAN1 and get no response (to the web)

Current configuration : 2179 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 bob
enable password bob
!
no aaa new-model
!
!
no ip routing
!
!
no ip cef
no ip dhcp use vrf connected
!
ip dhcp pool dhcp
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.250
   dns-server 192.168.1.250
!
!
ip name-server 194.74.65.69
ip name-server 194.72.0.114
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface BRI0
no ip address
encapsulation hdlc
no ip route-cache
shutdown
!
interface FastEthernet1
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
shutdown
!
interface FastEthernet5
shutdown
!
interface FastEthernet6
shutdown
!
interface FastEthernet7
shutdown
!
interface FastEthernet8
shutdown
!
interface ATM0
no ip address
ip virtual-reassembly
no ip route-cache
no atm ilmi-keepalive
pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
dsl operating-mode auto
!
interface Vlan1
ip address 192.168.1.250 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip flow egress
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname bob@bob.com
ppp chap password 0 bob
ppp ipcp dns request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
no ip http secure-server
ip dns server
ip nat inside source list NAT interface Dialer0 overload
!
ip access-list standard NAT
permit 192.168.1.0 0.0.0.255
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password bob
login
!
end

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: ADSL on 1841 - can you check my config pls

no ip routing

You'll need to get rid of that first.

2 REPLIES 2
Highlighted
Beginner

Re: ADSL on 1841 - can you check my config pls

no ip routing

You'll need to get rid of that first.

Beginner

ADSL on 1841 - can you check my config pls

Doh!!

Well spotted. Cheers I can now ping the interweb.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards