cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
562
Views
5
Helpful
1
Replies

All traffic hangs when I apply a simple access-list

benlemasurier
Level 1
Level 1

Hey everyone,

I'm attempting to log all outbound SMTP traffic so I can monitor for things like spambots on the network. I've created the following simple access-list:

ip access-list extended SMTP

remark SMTP TRAFFIC

permit tcp any any eq smtp log

!

interface GigabitEthernet0/1
  ...
  ip access-group SMTP in
!
However, as soon as I apply it to ge0/1 all traffic hangs. Any thoughts?

1 Accepted Solution

Accepted Solutions

Nagaraja Thanthry
Cisco Employee
Cisco Employee

Hello,

By default the access-list will have an implicit deny policy. So, when you applied the access-list to the interface, all other traffic got denied implicitely. Please add another line to the access-list that allows all other traffic:

ip access-list extended SMTP
remark SMTP TRAFFIC
permit tcp any any eq smtp log
permit ip any any

Hope this helps.

Regards,

NT

View solution in original post

1 Reply 1

Nagaraja Thanthry
Cisco Employee
Cisco Employee

Hello,

By default the access-list will have an implicit deny policy. So, when you applied the access-list to the interface, all other traffic got denied implicitely. Please add another line to the access-list that allows all other traffic:

ip access-list extended SMTP
remark SMTP TRAFFIC
permit tcp any any eq smtp log
permit ip any any

Hope this helps.

Regards,

NT

Review Cisco Networking for a $25 gift card