cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1988
Views
0
Helpful
5
Replies

apply configuration in HP into Cisco

ahmedmaged9432
Level 1
Level 1

 

i have these commands in HP switch need to configure them into Cisco switch , whats should i type 

vlan 1
name "DEFAULT_VLAN"
untagged 21-28
ip address X.X.X.X X.X.X.X 
no untagged 1-20
exit
vlan 2
name "Control"
untagged 1-10,15-20
ip address X.X.X.X X.X.X.X 
tagged 27-28
exit
vlan 3
name "CobraNet"
untagged 11-14
ip address X.X.X.X X.X.X.X 
tagged 27-28
exit
snmp-server community "public" unrestricted
spanning-tree

1 Accepted Solution

Accepted Solutions

So looking at this configuration:
Interfaces G0/25-26 are configured as a trunk and have VLANs 2 and 3 permitted and being tagged. The native VLAN on these interfaces is 1 by default but since you have not permitted it, no VLAN 1 traffic will be sent to them. You should modify the command to: switchport trunk allowed vlan 1-3. Alternatively, remove the command altogether; by default all defined VLANs will be permitted on a trunk unless you specify a list of allowed or denied VLANs.

Layer 3 Interface VLAN1 is shut down so it won't respond. Other devices on VLAN 1 can still talk to one another.
You haven't supplied any more configuration information so I can't tell what you have done, but from the original post, if you have configured the following:
Interface range g0/21-28
switchport access vlan 1
Then these ports (21-28) will be in VLAN 1

If you want to be sure what VLANs are operating on a particular interface, type: show spanning-tree interface <g0/x>
Note that this will work if the interface is up and operational but not if it is down.

As you have realized, the Cisco configuration is slightly different to the HP. From my small past history on HP so forgive me if I don't have it exactly correct:
* With Cisco the VLAN membership is defined at the interface level whereas in the HP the port membership is configured at the VLAN level.
* By default on a configured trunk interface Cisco will not tag the native VLAN whereas on the HP, you actually say which (if any VLANs) are to be tagged or not. There is a command which permits the native VLAN to be tagged which you can search for and examine if you like.
* On the Cisco you can specifically define if an interface is to be a trunk (multiple VLAN support) or an access (single untagged vlan). I think the HP gets this by the VLANs that are assigned.

It also doesn't really matter what you tag and what you don't as long as the device on the other end is configured the same way. Obviously there can only be 1 untagged VLAN on an interface but there doesn't have to be any.

L

View solution in original post

5 Replies 5

lpassmore
Level 1
Level 1
Try this for starters then find a configuration guide for your switch model and work out what everything does.

vlan 1
name DEFAULT_VLAN
vlan 2
name Control
vlan3
name CobraNet
vlan 999
name Unused

int range g1/0/1 - 10 , g 1/0/15 - 20 ' this command configures ports 1-10 and 15-20 at the same time. It might vary a bit depending on the switch model & IOS. You might need to remove the spaces between the range values or you can enter each interface individually. Interface names may be different on your switch. Do show run to find what they are

switchport
switchport mode trunk
switchport trunk allowed vlan 2 <permits VLAN 2 only>
switchport trunk native vlan 999 <makes sure VLAN2 (and any others that are allowed) is tagged>
no shut

int range g1/0/21 - 28
switchport
switchport mode access
switchport access vlan 1
no shut

int range g1/0/11 - 14
switchport
switchport mode access
switchport access vlan 3

no shut

snmp-server community public rw ;<ro is read-only, rw is read-write>
spanning-tree mode xxxx ;<whatever you need - rapid is best if not connecting to other make switches otherwise ieee>
spanning-tree portfast default


int vlan 1
no shut
ip address x.x.x.x x.x.x.x
int vlan 2
no shut
ip address x.x.x.x x.x.x.x
int vlan 3
no shut
ip address x.x.x.x x.x.x.x

switchport
switchport mode trunk
switchport trunk allowed vlan 2 <permits VLAN 2 only>
switchport trunk native vlan 999 <makes sure VLAN2 (and any others that are allowed) is tagged>
no shut

 

which port numbers will be configure to Vlan 2 and port 27,28 in multiple vlan 1,2 ,3 (can it be as it will be trunk port )

Sorry I missed ports 27 and 28. If you need vlans tagged on a port then you must configure it as a trunk, permit the vlans you want (optional but keeps unnecessary traffic out) and make sure the native vlan is different to the ones you want tagged.

 By default the native vlan on a trunk is not tagged. You can change that but simpler this way

interface GigabitEthernet0/25
switchport trunk allowed vlan 2,3
switchport mode trunk
!
interface GigabitEthernet0/26
switchport trunk allowed vlan 2,3
switchport mode trunk
!
interface Vlan1
ip address 192.168.3.254 255.255.255.0
no ip route-cache
shutdown
!
interface Vlan2
ip address 192.158.1.254 255.255.255.0
!
interface Vlan3
ip address 192.168.2.254 255.255.255.0

 

and this is for port 1 till 10 access vlan 2 

port 11 till 14 access vlan 3

15 till 24 access vlan 2

 

what will be the ports that access vlan 1

So looking at this configuration:
Interfaces G0/25-26 are configured as a trunk and have VLANs 2 and 3 permitted and being tagged. The native VLAN on these interfaces is 1 by default but since you have not permitted it, no VLAN 1 traffic will be sent to them. You should modify the command to: switchport trunk allowed vlan 1-3. Alternatively, remove the command altogether; by default all defined VLANs will be permitted on a trunk unless you specify a list of allowed or denied VLANs.

Layer 3 Interface VLAN1 is shut down so it won't respond. Other devices on VLAN 1 can still talk to one another.
You haven't supplied any more configuration information so I can't tell what you have done, but from the original post, if you have configured the following:
Interface range g0/21-28
switchport access vlan 1
Then these ports (21-28) will be in VLAN 1

If you want to be sure what VLANs are operating on a particular interface, type: show spanning-tree interface <g0/x>
Note that this will work if the interface is up and operational but not if it is down.

As you have realized, the Cisco configuration is slightly different to the HP. From my small past history on HP so forgive me if I don't have it exactly correct:
* With Cisco the VLAN membership is defined at the interface level whereas in the HP the port membership is configured at the VLAN level.
* By default on a configured trunk interface Cisco will not tag the native VLAN whereas on the HP, you actually say which (if any VLANs) are to be tagged or not. There is a command which permits the native VLAN to be tagged which you can search for and examine if you like.
* On the Cisco you can specifically define if an interface is to be a trunk (multiple VLAN support) or an access (single untagged vlan). I think the HP gets this by the VLANs that are assigned.

It also doesn't really matter what you tag and what you don't as long as the device on the other end is configured the same way. Obviously there can only be 1 untagged VLAN on an interface but there doesn't have to be any.

L

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card