cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4028
Views
50
Helpful
38
Replies
Community Manager

Ask the Expert: Understanding, Configuring, and Troubleshooting a Converged Network Using the Cisco Catalyst 3850 Series Switch

With Luke Primm, Colby Beam and Nicholas Tate 

 

Read the bioRead the bioRead the bio

Welcome to this Cisco Support Community Ask the Expert conversation. This is an opportunity to learn and ask questions about converged networks using the Cisco Catalyst 3850 Series Switch with experts Luke Primm, Colby Beam and Nicholas Tate. Our experts will answer all your questions about understanding, configuring, and troubleshooting a converged network using the Cisco Catalyst 3850.

The Cisco Catalyst 3850 is part of a unified access solution based on Cisco’s one policy, one management, one network. One network is the convergence of wired and wireless networks into one physical infrastructure with greater intelligence, performance, features, and operational consistency for simplicity and ease of use.

 

The Cisco Catalyst 3850 is a converged access switch for both wired and wireless Ethernet. It brings the best of wired and wireless together by supporting wireless tunnel termination and full wireless LAN controller functionality. This technical forum is intended to help answer and aid in the deployment of the Cisco Catalyst 3850 in your network. 

 

Luke Primm is a member of the TAC LAN switching team at Cisco responsible for the support of all Cisco IOS Software switching platforms. He has more than nine years of experience supporting small to enterprise-sized networks. Luke's technical career started as a high school computer technology teacher responsible for teaching the Cisco Networking Academy curriculum. Upon leaving the classroom, he spent the next eight years in education technology helping design and support K-12 network solutions. Luke graduated from Eastern Washington University with a BS degree in computer technology and recently achieved an MS degree in network architecture from Capella University.

 

Colby Beam has been a technical leader on the LAN switching team for the past year. Additionally, he spent two years working on the Cisco Nexus 5000 and 2000 platforms. He has more than eight years of experience with networking. Colby also has extensive experience with a wide variety of networks and data centers. He holds a bachelor of science degree in computer science from the University of North Carolina at Asheville. 

 

Nicholas Tate is a senior customer support engineer in the global technical assistance center supporting wireless technologies, where he works on complex wireless enterprise issues. He has published numerous wireless documents to Cisco.com and the Cisco Support Community. Tate has been with working at Cisco since 2011 and holds a degree in information computer technologies from East Carolina University. 

 

Remember to use the rating system to let Luke, Colby, and Nicholas know if you have received an adequate response.

 

They might not be able to answer each question due to the volume expected during this event. Remember that you can continue the conversation on the Network Infrastructure community and sub-community, LAN, Switching and Routing discussion forum shortly after the event.

 

This event lasts through December 13, 2013.. Visit this forum often to view responses to your questions and the questions of other community members.

 
38 REPLIES 38

Ask the Expert: Understanding, Configuring, and Troubleshooting

I have a two questions. First, where can I find some documentation that will help me come up to speed with the configuration steps necessary to deploy the converged features of the 3850. Second, do AP's need to be directly connected to the 3850 or can the 3850 be used as a the distribution switch of a small site with alternate (I.e. 2960's) as the access switches that the AP's plug into? Thanks for your time and for sharing your expertise with us.

Cisco Employee

Ask the Expert: Understanding, Configuring, and Troubleshooting

Hello Charles,

Thanks for getting us started on this Ask the Expert event.  These are very good questions that TAC gets asked a lot.  Lets start with your second question.  In order for APs to join a 3850 switch they DO have to be directly connected to it.  They shouldn't be installed on a 2960 that is trunked to the 3850.  Also, keep in mind that your APs will need to be on the same VLAN as the 3850's wireless managment interface and be on access ports only.

To answer your first question.  Documentation of this product is a little more limited then the classic WLC.  In the past couple months TAC has put together a lot of public facing documents with more on the way.  These links are great places to start.

3850/5760 Deployment Guide

http://www.cisco.com/en/US/docs/wireless/technology/5760_deploy/CT5760_Controller_Deployment_Guide.html

NGWC GUI Config

http://www.cisco.com/en/US/docs/wireless/controller/technotes/7.5/ConvergedAccessDG3_2_2.html

NGWC 802.1x Config

http://www.cisco.com/en/US/products/ps12598/products_configuration_example09186a0080c1e307.shtml

Nick

Beginner

Ask the Expert: Understanding, Configuring, and Troubleshooting

I am looking for documentation on how to setup 3850 switches connecting to two 6509’s in a VSS cluster maximizing  ten gig connects in two , three and four stack setups . I want to use it across two blades for redundancy one being a 16 port and the other being an eight port.  SO multiple 10 gig connects from the 3850 stacks. Can you point me in the right direction?

regards,

Stephen

Cisco Employee

Re: Ask the Expert: Understanding, Configuring, and Troubleshoot

Stephen

Excellent question. There is no exact documentation for the topology you are describing, however here is a quick example.

interface Port-channel15

switchport mode trunk

interfaceTenGigabitEthernet1/1/3

switchport mode trunk

channel-group 15 mode active

interface TenGigabitEthernet2/1/3

switchport mode trunk

channel-group 15 mode active

The configuration on the 6500 VSS would be almost identical excepf for the added encapsulation commands. The 3850 only supports Dot1Q, so there is no need to specify which encapsulation method on the 3850.

interface Port-channel15

switchport

switchport trunk encapsulation dot1q

interface TenGigabitEthernet1/2/2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

interface TenGigabitEthernet2/2/2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

This would give you two uplinks across a stack of 3850s, and also across the switches in the 6500 VSS creating a MEC (Multichassis EtherChannel). You could added extra links as needed or required. Let me know if there are further questions on this. The only addition configuration I can see is restricting which vlans you want on these links.

I was able to find some documentation on best practices for 6500 VSS.

http://www.cisco.com/en/US/products/ps9336/products_tech_note09186a0080a7c837.shtml

Beginner

Ask the Expert: Understanding, Configuring, and Troubleshooting

Hello experts,

I'm replacing my 3750 with the 3850 and need to configure QoS.  What are some major differences between these platforms?  Thank you for your help.

Kind regards,

Jessica

Cisco Employee

Re: Ask the Expert: Understanding, Configuring, and Troubleshoot

Hello Jessica,

This is a common question as we have a number of customers that are migrating off the 3750 and onto the 3850 platform.  The biggest difference is that we no longer support MLS QOS and we have moved to an MQC (Modular QOS CLI) based configuration, which is conceptually simpler in my opinion.  Customers often realize this when they try and paste their old QOS configurations into their 3850's and the commands are rejected. 

Another difference is that QOS is enabled out of the box on the 3850, unlike your 3750 where you had to enable MLS QOS globally.  Lastly, we have moved to a trust model in which we trust (DSCP) all markings by default on ingress.  You will recall on the 3750 that this was not the case and we would strip the markings and remark.  These are probably the three "biggest" differences that we explain to customers, however there are many others.  I would encourage you and anyone moving to the 3850 to check out the config guide below for much more detailed explanations of the differences.

:: Configuring QoS on 3850:  CLICK HERE

As noted previously, this a common question within TAC and we usually encourage the end customer to migrate to "auto-qos" if possible.  We find that auto-qos fits the vast majority of our customers needs and its simplicity makes it an excellent option.  Below are the supported auto-qos commands available.  

:: Auto QoS commands

auto qos classify police

auto qos trust cos

auto qos trust dscp

auto qos video cts

auto qos video ip-camera

auto qos video media-player

auto qos voip cisco-phone

auto qos voip cisco-softphone

auto qos voip trust

:: Configuring Auto-QoS on the 3850: CLICK HERE

I hope this at least gives you a start on QOS differences, if there are any other more specific questions, please reply and I can provide a more detailed answer.  Thanks!

-Luke

VIP Mentor

Re: Ask the Expert: Understanding, Configuring, and Troubleshoot

Hi Luke,

Apart from these config guides, is there any reference guide or design guide to understand this QoS topic in detail for these product platform ?

Is there any plan to update below QoS SRND 4.0 with this latest product ?

http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND/QoSIntro.html

Rasika

Cisco Employee

Re: Ask the Expert: Understanding, Configuring, and Troubleshoot

Hello Rasika,

It is my understanding that yes indeed we will be updating the campus design to include some of the newer platforms including the 3850.  The timeline however is still unknown, but my guess is it will be mid to late 2014 before we have a new release.  I do have a few links that I routinely provide to my customers that may help in your design process.  I would also encourage you to check out the recently released End-To-End QOS Network Design book from Cisco press.  It does cover both wired and wireless QOS on the 3850 and may be your best bet until we release something on CCO.

End-to-End QoS Network Design: Quality of Service for Rich-Media & Cloud Networks, 2nd Edition

http://www.ciscopress.com/store/end-to-end-qos-network-design-quality-of-service-for-9781587143694

Common resources that I frequently provide to my customers:

QoS on Converged Access Controllers and Lightweight APs Configuration Example

http://www.cisco.com/en/US/partner/tech/tk722/tk809/technologies_configuration_example09186a0080c1e227.shtml

QoS Command Reference, Cisco IOS XE Release 3SE (Catalyst 3850 Switches)

http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst3850/software/release/3se/qos/command_reference/b_mqc_qt_3se_3850_cr_chapter_0100.html

Enterprise Medianet Quality of Service Design 4.0—Overview

http://www.cisco.com/en/US/partner/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND_40/QoSIntro_40.html

Medianet Campus QoS Design 4.0

http://www.cisco.com/en/US/partner/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND_40/QoSCampus_40.html

If you have a Cisco Live subscription (FREE), you can checkout the live presentation - BRKCRS-2501 - Campus QoS Design Simplified

goto www.ciscolive365.com (Register - its free)

Enter BRKCRS-2501 in the search

:: Session PDF

** I would highly recommend checking out the Cisco live presentation noted above, its an excellent resource for not only the 3850 platform but the 3750, 4K, and 6K.

I hope this helps, please let me know if you have any further questions, thanks!

Luke

VIP Mentor

Re: Ask the Expert: Understanding, Configuring, and Troubleshoot

Hi Luke,

Thanks for prompt & detail response. All of them are really useful links.

I have already purchased that End-to-End QoS book. Will go through it soon (Noticed CH20-21 cover CA QoS ).

Yes that presentation is an excellent resource

Thanks

Rasika

Beginner

Ask the Expert: Understanding, Configuring, and Troubleshooting

Hello 3850 Experts,

I am wondering how to get some advice on the wireless capabilities of the Cisco 3850 switches please. In particular, I want to know if we can somehow get the Cisco 3850's to locally terminate the data traffic of a single SSID, while passing the traffic of other SSID's back to our central 5508 WLC / data centre.

Our 5508 WLC has several existing SSID's for data which work fine, but we are trying to add a Voice SSID. Our voice engineer thinks it would be great if we can terminate the wireless voice traffic on the 3850's, but the rest of the data traffic must go back to the WLC because of security reasons. Thanks for your help.

Dave

Cisco Employee

Ask the Expert: Understanding, Configuring, and Troubleshooting

Yes this is possible.  You will need to do a basic config on your 3850, have your APs join, and configure both your data and voice WLANs.  By default all your data will be switched locally at the 3850.  In order to get your existing SSIDs data pushed to the 5508 you will need to create an auto anchor. 

The first step in this process is to ensure your 5508 has new mobility architecture turned on.  This feature is only found in 7.3.112.0 or 7.5.x code or higher.  (7.4.x doesn't have this feature).  Next step is to create a mobility group between these 2 devices (you can also perform this as a SPG (switch pair group) if your 3850 is running in MA mode.  Once the mobility group is up and running you will configure the wlan on the 3850 to anchor the traffic to the 5508.

There isn't a good tech tip on this exact deployment; however, there are some documents you can piece together to get this up and running.  Go ahead and review these and if you hit a snag go ahead and open a TAC case and we can get this configured for you.

Mobility on 3850

http://www.cisco.com/en/US/docs/wireless/technology/5760_deploy/Mobility_Architecture.html#wp1054566

Mobility on 5508

http://www.cisco.com/en/US/docs/wireless/controller/7.5/config_guide/b_cg75_chapter_010010101.html

Highlighted

Ask the Expert: Understanding, Configuring, and Troubleshooting

Hi, I have a question about 3850 Switches , How many AP are supported in each switch?? and if Ihave a stack of these switches , duplicates the number of AP supported??

Regards

Cisco Employee

Ask the Expert: Understanding, Configuring, and Troubleshooting

Hello Francisco,

This is a very good question.  The 3850 switch is limited to 50 APs.  When you stack switches together they become one logical switch.  The end result of that is 1 3850 stack will support upto 50 APs.  Please note that 2 seperate switches or 2 seperate stacks will support 50 APs each.

Nick

Beginner

Ask the Expert: Understanding, Configuring, and Troubleshooting

Thank you for the details answer! One more question about the 3850.  How many switches can be stacked together with the Catalyst 3850? 

Thanks again,

Jessica

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards