09-15-2017 08:51 PM - edited 03-08-2019 12:03 PM
Hi Experts,
I need some help with an ASR BDI configuration. Here is the network scenario, my network is;
2– ASR 1001X Routers and 2 – Dell S4820T Switches
The ASR Routers and Dell S4820T Switches are cross connecting for redundancy, and the 40GB QSFP+ ports 48 and 52 have been fanned out on both switches into 4 separate 10GB QSFP+ ports.
They are connected as following:
ASR Router A Interface TenGigabitEthernet0/0/0 connected to Dell Switch A Interface TenGigabitEthernet 0/48
ASR Router A Port TenGigabitEthernet0/0/1 connected to Dell Switch B Interface TenGigabitEthernet 0/48
ASR Router B Interface TenGigabitEthernet0/0/0 connected to Dell Switch A Interface TenGigabitEthernet 0/52
ASR Router B Port TenGigabitEthernet0/0/1 connected to Dell Switch B Interface TenGigabitEthernet 0/52
What I am trying to do is created an BDI interface on both routers (BDI1), then configure TenGigabitEthernet0/0/0 and TenGigabitEthernet0/0/1 interface on to one bridge domain.
I’m not sure if I am messing something, but I am getting packets drop, and switch is running slow. The error message I received on the ASR is : Punted packet with unknown service type 73.
Also, not able to ping 10.123.107.1 for either switch. This my VIP on BDI1
Here is my configuration for the interfaces, it is the same on both routers:
interface TenGigabitEthernet0/0/0
description inside
no ip address
service instance 103 ethernet
encapsulation dot1q 103
rewrite ingress tag pop 1 symmetric
bridge-domain 1
!
service instance 104 ethernet
encapsulation dot1q 104
rewrite ingress tag pop 1 symmetric
bridge-domain 1
!
service instance 107 ethernet
encapsulation dot1q 107
rewrite ingress tag pop 1 symmetric
bridge-domain 1
!
!
interface TenGigabitEthernet0/0/1
description inside
no ip address
service instance 103 ethernet
encapsulation dot1q 103
rewrite ingress tag pop 1 symmetric
bridge-domain 1
!
service instance 104 ethernet
encapsulation dot1q 104
rewrite ingress tag pop 1 symmetric
bridge-domain 1
!
service instance 107 ethernet
encapsulation dot1q 107
rewrite ingress tag pop 1 symmetric
bridge-domain 1
Here is my configuration for the BDI interfaces
For Router A:
interface BDI1
description inside
ip address 10.123.107.2 255.255.255.0
ip nat inside
standby 107 ip 10.123.107.1
standby 107 priority 105
standby 107 preempt
standby 107 authentication test
standby 107 track 1 decrement 10
standby 107 track 2 decrement 10
standby 107 track 3 decrement 10
ip virtual-reassembly
For Router B:
interface BDI1
description inside
ip address 10.123.107.3 255.255.255.0
ip nat inside
standby 107 ip 10.123.107.1
standby 107 preempt
standby 107 authentication test
standby 107 track 1 decrement 10
standby 107 track 2 decrement 10
standby 107 track 3 decrement 10
ip virtual-reassembly
It a pretty simple network with 3 VLANs on each switch: VLAN 103, VLAN 104 and VLAN 107. With only VLAN 107 needed to connect out through router.
I have not worked on Dell S4820T switches before, so not sure if I have my uplink port configure correctly.
I have attached the uplink port configuration:
For Switch A:
interface TenGigabitEthernet 0/48
description TO TMDS-RT-A PORT TE0/0
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
no shutdown
!
interface TenGigabitEthernet 0/49
no ip address
mtu 12000
flowcontrol rx on tx off
!
port-channel-protocol LACP
port-channel 1 mode active
no shutdown
!
interface TenGigabitEthernet 0/50
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
shutdown
!
interface TenGigabitEthernet 0/51
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
shutdown
!
interface TenGigabitEthernet 0/52
description TO TMDS-RT-B PORT TE0/0
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
no shutdown
!
interface TenGigabitEthernet 0/53
no ip address
mtu 12000
flowcontrol rx on tx off
!
port-channel-protocol LACP
port-channel 1 mode active
no shutdown
!
interface TenGigabitEthernet 0/54
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
shutdown
!
interface TenGigabitEthernet 0/55
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
shutdown
!
interface fortyGigE 0/56
description VLT To SW-B
no ip address
no shutdown
!
interface fortyGigE 0/60
description VLT To SW-B
no ip address
no shutdown
!
interface ManagementEthernet 0/0
no ip address
no shutdown
!
interface ManagementEthernet 1/0
no shutdown
!
interface ManagementEthernet 2/0
no shutdown
!
interface ManagementEthernet 3/0
no shutdown
!
interface ManagementEthernet 4/0
no shutdown
!
interface ManagementEthernet 5/0
no shutdown
!
interface ManagementEthernet 6/0
no shutdown
!
interface ManagementEthernet 7/0
no shutdown
!
interface ManagementEthernet 8/0
no shutdown
!
interface ManagementEthernet 9/0
no shutdown
!
interface ManagementEthernet 10/0
no shutdown
!
interface ManagementEthernet 11/0
no shutdown
!
interface Port-channel 1
no ip address
switchport
vlt-peer-lag port-channel 1
no shutdown
!
interface Port-channel 100
no ip address
channel-member fortyGigE 0/56,60
no shutdown
!
interface Vlan 1
description Default VLAN
name Default VLAN
!untagged Port-channel 1,100
no shutdown
!
interface Vlan 103
description Workstations VLAN
name Workstations
ip address 10.123.103.4/24
untagged TenGigabitEthernet 0/0-24
no shutdown
!
interface Vlan 104
description The Management VLAN
name Management VLAN
ip address 10.123.104.4/24
untagged TenGigabitEthernet 0/40-45,50-51,54-55
no shutdown
!
interface Vlan 107
description Servers VLAN
name Servers
ip address 10.123.107.4/24
tagged TenGigabitEthernet 0/48,52
untagged TenGigabitEthernet 0/25-39
no shutdown
For Switch B:
interface TenGigabitEthernet 0/48
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
no shutdown
!
interface TenGigabitEthernet 0/49
no ip address
mtu 12000
flowcontrol rx on tx off
!
port-channel-protocol LACP
port-channel 1 mode active
no shutdown
!
interface TenGigabitEthernet 0/50
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
shutdown
!
interface TenGigabitEthernet 0/51
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
shutdown
!
interface TenGigabitEthernet 0/52
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
no shutdown
!
interface TenGigabitEthernet 0/53
no ip address
mtu 12000
flowcontrol rx on tx off
!
port-channel-protocol LACP
port-channel 1 mode active
no shutdown
!
interface TenGigabitEthernet 0/54
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
shutdown
!
interface TenGigabitEthernet 0/55
no ip address
mtu 12000
switchport
flowcontrol rx on tx off
spanning-tree rstp edge-port
shutdown
!
interface fortyGigE 0/56
description VLT To SW-A
no ip address
no shutdown
!
interface fortyGigE 0/60
description VLT To SW-A
no ip address
no shutdown
!
interface ManagementEthernet 0/0
no ip address
no shutdown
!
interface ManagementEthernet 1/0
no shutdown
!
interface ManagementEthernet 2/0
no shutdown
!
interface ManagementEthernet 3/0
no shutdown
!
interface ManagementEthernet 4/0
no shutdown
!
interface ManagementEthernet 5/0
no shutdown
!
interface ManagementEthernet 6/0
no shutdown
!
interface ManagementEthernet 7/0
no shutdown
!
interface ManagementEthernet 8/0
no shutdown
!
interface ManagementEthernet 9/0
no shutdown
!
interface ManagementEthernet 10/0
no shutdown
!
interface ManagementEthernet 11/0
no shutdown
!
interface Port-channel 1
no ip address
switchport
vlt-peer-lag port-channel 1
no shutdown
!
interface Port-channel 100
no ip address
channel-member fortyGigE 0/56,60
no shutdown
!
interface Vlan 1
description Default VLAN
name Default VLAN
!untagged Port-channel 1,100
no shutdown
!
interface Vlan 103
description Workstations
name Workstations
ip address 10.123.103.5/24
untagged TenGigabitEthernet 0/0-31
no shutdown
!
interface Vlan 104
description The Management VLAN
name Management VLAN
ip address 10.123.104.5/24
untagged TenGigabitEthernet 0/40-46,50-51,54-55
no shutdown
!
interface Vlan 107
description Servers
name Servers
ip address 10.123.107.5/24
tagged TenGigabitEthernet 0/48,52
untagged TenGigabitEthernet 0/32-39
no shutdown
!
ip route 0.0.0.0/0 10.123.107.1
I will take all the help I can get please. I have upload the configs for both switches and routers.
Thank You All!!!
I will try to post an Network diagram of this as well.
Solved! Go to Solution.
09-16-2017 04:04 PM
Hi Rookie,
Could you please share the output of the following command?
show platform hardware qfp active infrastructure punt statistics type per-cause
It looks like ASR is receving BPDUs from DELL switches, as it does not know how to handle them is punting them to the CPU.
Enable BPDU filter on interfaces directly connected to ASR (diable STP) and check if you still receive the error messages.
BR
09-16-2017 04:04 PM
Hi Rookie,
Could you please share the output of the following command?
show platform hardware qfp active infrastructure punt statistics type per-cause
It looks like ASR is receving BPDUs from DELL switches, as it does not know how to handle them is punting them to the CPU.
Enable BPDU filter on interfaces directly connected to ASR (diable STP) and check if you still receive the error messages.
BR
09-18-2017 01:02 PM
Hi BR,
Thanks for the help.
So I enable BDU filter on the interfaces ( no spanning-tree). And the punt error have stop, however my switches are still running and unable to coneect to the rotuers.
Out of the command you wanted me run below:
Global Per Cause Statistics
Number of punt causes = 117
Per Punt Cause Statistics
Packets Packets
Counter ID Punt Cause Name Received Transmitted
------------------------------------------------------------------------------------------------
000 Reserved 0 0
001 MPLS ICMP Can't Fragment 0 0
002 IPv4 Options 35 0
003 Layer2 control and legacy 123188 123188
004 PPP Control 0 0
005 CLNS IS-IS Control 0 0
006 HDLC keepalives 0 0
007 ARP request or response 7449337029 14351844
008 Reverse ARP request or repsonse 1233196 294245
009 Frame-relay LMI Control 0 0
010 Incomplete adjacency 0 0
011 For-us data 2178 2178
012 Mcast Directly Connected Source 0 0
013 Mcast IPv4 Options data packet 0 0
014 Skip egress processing 0 0
015 MPLS TTL expired 0 0
016 MPLS Reserved label (ie: 0-15) 0 0
017 IPv6 Bad hop limit 0 0
018 IPV6 Hop-by-hop Options 0 0
019 Mcast Internal Copy 0 0
020 Generic QFP generated packet 0 0
021 RP<->QFP keepalive 118758 118758
022 QFP Fwall generated packet 0 0
023 Mcast IGMP Unroutable 0 0
024 Glean adjacency 24 24
025 Mcast PIM signaling 0 0
026 QFP ICMP generated packet 11305 11305
027 Subscriber session control 0 0
028 Subscriber data switching back 0 0
029 RP handled ICMP 3 3
030 RP injected For-us data 15 15
031 Punt adjacency 0 0
032 SBC RTP DTMF 0 0
033 Pseudowire VCCV control channel 0 0
034 Generic QFP generated packet (keep GPM) 0 0
035 Ethernet slow protocol (ie: LACP, OAM) 0 0
036 Ethernet OAM Loopback 0 0
037 UNUSED 0 0
038 SPA IPC packet 0 0
039 Punt and replicate 0 0
040 PPPoE control 0 0
041 PPPoE session 0 0
042 L2TP control 0 0
043 IP Subscriber control (ie: FSOL, keepali 0 0
044 L2TP session 0 0
045 BFD control 0 0
046 MVPN non-RPF signaling packet 0 0
047 MVPN PIM signalling packet 0 0
048 Mcast punt to RP 0 0
049 SBC generated packet 0 0
050 IPv6 packet 0 0
051 DMVPN NHRP redirect 0 0
052 PFR monitored prefix logging 0 0
053 PFR top talkers logging 0 0
054 PFR top talkers application logging 0 0
055 For-us control 2524537567 212605133
056 RP injected for-us control 0 0
057 QFP VTCP generated packet 0 0
058 Layer2 bridge domain data packet 0 0
059 QFP Stile generated packet 0 0
060 IP subnet or broadcast packet 608949 118733
061 Ethernet CFM packet 0 0
062 Ethernet CFM notify packet 0 0
063 LISP LSB NOTIFICATION 0 0
064 Service Engine packet 0 0
065 L2BD Control packet from FIA 0 0
066 L2BD Control Message from CPP 0 0
067 MFR_LIP_CONTROL 0 0
068 Media Monitoring record punted from CPP 0 0
069 OTV Control packet 0 0
070 OTV ARP packet 0 0
071 REP control 0 0
072 IP MTU EXCEPTION 0 0
073 STP BPDU's 6567 6567
074 ACL log 0 0
075 EPC 0 0
076 Lisp Dynamic eid 0 0
077 L2 Control packet 932 932
078 WAAS CPP to CPP punt 0 0
079 dhcp snoop 0 0
080 Metric Mediation Agent record punted fro 0 0
081 IPv6 DMVPN NHRP redirect 0 0
082 Ethernet CFM packet from core 0 0
083 Ethernet CFM punt fwd packet 0 0
084 PTP punt fwd packet 0 0
085 ISDN D-Channel raw packet 0 0
086 Service controller SCG punt pkt 0 0
087 IPv6 FHS SG dropped packet 0 0
088 IPv6 FHS Data glean packet 0 0
089 SBC DSP pkts 0 0
090 Raw Socket Data packet 0 0
091 SSLVPN session control 0 0
092 ICMP unreachables for ACL denied packets 0 0
093 CENT Smart Probe packet 0 0
094 AppNav vPATH pktless API generated pkt 0 0
095 Autonomic Network Channel Discovery pack 0 0
096 Layer2 control protocols 0 0
097 Pakcets to LFTS 0 0
098 VLAN Auto Sense FSOL 0 0
099 ZTP Discovery packet 0 0
100 cable arp filter 0 0
101 Cable L3 mobility 0 0
102 Source Verify inconclusive 0 0
103 cable modem pre reg 0 0
104 mpls receive adj 0 0
105 MKA EAPoL packet 0 0
106 ICMP Unreachable 0 0
107 Cable DHCP 0 0
108 Snooping packet 0 0
109 snoop packets 0 0
110 msg Indicating ppp intf assigned ip addr 0 0
111 msg indicating there is another common h 0 0
112 QoS CAC Flow Report 0 0
113 Active identity 0 0
114 BGP Overlay Tunnel packet 0 0
115 Lisp gsmr enabled 0 0
116 Async TS 0 0
Number of inject causes = 48
Per Inject Cause Statistics
Packets Packets
Counter ID Inject Cause Name Received Transmitted
------------------------------------------------------------------------------------------------
000 RESERVED 0 0
001 L2 control/legacy 0 0
002 QFP destination lookup 57086 57071
003 QFP IPv4/v6 nexthop lookup 19 19
004 QFP generated packet 0 0
005 QFP <->RP keepalive 118758 0
006 QFP Fwall generated packet 0 0
007 QFP adjacency-id lookup 240485 240485
008 Mcast specific inject packet 0 0
009 QFP ICMP generated packet 11305 11001
010 QFP/RP->QFP Subscriber data packet 0 0
011 SBC DTMF 0 0
012 ARP request or response 6814094 6814094
013 Ethernet OAM loopback packet 0 0
014 UNUSED 0 0
015 PPPoE discovery packet 0 0
016 PPPoE session packet 0 0
017 QFP inject for pp_index lookup 0 0
018 QFP inject replicate 0 0
019 QFP inject PIT lookup 0 0
020 SBC generated packets 0 0
021 QFP VTCP generated packet 0 0
022 QFP Stile generated packet 0 0
023 Service Engine generated packet 0 0
024 Layer2 frame to EFP 0 0
025 Layer2 frame to BD 0 0
026 QfP Asym Routing redirected pkt 0 0
027 Compressed packet from WAAS 0 0
028 Media (e.g. voice) associated with a ses 0 0
029 service controller scg packet 0 0
030 Packet for 14 port Serial IM 0 0
031 Subscriber generated TCP reset packet 0 0
032 Layer2 frame to INPUT EFP 0 0
033 SSLVPN inject control 0 0
034 injected packet from UTD SP 0 0
035 injected packet from DPSS SN 0 0
036 injected packet by AppNav vPath 0 0
037 Uncompressed packet from WAAS 0 0
038 Autonomic Network Channel Discovery pack 0 0
039 Cable Bundle Flood Inject 0 0
040 Cable L2 unicast inject 0 0
041 downstream jib packet 0 0
042 switch port layer 2 control packet 0 0
043 Applications Injecting Pkts using LFTS 0 0
044 Enhanced ping and traceroute 0 0
045 Applications Injecting packets with SGT 0 0
046 CoPP packets from EPC_WS 0 0
047 Async TS 0 0
Is there an issue with BDI on the ASR 1001x?
09-18-2017 01:04 PM
10-04-2017 07:12 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide