- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-10-2019 02:47 PM
Can anyone tell me why I can't pass traffic to a trunked port on a Cisco 2960 or 3560 with this config running on an ASR920? I can pass untagged traffic....BDI1 but nothing for VLAN's 10,20 or 30. Standard switchport mode trunk config on the switches. Thanks in advance!
Switch#show run
Building configuration...
Current configuration : 6714 bytes
!
!
version 16.8
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
service unsupported-transceiver
no platform punt-keepalive disable-kernel-core
platform bfd-debug-trace 1
platform xconnect load-balance-hash-algo mac-ip-instanceid
platform tcam-parity-error enable
platform tcam-threshold alarm-frequency 1
!
hostname Switch
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
aaa new-model
!
!
no ip bootp server
ip domain name BLANK
multilink bundle-name authenticated
!
!
spanning-tree extend system-id
sdm prefer default
diagnostic bootup level minimal
!
!
redundancy
bridge-domain 2
!
!
transceiver type all
monitoring
cdp run
!
lldp run
!
policy-map mark-default
class class-default
set dscp default
!
interface GigabitEthernet0/0/0
no ip address
negotiation auto
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
!
!
interface GigabitEthernet0/0/5
no ip address
media-type auto-select
negotiation auto
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
!
service instance 10 ethernet
encapsulation dot1q 10
bridge-domain 10
!
service instance 20 ethernet
encapsulation dot1q 20
bridge-domain 20
!
service instance 30 ethernet
encapsulation dot1q 30
bridge-domain 30
!
!
i
interface TenGigabitEthernet0/0/13
description Uplink to ISP
ip address 10.x.x.x 255.255.255.252
negotiation auto
!
interface BDI1
description LAN
ip address 10.17.0.1 255.255.254.0
!
interface BDI10
description STAFF VLAN
ip address 10.17.10.1 255.255.255.0
!
interface BDI20
description STUDENT VLAN
ip address 10.17.20.1 255.255.252.0
!
interface BDI30
description GUEST VLAN
ip address 10.17.28.1 255.255.252.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 10x.x.x
!
Solved! Go to Solution.
- Labels:
-
Branch Router
-
LAN Switching
Accepted Solutions
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-13-2019 11:18 PM
Hi
You are missing the rewrite command, it will not work without it.
/Mikael
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-10-2019 03:04 PM
Hi @jatkins03 ,
Maybe this disscusion can give you some help:
https://community.cisco.com/t5/routing/asr-920-support-of-subinterfaces-with-vlans/td-p/2676329
Regards
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-10-2019 03:24 PM
Thanks for the reply. I saw this post and thought that's what I configured, but it's still not working.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-13-2019 11:18 PM
Hi
You are missing the rewrite command, it will not work without it.
/Mikael
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-14-2019 07:35 AM
Thank you, mlund, for putting me on the right track. This worked:
interface GigabitEthernet0/0/5
no ip address
media-type auto-select
negotiation auto
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
!
service instance 10 ethernet
encapsulation dot1q 10
rewrite ingress tag pop 1 symmetric
bridge-domain 10
!
service instance 20 ethernet
encapsulation dot1q 20
rewrite ingress tag pop 1 symmetric
bridge-domain 20
!
service instance 30 ethernet
encapsulation dot1q 30
rewrite ingress tag pop 1 symmetric
bridge-domain 30
!