cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
723
Views
0
Helpful
3
Replies

Bridging Wireless and LAN

pmillerj
Level 1
Level 1

I currently have a 2811 and a LAN setup via a sub-interface FA0/1.3 and using a HWIC-AP I have a sub-interface dot11radio 0/1.5.  I have them setup to work and surf the inet great, but I have recently been overly annoyed with the fact that the wifi cannot access windows shares on desktops and visa versa with the laptops.

The trick to make this happen is currently they are not on the same subnet.  I know the answer is bridging the interfaces but when I do this using the simple commands:

bridge 1 protocol ieee

interface x & y

bridge-group 1

Although what should be simple has failed (good thing I tftp'd my working config).  Here is my current configuration. Please let me know if there is a way to make this happen.

interface FastEthernet0/1.30

encapsulation dot1Q 30

ip address 192.168.3.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

no ip route-cache

!

interface Dot11Radio0/2/0

no ip address

ip nat inside

ip virtual-reassembly in

!

encryption vlan 50 mode ciphers aes-ccm tkip

!

!

broadcast-key vlan 50 change 30

!

!

ssid MillerNET

!

mbssid

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Dot11Radio0/2/0.50

encapsulation dot1Q 50

ip address 192.168.5.1 255.255.255.0

no ip proxy-arp

ip nat inside

ip virtual-reassembly in

As always thanks in advance!

1 Accepted Solution

Accepted Solutions

Jeff Van Houten
Level 5
Level 5

Didnt see the global irb command you need. Also when you bridge you take the ip addresses off the interfaces and create a new bvi interface with the correct address.

Sent from Cisco Technical Support iPad App

View solution in original post

3 Replies 3

Jeff Van Houten
Level 5
Level 5

Didnt see the global irb command you need. Also when you bridge you take the ip addresses off the interfaces and create a new bvi interface with the correct address.

Sent from Cisco Technical Support iPad App

I will be implementing this tonight and will test it.  Wish me luck

I believe that worked but I will be monitoring it for awhile.

Thanks for the quick fix

Review Cisco Networking for a $25 gift card