cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2693
Views
0
Helpful
16
Replies
Highlighted
Beginner

can I use freeFTPd as TFTP server to store routers & switches confi?

we use freeFTPd for Voip backup, now want to backup all routers & switches confi, does this free program work for them?

if yes, can anyone show me the exact CLI to copy start-config to it? I ran "copy start ftp" --> enter server IP when prompted, got "$error opening ftp://x.x.x.x/file name  (undefined error)" . it doesn't prompt me username and password, is that why I can't open the path?

if no, which program should I use here? more details, pls

thx.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Whatever user name you used and password you used is that username and password defined on the server for freeFTPd?  Is there a home directory setup for that user?  Can you send a screen shot of that freeFTPd?

That user should have a home directory, are you trying to put he file into the users home directory or did you create another directory within the home directory and then trying to put the file in there?

Post some screen shots of the freeFTPd software configuration espeically the way user is configured.

View solution in original post

16 REPLIES 16
Highlighted
Frequent Contributor

Instead of using manual backups why don't you use automated program like Rancid or Opennet Admin or Solarwinds' Kiwi Cat Tools I believe offers a free version too.  You can also use the Solarwinds' free TFTP server application and do a backup.  Would be much easier to use the TFTP server you'll simply run:

"copy startup-config tftp" and just follow the prompts very simple that way

Here is a table that shows the syntax for the "ftp"

http://www.cisco.com/en/US/docs/ios/12_1/configfun/command/reference/frd2002.html#wp1017432

Highlighted

well, our server admin doesn't like multiple programs installed on the server, that's why I prefer to use the existing one (unless I got the positive answer that this free program doesn't work for router bacup).but the problem is don't know if freeFTPd is compatible with router config backup or not.

copy start ftp or copy start tftp is simple and straight forth, but it doesn't work.

freeFTPd requires userID and password to access it, but in router CLI, it doesn't prompt me anything like that, that's part I am trying to figure out.

Highlighted
Advisor

Hi,

you can specify password and username in the FTP URL: ftp://username:password@x.x.x.x

or  use  following commands:

-ip ftp password xxxx

-ip ftp user xxxx

Regards.

Alain

Don't forget to rate helpful posts.
Highlighted

googled this one:http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_tech_note09186a008020260d.shtml#ftp

resolved my username and password concerns, but still not working. .

how do I specify the path? for now, after I ran copy start-cofniguration ftp, got prompt for address of remote host, and destination filename. not asking for path, what can I do now?

thx.

Highlighted

Hi,

use file prompt quiet  and specify path in URL: copy run ftp:// user:pass@ x.x.x.x/directory/filename

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted

copy startup-config ftp://username:password@ftp-server-ip/directory-for-backup/filename.txt

Here is a sample screen shot from my backup but I used the default directory:

Highlighted

is it something we didn't configure properly on the server side? I ran the exact CLIs, but still "error opeing ftp://x.x.x.x (undefined error)"

router is Cisco 2951

ping from router --> ftp server, successed

the destination folder is NOT the user home directory but the one I created.

just found that people who setup the FTP only allow certain IP addresses accessing the server, added the router to allow list, still not working.

Highlighted

Whatever user name you used and password you used is that username and password defined on the server for freeFTPd?  Is there a home directory setup for that user?  Can you send a screen shot of that freeFTPd?

That user should have a home directory, are you trying to put he file into the users home directory or did you create another directory within the home directory and then trying to put the file in there?

Post some screen shots of the freeFTPd software configuration espeically the way user is configured.

View solution in original post

Highlighted

u saved me.

got to be default root path, doesn't work with the directory I created. but this doesn't make sense too me, can u pls tell me if we can change it to the specific path I want?

thx.

Highlighted

If you can share the screen shots of how the user is created in the application and how the directory is created I can see but like I said if you can't upload it then it is most likely permissions issue or the syntax issue.  Can you post the full command you are typing in there as well?

Highlighted

- Might be an issue with the permissions on the new directory you created confirm permissions.

Highlighted

don't know if I can vote multiple answers as correct answers. I mean almost everyone here contribute to the resolution, appreciate all

what I did:

1. added the router's IP to allow access list on freeFTPd

2. created a new user account allowing it to access both FTP and SFTP on freeFTPd

3. specified the home directory of this new user to the directory I created on D: of the server, but had to change it back to default setting or it doesn’t work

4.for both default home and new created directories, leave all permissions default, admin has full control, users “read&execute”, “list folder contents”, and “read” but special permissions are “create files/ write date” & “create folders/append data”, no difference between 2 directories, don’t understand why it works with default home but not new created one.

Highlighted

Life is never easy, just sort of fixed this , but new issues comes, tried to backup the other exact same model Cisco 2951 router, encountered different error, this time is “%Error opening ftp://*****:*****@x.x.x/filename (Protocol error)”, what’s going on?

Have to open a new discussion.

Highlighted

Didn't you mentioned that you have to allow the IP address to be able to access the FTP ? 

Content for Community-Ad