cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1432
Views
5
Helpful
16
Replies
Beginner

Can't Ping From local network to Router(ISP)

i have been having an issue with a lab i have been doing in packet tracer. i have a few networks configured connecting to their receptive sub-interfaces on router one. all the networks can communicate among each other as their networks are being advertised by ospf. Now router one is connected to router two, which in this case is my isp. For my local host to get to the internet they must use a default route. the problem is that i can ping router one from any of my networks
the configuration is as follows i just can't ping router two from those network. From router one to two i can ping.

R1

no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0/0
description Connection To ISP
ip address 145.207.45.2 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/1.70
description Connection To Core Sw
encapsulation dot1Q 70
ip address 172.16.70.10 255.255.255.192
!
interface GigabitEthernet0/0/1.90
description Connection To Core Sw
encapsulation dot1Q 90
ip address 172.16.90.10 255.255.255.128
!
interface GigabitEthernet0/0/1.128
description Connection To Core Sw
encapsulation dot1Q 128
ip address 172.16.70.129 255.255.255.224
!
interface GigabitEthernet0/0/1.192
description Connection To Core Sw
encapsulation dot1Q 192
ip address 172.16.90.193 255.255.255.240
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 172.16.70.0 0.0.0.63 area 0
network 172.16.90.0 0.0.0.127 area 0
network 172.16.70.128 0.0.0.31 area 0
network 172.16.90.192 0.0.0.15 area 0
default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 145.207.45.1
----------------------------------------------------------------------------------------------------------------
___________________________________________________________________
R2
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
description Connection R1
ip address 145.207.45.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 145.207.0.0

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Master

Re: Can't Ping From local network to Router(ISP)

There is certainly not any problem with the locals using a default route to get to the Internet. The important question here is how will the isp router know how to forward to the locals. Either the isp router must have a route for those subnets or your router needs to do address translation of traffic going to the isp router.

 

HTH

 

Rick

Beginner

Re: Can't Ping From local network to Router(ISP)

let me do that on the fly. i was thinking about that. the reason i didn't do it was because i was thinking that i should at the very least ping the 145.207.45.1. i have done something similar to this when i was learning vpn but no sub-interfaces just default route to the internet with one local device. will let you know though

16 REPLIES 16
Hall of Fame Master

Re: Can't Ping From local network to Router(ISP)

There are a couple of obvious issues.

1) router 1 is running OSPF on interfaces except for the interface connecting to router 2. So there is no routing advertisement sent to router 2.

2) router 2 is running EIGRP on its interface connecting to router 1. This does not match up with router 1 even if router 1 did run its routing protocol on its interface since router 1 is running OSPF while router 2 is running EIGRP.

 

Both routers need to run the same routing protocol on the interface that connects them and that protocol on router 1 must advertise all of the subnets found on router 1.

 

HTH

 

Rick

Beginner

Re: Can't Ping From local network to Router(ISP)

True. The requirement is to only advertise of the local networks. the only way they should be able to get to the (internet) r2 is the default. so what i don't get is why i can't ping 145.207.45.1 from....lets say 172.16.70.5 (host device on the network 172.16.70.0)

VIP Mentor

Re: Can't Ping From local network to Router(ISP)

Hello,

 

R2 doesn't know about your local networks. Add a default route on R2 as well:

 

R2

ip route 0.0.0.0 0.0.0.0 145.207.45.2

Beginner

Re: Can't Ping From local network to Router(ISP)

Remember, R2 belongs to the ISP, so I think to add a default route pointing out to R1 is not a good idea...

Beginner

Re: Can't Ping From local network to Router(ISP)


@Yachay wrote:

Remember, R2 belongs to the ISP, so I think to add a default route pointing out to R1 is not a good idea...


how so? 

Beginner

Re: Can't Ping From local network to Router(ISP)

good suggestion, i tried it but it didn't work. but being that i can ping 145.207.45.2 from my locals, wouldn't it be possible to just use the default route to do it. that is to ping 145.207.45.1.

VIP Mentor

Re: Can't Ping From local network to Router(ISP)

Post the Packet Tracer project file. Rename the .pkt to a .jpg first, otherwise the system will not let you post it.

Re: Can't Ping From local network to Router(ISP)

Hello, Georg Pauwen

you are saying right it would work perfectly. But i think on real network scenario ISP not doing this thing. To configure default route to own end to reach customers.

The best way to configure same routing protocols in both end routers(Customer end and ISP end). Then they create neighbor ship with each other then we used ping utility to check the connectivity. It will ping from local network to router of ISP perfectly.

 

 

 

 

 

 

Highlighted
Beginner

Re: Can't Ping From local network to Router(ISP)

R2 needs to have routes back your networks (which should be static routes.)

 

Hall of Fame Master

Re: Can't Ping From local network to Router(ISP)

Let me explain it this way and perhaps that will help you understand the issue. Remember that for ping to work the ping request must get to the target and the ping response must get from the target back to the source. In your case the host 172.16.70.5 sends its ping request to 145.207.45.1 and it is received. Now the router at 145.207.45.1 wants to send a response but it does not have network 172.16.70.0 in its routing table. How can it send the response? It can not and that causes the ping to fail.

 

HTH

 

Rick

Beginner

Re: Can't Ping From local network to Router(ISP)

 

 

 

VIP Mentor

Re: Can't Ping From local network to Router(ISP)

Hello,

 

the idea was to post the .pkt (renamed as .jpg) so we can open the project and check what you are missing...

Beginner

Re: Can't Ping From local network to Router(ISP)

lol my bad i am multi-tasking 


@Georg Pauwen wrote:

Hello,

 

the idea was to post the .pkt (renamed as .jpg) so we can open the project and check what you are missing...


 

Beginner

Re: Can't Ping From local network to Router(ISP)

@Richard Burts wrote:

Let me explain it this way and perhaps that will help you understand the issue. Remember that for ping to work the ping request must get to the target and the ping response must get from the target back to the source. In your case the host 172.16.70.5 sends its ping request to 145.207.45.1 and it is received. Now the router at 145.207.45.1 wants to send a response but it does not have network 172.16.70.0 in its routing table. How can it send the response? It can not and that causes the ping to fail.

 

HTH

 

Rick



 i get that i do. but as i said before locals must use default to get to the internet. i used eigrp to advertise for the 145.207.45.0 network on the isp as i plan to expand the network to support multiple sites.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards