cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1837
Views
0
Helpful
3
Replies
Highlighted
Beginner

Can't ping to internet from second router via serial cable.

Hi everyone, I have 2 Cisco router connected via Serial cable, Router1 is an ADSL gateway, Router2 connected to Router1 via serial cable, all the hosts of Router2 can ping and access to Internet website through Router1, but I can't ping an internet address or  a website on Router2 by command line in console terminal. Please help and thanks in advance.

Host------------Router2--------------------------------Router1(ADSL)------------Internet

                                   (serial link)

Router2 config:
------------------------------------

interface FastEthernet0/0.1

description ###Manage Vlan###

encapsulation dot1Q 1 native

ip address 192.168.1.1 255.255.255.0

ip virtual-reassembly in

!

interface FastEthernet0/0.10

description ###Data Vlan###

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

ip virtual-reassembly in

!

interface FastEthernet0/0.20

description ###Voice Vlan###

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

ip virtual-reassembly in

!

interface Serial0/3/0

description ###CONNECTED TO ADSL GATEWAY###

ip address 10.10.10.2 255.255.255.252

!

ip route 0.0.0.0 0.0.0.0 Serial0/3/0

Router1 config:

------------------------------------

interface FastEthernet0/0

description ###LOCAL###

ip address 192.168.30.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface Serial0/1/0

description ###CONNECTED TO Router2###

ip address 10.10.10.1 255.255.255.252

ip nat inside

ip virtual-reassembly

clock rate 2000000

!

ip nat inside source list Local_Access_Internet interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 192.168.1.0 255.255.255.0 Serial0/1/0

ip route 192.168.10.0 255.255.255.0 Serial0/1/0

ip route 192.168.20.0 255.255.255.0 Serial0/1/0

!

ip access-list extended Local_Access_Internet

permit ip 192.168.30.0 0.0.0.255 any

permit ip 192.168.1.0 0.0.0.255 any

permit ip 192.168.10.0 0.0.0.255 any

permit ip 192.168.20.0 0.0.0.255 any

1 ACCEPTED SOLUTION

Accepted Solutions
Enthusiast

Re: Can't ping to internet from second router via serial cable.

Hi Thai,

have you tried to ping from a specific IP address?

Try ping 8.8.8.8 source 192.168.1.1

My suggestion here is, that maybe you are pinging with source IP address that is not translated (10.10.10.2) and therefore the ping on Router2 fails.

Best regards,

Jan

View solution in original post

3 REPLIES 3
Enthusiast

Re: Can't ping to internet from second router via serial cable.

Hi Thai,

have you tried to ping from a specific IP address?

Try ping 8.8.8.8 source 192.168.1.1

My suggestion here is, that maybe you are pinging with source IP address that is not translated (10.10.10.2) and therefore the ping on Router2 fails.

Best regards,

Jan

View solution in original post

Beginner

Can't ping to internet from second router via serial cable.

Hi Jan, Thank you very much, you are right about pinging with source interface. Thanks Jan

Enthusiast

Re: Can't ping to internet from second router via serial cable.

Hi Thai,

I am more than happy to hear that! Take care!

Best regards,

Jan

CreatePlease to create content
Content for Community-Ad