07-13-2017 04:54 AM - edited 03-08-2019 11:18 AM
Hi all,
Please find the below sh run of three router.
ROUTER R1 connect to R3 & R3 connect R2 -- but i can't ping to 20.20.20.1 from R1 using source 10.10.10.1 vice versa for R2.
R1:
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.252
duplex half
!
interface Ethernet1/0
ip address 10.10.10.1 255.255.255.0
duplex half
ip route 20.20.20.0 255.255.255.0 192.168.1.2
ip route 192.168.2.0 255.255.255.252 192.168.1.2
R3:
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.252
duplex half
interface Ethernet1/1
ip address 192.168.2.2 255.255.255.252
duplex half
ip route 10.10.10.0 255.255.255.0 192.168.1.1
ip route 20.20.20.0 255.255.255.0 192.168.2.1
R2:
interface Ethernet1/0
ip address 20.20.20.1 255.255.255.0
duplex half
!
interface Ethernet1/1
ip address 192.168.2.1 255.255.255.252
duplex half
ip route 10.10.10.0 255.255.255.0 192.168.1.1
ip route 192.168.1.0 255.255.255.0 192.168.2.2
07-13-2017 05:05 AM
On r2 your static routes appear to be incorrect. You have two outgoing interfaces configured in the static but there is only upstream connection from r2 to r3.
Change static routes on r2:
ip route 10.10.10.0 255.255.255.0 192.168.2.2
ip route 192.168.1.0 255.255.255.0 192.168.2.2
07-13-2017 05:06 AM
Hi
You should configure on R2:
ip route 10.10.10.0 255.255.255.0 192.168.2.2
instead
ip route 10.10.10.0 255.255.255.0 192.168.1.1
07-13-2017 05:11 AM
Additional, in order to avoid 2 static routes, remove first the wrong:
no ip route 10.10.10.0 255.255.255.0 192.168.1.1
then create the new one.
ip route 10.10.10.0 255.255.255.0 192.168.2.2
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide