cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1509
Views
0
Helpful
1
Replies

Cannot Redistributing Direct,EIGRP and OSPF on Nexus 7000

GIlrandy Giovani
Beginner
Beginner

Hi, i have a problem on redistributing OSPF,EIGRP & Direct connected on my Nexus 7000. Here is My topology

 

LAN--------N7k Vdc 1 (OSPF)---------------(OSPF)n7k vdc 2(EIGRP) -----------------------(EIGRP)Router ------WAN

 

I dont know if there s a problem on my route map, in each of those device are not accepting routing from redistribution.

i want on VDC 1 its should have a routing table from VDC 2 and Router antind VDC 2 and Router should have all the device routing table.te

Note:

- Router is a Vendor Device,dont have the configuration.

- the EIGRP and the and OSPF are running well.

- VDC 1 have ospf table from VDC 2,but not learn EIGRP table from Router

- VDC 2 have ospf table from VDC 1 & have EIGRP table from Router

- Router not learn any ospf table from VDC 2 and 1

 

Here s my Configuration:

 

VDC 1

 

ip prefix-list 10 seq 5 permit 10.49.0.0/16
ip prefix-list 10 seq 10 permit 10.53.0.0/16
ip prefix-list 10 seq 20 permit 172.16.10.0/24
route-map OSPF_redist permit 10
  match ip address prefix-list 10
 

 

------------- Some of Vlan----------

interface Vlan3
  no shutdown
  ip address 10.5x.x.1/26
  ip router ospf 1 area 0.0.0.0

interface Vlan4
  no shutdown
  ip address 10.5x.x.129/26
  ip router ospf 1 area 0.0.0.0

interface Vlan5
  no shutdown
  ip address 10.5x.x.33/26
  ip router ospf 1 area 0.0.0.0

  interface port-channel1
  description "Connect to VDC 2"
  ip address 10.5x.x.41/30
  ip router ospf 1 area 0.0.0.0

router ospf 1
  router-id 10.6x.x.69
  default-information originate always
  redistribute direct route-map OSPF_redist
  redistribute static route-map OSPF_redist
  default-metric 1

 

VDC 2

ip prefix-list 10 seq 5 permit 10.4x.0.0/16
ip prefix-list 10 seq 10 permit 10.5x.0.0/16
ip prefix-list 10 seq 20 permit 172.1x.10.0/24
route-map OSPF_redist permit 10
  match ip address prefix-list 10
 

interface port-channel3
  description "Connect to VDC 1
  ip address 10.5x.x.33/30
  ip router ospf 1 area 0.0.0.

interface Ethernet2/43
  description "Connect to Router G0/0"
  ip address 10.49.3.74/29
  ip router eigrp 500
  no shutdown

  router eigrp 500
  router-id 10.x.x.67
  default-metric 1000000 1 255 1 1500
  redistribute direct route-map OSPF_redist
   redistribute ospf 1 route-map OSPF_redist
router ospf 1
  router-id 10.x.x.67
  default-information originate always
  redistribute direct route-map OSPF_redist
  default-metric 1
  redistribute eigrp 800 route-map OSPF_redist

Did i miss something,even i cant redistribute direct connect to each device.

 

 

 

 

 

 


 

1 Reply 1

ashish shirkar
Beginner
Beginner

 

Hi ,

As per my observation ,your prefix list seems to be wrong,

 

example ip prefix-list 10 seq 5 permit 10.49.0.0/16

this will redistribute only 10.49.0.0/16 specific subnet like it will not redistribute 10.49.1.1/32 or 10.49.2.0/24 

you need to mentioned ge or le words to specify subnet mast.

Regards,

Ashish

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers