04-14-2010 12:20 AM - edited 03-06-2019 10:36 AM
I’ve got Catalyst 3750 switch. On the ingress port (Gi1/0/4) I am receiving lot of traffic from some Voice equipment. This is the configuration:
interface GigabitEthernet1/0/4
description "media"
switchport access vlan 113
switchport mode access
service-policy input MEDIA
policy-map MEDIA
class MEDIA-SPC
set dscp cs2
class MEDIA-RTP
set dscp cs5
class-map match-all MEDIA-SPC
match ip dscp af11
class-map match-all MEDIA-RTP
match ip dscp default
I want to remark AF11 to CS2. And this works just fine. ( I can see the packets correctly marked when leaving the switch (uplink monitored with Wireshark).
I would like also to remark DSCP 0 to DSCP 40 (CS50) but the switch doesn’t remark that as expected.
Does anyone know why I can remark AF11 and I cannot do the same for DSCP0?
Regards,
Franjo
04-14-2010 01:43 AM
Show the outout of
show mls qos
show mls qos maps ip-prec-dscp
04-16-2010 01:03 AM
CRI31#show mls qos
QoS is enabled
QoS ip packet dscp rewrite is enabled
CRI31#show mls qos maps ip-prec-dscp
IpPrecedence-dscp map:
ipprec: 0 1 2 3 4 5 6 7
--------------------------------
dscp: 0 8 16 24 32 40 48 56
CRI32#
CRI32#show mls qos maps ip-prec-dscp
IpPrecedence-dscp map:
ipprec: 0 1 2 3 4 5 6 7
--------------------------------
dscp: 0 8 16 24 32 40 48 56
04-16-2010 02:06 AM
change your config to:-
policy-map MEDIA
class MEDIA-RTP
set dscp 40
04-16-2010 03:13 AM
I actually configured it this way but in sh running-configuration you see it as CS5. So it is only how IOS prefers to display binary value 101 000.
04-16-2010 03:33 AM
Hi Franjo
The "match ip dscp default" actally means "match ip dscp 0"
There are a very high chance that the rtp-streams already are marked with some dscp-value (normally 40 or 46), and therefore are not matched.
Try to match something else in the "class-map match-all MEDIA-RTP", "match dscp 40" or "match dscp 46" or maybe "match any" , if the stream already are marked with dscp 40 you don't need to rewrite it.
/Mikael
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide