cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

3296
Views
0
Helpful
1
Replies
Highlighted
Beginner

Catalyst 3560 vlan trunks over etherchannel

I'm configuring two etherchannel groups (2 ports in each) on a 3560 switch.  I need to trunk multiple vlans over each channel group.

I created the vlan trunks and allowed vlans on each physical interface.  I notice that I can also configure the vlan trunks on the port-channel interfaces that were created. Should I configure them under those interfaces, or leave them on the physical interfaces?  Relevant config is below:

---------------------------------------------------------

interface Port-channel1

!

interface Port-channel2

!

interface FastEthernet0

no ip address

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,7,9

switchport mode trunk

channel-group 1 mode active

!

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,7,9

switchport mode trunk

channel-group 1 mode active

!

interface GigabitEthernet0/3

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,7,9

switchport mode trunk

channel-group 2 mode active

!

interface GigabitEthernet0/4

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,7,9

switchport mode trunk

channel-group 2 mode active

------------------------------------------------------------

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Rising star

Re: Catalyst 3560 vlan trunks over etherchannel

Hi,

configure whatever attribute you need for the links under the Po1 and Po2 interfaces, whats important here is that all your physical links in a boundle have the same characteristic (L2, L3, etc). The rest is to be done under port channel int when created.

"After you configure an EtherChannel, configuration changes applied to the port-channel interface apply to all the physical ports assigned to the port-channel interface. Configuration changes applied to the physical port affect only the port where you apply the configuration. To change the parameters of all ports in an EtherChannel, apply configuration commands to the port-channel interface."

plz Rate if it helped,

Soroush.

Hope it Helps!

Soroush.

View solution in original post

1 REPLY 1
Rising star

Re: Catalyst 3560 vlan trunks over etherchannel

Hi,

configure whatever attribute you need for the links under the Po1 and Po2 interfaces, whats important here is that all your physical links in a boundle have the same characteristic (L2, L3, etc). The rest is to be done under port channel int when created.

"After you configure an EtherChannel, configuration changes applied to the port-channel interface apply to all the physical ports assigned to the port-channel interface. Configuration changes applied to the physical port affect only the port where you apply the configuration. To change the parameters of all ports in an EtherChannel, apply configuration commands to the port-channel interface."

plz Rate if it helped,

Soroush.

Hope it Helps!

Soroush.

View solution in original post

CreatePlease to create content
Content for Community-Ad