cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2878
Views
0
Helpful
7
Replies
Highlighted
Beginner

CDP on sub-interfaces

Hello,

I have a central hub router using sub-interfaces that connects to multiple remote sites. Running CDP across all links, I can see the remote sites from the hub router, but not the hub router from all remote sites.

I'm guessing this is due to CDP being tagged as it's sent out the sub-interfaces (and not in VLAN1), i.e.: the example below is tagged in VLAN701 and sent out:

PPCW_R28_508#sh cdp int g0/1.701

GigabitEthernet0/1.701 is up, line protocol is up

  Encapsulation 802.1Q Virtual LAN, Vlan ID  701.

  Sending CDP packets every 60 seconds

  Holdtime is 180 seconds

BOURNE_D_CR451_01#sh cdp int f1/48

FastEthernet1/48 is up, line protocol is up

  Encapsulation ARPA

  Sending CDP packets every 60 seconds

  Holdtime is 180 seconds

PPCW_R28_508#sh cdp ne
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
BOURNE_D_CR451_01  Gig 0/1.701        144        R S I      WS-C4510R Fas 1/48

I can see CDP packets sent out (debug), but assume the tagging is the problem - is there a solution to this?

Regards,

Phil

Everyone's tags (2)
7 REPLIES 7
Advisor

CDP on sub-interfaces

Hi,

cdp is not tagged.It uses the native VLAN. did you debug cdp on both sides?

Regards.

Alain.

Don't forget to rate helpful posts.
Beginner

CDP on sub-interfaces

Yep - debugging showed CDP being sent out:

BOURNE_D_CR451_01#sh log | in 1/48

Sep  8 10:42:07: CDP-PA: version 2 packet sent out on FastEthernet1/48

PPCW_R28_508#sh log | in 701

000385: Sep  8 10:42:07: CDP-PA: Packet received from BOURNE_D_CR451_01 on inter

face GigabitEthernet0/1.701

PPCW_R28_508#sh log | in 0/1

000370: Sep  8 10:41:48: CDP-PA: version 2 packet sent out on GigabitEthernet0/1
000408: Sep  8 10:42:48: CDP-PA: version 2 packet sent out on GigabitEthernet0/1

..although looking at this, looks like it's only going out the physical interface, not the sub-interfaces on the hub router....

Advisor

CDP on sub-interfaces

Hi,

although looking at this, looks like it's only going out the physical interface, not the sub-interfaces on the hub router

if native VLAN is on physical interface this seem logical imho.

Regards.

Alain.

Don't forget to rate helpful posts.
Beginner

CDP on sub-interfaces

...so is there a way to send CDP on sub-interfaces?

rgds

Phil

Advisor

CDP on sub-interfaces

Hi,

if the behaviour is what I think it is as posted above then you have to define a subinterface for the native VLAN.

Alain.

Don't forget to rate helpful posts.
Beginner

CDP on sub-interfaces

so you can configure native vlan on a single sub-interface... will this mean all CDP traffic is sent out of a single sub-interface instead of the physical? Or can you assign the same native VLAN ID 1 to all sub-interfaces causing CDP to be sent out of each sub-int?...

Advisor

CDP on sub-interfaces

Hi,

if you don't configure a subinterface vor native vlan then it is supposed to be on main interface but I think that if it is not the default vlan 1 it must be configured on a subinterface. I don't remember if it is a IOS version caveat or not, I must retrieve the info.

But you can't configure multiple subinterfaces to carry the native vlan, each subinterface carries a particular vlan.

Regards.

Alain.

Don't forget to rate helpful posts.
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards