cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
351
Views
1
Helpful
10
Replies

Cisco 2960-s - fix IP for web gui

Drug_Store
Beginner
Beginner

Hi,

I have a Cisco 2960-s, and all I want to be configured is a simple web gui access.

I reset it, only added the name and password by cli, but I dont see it in my network.

I don´t need any configuration (all connected devices will receive DHCP from another device), but I need to access the 2960-s by web GUI once in while (since sometime I´m not near it to access by cli).

I´ve been struggling to config it. I´m sure, this is simple, but not for me

All I need is to be default configuration (vlan1, etc), and the switch to have fixed IP for me to access by web GUI.

 

Can someone guide me?

 

Thank you

10 Replies 10

MHM Cisco World
VIP Mentor VIP Mentor
VIP Mentor

I think you need to config HTTP/HTTPS in SW to access via GUI

Yes, perhaps... but how?

Procedure 1 - Configure The HTTP Server On The Switch | Global Switch Configuration | Guides

START first with HTTP then config HTTPS (HTTPS need domain and crypto key, so if you success with HTTP no need this command).

Note:- enable HTTP in SW make SW listen to HTTP port and you can see some DDoS attack.

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

You need to have correct TAR image to get full GUI for your device.

post below output from device :

show version

dir 

Other Option you can configure from CLI using SSH if you are able to reach GUI means you can able to SSH to the device.

below DHCP should work :

service dhcp 

ip dhcp excluded-address 192.168.1.1 192.168.1.20
!
ip dhcp pool LANPOOL
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8

!

interface GigabitEthernetx/x
ip address 192.168.50.1 255.255.255.0
no shtudown

or 

interface  vlan 1 
ip address 192.168.50.1 255.255.255.0
no shutdown

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Here´s the version :

 

cisco WS-C2960S-24PS-L (PowerPC) processor (revision M0) with 131072K bytes of memory.
Processor board ID FOC1845Y3SP
Last reset from power-on
1 Virtual Ethernet interface
1 FastEthernet interface
28 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : E0:89:9D:4B:31:80
Motherboard assembly number : 73-11908-10
Power supply part number : 341-0393-02
Motherboard serial number : FOC18450C4L
Power supply serial number : DCA1841U0K7
Model revision number : M0
Motherboard revision number : A0
Model number : WS-C2960S-24PS-L
Daughterboard assembly number : 73-11933-04
Daughterboard serial number : FOC18444UYD
System serial number : FOC1845Y3SP
Top Assembly Part Number : 800-30945-04
Top Assembly Revision Number : F0
Version ID : V04
CLEI Code Number : COMGE00ARD
Daughterboard revision number : A0
Hardware Board Revision Number : 0x01


Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 28 WS-C2960S-24PS-L 15.2(2)E9 C2960S-UNIVERSALK9-M


Configuration register is 0xF

Yes, perhaps  - not sure is this means you have a TAR file.

you have not posted the below output :

#dir 

#show run

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Cisco2960-s#dir
Directory of flash:/

2 -rwx 34 Jan 2 2006 00:02:36 +00:00 pnp-tech-time
3 -rwx 10867 Jan 2 2006 00:02:38 +00:00 pnp-tech-discovery-summary
4 -rwx 3782 Jan 18 2022 00:30:40 +00:00 startup-config.bak
5 -rwx 10264 Jan 2 2006 00:00:52 +00:00 multiple-fs
6 drwx 512 Jan 9 2022 15:39:04 +00:00 c2960s-universalk9-mz.152-2.E9
672 -rwx 1920 Jan 2 2006 00:00:52 +00:00 private-config.text
673 -rwx 99 Jan 3 2006 22:32:47 +00:00 express_setup.debug
674 -rwx 2019 Jan 2 2006 00:00:52 +00:00 config.text

57931776 bytes total (35276800 bytes free)

Cisco2960-s#sh run
Building configuration...

Current configuration : 3313 bytes
!
! Last configuration change at 00:00:46 UTC Mon Jan 2 2006
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco2960-s
!
boot-start-marker
boot-end-marker
!
enable secret 5 *****.
enable password ****
!
no aaa new-model
switch 1 provision ws-c2960s-24ps-l
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-*****
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-*****
revocation-check none
rsakeypair TP-self-signed-****
!
!
crypto pki certificate chain TP-self-signed-*****
certificate self-signed 01
****
quit
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
no ip address
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
ip address 192.168.1.45 255.255.255.0
shutdown
!
ip http server
ip http secure-server
!
!
!
!
line con 0
line vty 0 4
password *****
login
line vty 5 15
password *****
login
!
end

 

Vlan1 shutdown? Maybe I´m doing something wrong...

Drug_Store
Beginner
Beginner

flash:/c2960s-universalk9-mz.152-2.E9/c2960s-universalk9-mz.152-2.E9.bin

 

if I reset it, I can see it in my network as 192.168.1.40, and I can actually open a browser and asks for user/pass, which nothing works since I didn´t define it yet. After start the system configuration by CLI and trying to define it to 192.168.1.45 with my password, never get to see him my network afterwards.

Add this Lines  and test it

username cisco privilege 15 password cisco123   <---- whatever username and password you looking to use

aaa new-model
aaa authentication login default local
aaa authorization exec default local

ip http server
ip http authentication local

 

EDIT : just observer your vlan interface down, 

config t

!

interface vlan 1

no shutdown

!

end

 

connect one of the ports and check from the console is the vlan up, configure the PC with 192.168.1.X, and ping Switch IP, if you ping then try GUI.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Still no success

Can you tell me step by step, how to config it from the reset state?

 

Thank you very much

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers