cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1251
Views
0
Helpful
2
Replies

Cisco 2960S(LanLite) Port Aggregation to 2 (Cisco SMB 300 Series Switches)

levi.rogers
Level 1
Level 1

I am currently trying to setup my new cisco switches.

What I am trying to do:

I have 2 SMB 300's which are "access" switches.  Essentially the drops come down into these switches.  I also have a backbone switch which sets in my server racks.  In order to ensure maximum capacity between the backbone switch and the access switches I wanted to use Port Aggregation.  8 ports from each access switch make each trunk going to the backbone switch.  I can link the two access switches together and everything works fine, however, when I hookup the backbone switch I see a large amount of packet loss, dropped connections etc.

About me:

Just really brief to give you an idea of what you are dealing with, I am very new to cisco.  I am not a complete dolt but some of the innerworkings of the Cisco IOS through me for a loop.  Any help on this matter would be greatly appreciated.

Included:

A copy of the 2960 config, and a copy of one of the 300 configs.

2960 Config:


COREKNYNOR_001#show config
Using 3864 out of 524288 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname COREKNYNOR_001
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$o6oi$SJIPCEVG3z4SSeTE.9n01/
!
!
!
no aaa new-model
clock timezone UTC -6
clock summer-time UTC recurring
authentication mac-move permit
ip subnet-zero
!
!
!
!
crypto pki trustpoint TP-self-signed-2877403904
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2877403904
revocation-check none
rsakeypair TP-self-signed-2877403904
!
!
crypto pki certificate chain TP-self-signed-2877403904
certificate self-signed 01 nvram:IOS-Self-Sig#3434.cer
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
interface Port-channel1
!
interface Port-channel2
!
interface FastEthernet0
no ip address
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface GigabitEthernet0/29
!
interface GigabitEthernet0/30
!
interface GigabitEthernet0/31
!
interface GigabitEthernet0/32
!
interface GigabitEthernet0/33
description trunkAcc2
channel-group 1 mode desirable
!
interface GigabitEthernet0/34
description trunkAcc2
channel-group 1 mode desirable
!
interface GigabitEthernet0/35
description trunkAcc2
channel-group 1 mode desirable
!
interface GigabitEthernet0/36
description trunkAcc2
channel-group 1 mode desirable
!
interface GigabitEthernet0/37
description trunkAcc2
channel-group 1 mode desirable
!
interface GigabitEthernet0/38
description trunkAcc2
channel-group 1 mode desirable
!
interface GigabitEthernet0/39
description trunkAcc2
channel-group 1 mode desirable
!
interface GigabitEthernet0/40
description trunkAcc2
channel-group 1 mode desirable
!
interface GigabitEthernet0/41
description trunkAcc1
channel-group 2 mode desirable
!
interface GigabitEthernet0/42
description trunkAcc1
channel-group 2 mode desirable
!
interface GigabitEthernet0/43
description trunkAcc1
channel-group 2 mode desirable
!
interface GigabitEthernet0/44
description trunkAcc1
channel-group 2 mode desirable
!
interface GigabitEthernet0/45
description trunkAcc1
channel-group 2 mode desirable
!
interface GigabitEthernet0/46
description trunkAcc1
channel-group 2 mode desirable
!
interface GigabitEthernet0/47
description trunkAcc1
channel-group 2 mode desirable
!
interface GigabitEthernet0/48
description trunkAcc1
channel-group 2 mode desirable
!
interface GigabitEthernet0/49
!
interface GigabitEthernet0/50
!
interface Vlan1
ip address 192.168.xxx.xxx 255.255.xxx.xxx
!
ip default-gateway 192.168.xxx.xxx
ip http server
ip http secure-server
!
banner login ^C Access for authorized users only.  Please enter your username and password. ^C
banner motd ^C  Please contact Admin for questions regarding the setup of this switch. ^C
!
line con 0
line vty 0 4
password 7 034C1142321A314342084C5756584A
login
line vty 5 15
password 7 145F584238113A2428296667635946
login
!
end

300 Config:


interface port-channel 1
description CORE_TRUNK_2
exit
interface range ethernet g(41-48)
description CORE_TRUNK_2
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
interface range ethernet g(41-48)
channel-group 1 mode on
exit
interface vlan 1
ip address 192.168.xxx.xxx 255.255.xxx.xxx
exit
ip default-gateway 192.168.xxx.xxx
interface vlan 1
no ip address dhcp
exit
bonjour service enable csco-sb
bonjour service enable http  
bonjour service enable https 
bonjour service enable ssh   
bonjour service enable telnet
hostname ACCESS2KNYNOR
username cisco password cc8d1b658aa0970b3ca367cdb7ccd7a858b6851c level 15 encrypted
no snmp-server enable
snmp-server location KRNY_NOR
snmp-server contact "ADMIN"
clock timezone -6
clock summer-time recurring usa

I feel like I might have something set wrong on one side or the other with what type of etherchannel it is looking for and the mode that it is set in.  Any help on this matter would be greatly appreciated, also if you could give a little direction on the appropriate commands to make any necessary changes I wouldn't dislike you by any means.

Cheers! 

1 Accepted Solution

Accepted Solutions

glen.grant
VIP Alumni
VIP Alumni

  You have the channel settings incorrect .  On one switch you have them set as desirable and on the other it is forced "on" .  This won't work . Both sides have to match.  Not knowing what the "300" is capable of you should just force both sides as on .  The 2960 should not be desirable if the other switch does not have the capability of negotiating the etherchannel. Make the 2960 channel-group X mode on also .   That is also the issue with forcing channels on if both sides are not exactly the same  and in your config they are not you can blackhole the traffic and cause all sorts of issues.

View solution in original post

2 Replies 2

glen.grant
VIP Alumni
VIP Alumni

  You have the channel settings incorrect .  On one switch you have them set as desirable and on the other it is forced "on" .  This won't work . Both sides have to match.  Not knowing what the "300" is capable of you should just force both sides as on .  The 2960 should not be desirable if the other switch does not have the capability of negotiating the etherchannel. Make the 2960 channel-group X mode on also .   That is also the issue with forcing channels on if both sides are not exactly the same  and in your config they are not you can blackhole the traffic and cause all sorts of issues.

First off I am going to mark this as correct simply because what you say makes sense.  If I try it and that does not work I will post back.

See this from the switch notes:

EtherChannel On Mode
EtherChannel on mode can be used to manually configure an EtherChannel. The on mode forces a port
to join an EtherChannel without negotiations. The on mode can be useful if the remote device does not
support PAgP or LACP. In the on mode, a usable EtherChannel exists only when the switches at both
ends of the link are configured in the on mode.
Ports that are configured in the on mode in the same channel group must have compatible port
characteristics, such as speed and duplex. Ports that are not compatible are suspended, even though they
are configured in the on mode.
Caution You should use care when using the on mode. This is a manual configuration, and ports on both ends of
the EtherChannel must have the same configuration. If the group is misconfigured, packet loss or
spanning-tree loops can occur.

How do I avoid this, is there a best practice?  Storm Control?

Review Cisco Networking for a $25 gift card