cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1282
Views
0
Helpful
10
Replies

EIGRP load balancing

david.sua
Level 1
Level 1

Hi all!

I have a doubt about load balancing with EIGRP in a particular scenario.

This is the scenario,

   RCentral

    |          \

    |           \

    |            \

    |             \

R1----LAN----R2

I have a VDSL2 (Dialer1) between RCentral and R1 and I have two VDSL2 (Dialer2 and Dialer3) between RCentral and R2

R1 ends PPPoE Sessions

I would like load balance between R1 and R2 but routes only points via Dialer1. However, I can see both routes into R1 topology table via Dialer1 and via R2

This is the output,

R1#sh ip ro 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "eigrp 10", distance 170, metric 983552, candidate default path, type external
  Redistributing via eigrp 10
  Last update from 10.20.116.1 00:00:02 ago
  Routing Descriptor Blocks:
  * 10.20.116.1, from 10.20.116.1, 00:00:02 ago
      Route metric is 983552, traffic share count is 1
      Total delay is 5090 microseconds, minimum bandwidth is 3000 Kbit
      Reliability 255/255, minimum MTU 1492 bytes
      Loading 6/255, Hops 1

R1#sh ip eigrp topology 0.0.0.0/0
IP-EIGRP (AS 10): Topology entry for 0.0.0.0/0
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 983552
  Routing Descriptor Blocks:
  10.20.116.1 (Dialer1), from 10.20.116.1, Send flag is 0x0
      Composite metric is (983552/130304), Route is External
      Vector metric:
        Minimum bandwidth is 3000 Kbit
        Total delay is 5090 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1492
        Hop count is 1
      External data:
        Originating router is 1.1.1.1
        AS number of route is 0
        External protocol is Static, external metric is 0
        Administrator tag is 0 (0x00000000)
        Exterior flag is set
  192.168.116.2 (FastEthernet0/0.1), from 192.168.116.2, Send flag is 0x0
      Composite metric is (986112/983552), Route is External
      Vector metric:
        Minimum bandwidth is 3000 Kbit
        Total delay is 5190 microseconds
        Reliability is 255/255
        Load is 47/255
        Minimum MTU is 1492
        Hop count is 2
      External data:
        Originating router is 1.1.1.1
        AS number of route is 0
        External protocol is Static, external metric is 0
        Administrator tag is 0 (0x00000000)
        Exterior flag is set

My first objective is have a 50% sharing between R1 and R2.

But i would like if its possible a route table like this

R1 routing table,

Dialer1    33%

R2          66%

Somebody could help me, please?

Thanks in advance

1 Accepted Solution

Accepted Solutions

It looks as if we initially missed an important detail: the feasibilty condition must be met.

This requires the reported distance of any alternative route to be lower than the FD.

Only when this requirement is met, a route is considered for load balancing. It is in the text though:

" EIGRP includes all routes that have a metric of less than or equal to X and satisfy the feasibility condition."

Knowing this, I succeeded in creating a load balanced path via R2.

To achieve this, I lowered the delay (used in metric calculation) to 19900 usec. This compensates for the 100 usec delay on the fast-ethernet link between R1 and R2 and result in a suitable metric for demonstration of the case.

R1#sh ip ro 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "eigrp 10", distance 170, metric 1390848, candidate default path, type external
  Redistributing via eigrp 10
  Last update from 192.168.116.2 on FastEthernet0/0, 00:09:45 ago
  Routing Descriptor Blocks:
    192.168.116.2, from 192.168.116.2, 00:09:45 ago, via FastEthernet0/0
      Route metric is 1390848, traffic share count is 1
      Total delay is 21000 microseconds, minimum bandwidth is 3000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2
  * 10.20.116.1, from 10.20.116.1, 00:09:45 ago, via Serial1/1
      Route metric is 1390848, traffic share count is 1
      Total delay is 21000 microseconds, minimum bandwidth is 3000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

R1#

R1#sh ip eigrp topo 0.0.0.0
IP-EIGRP (AS 10): Topology entry for 0.0.0.0/0
  State is Passive, Query origin flag is 1, 2 Successor(s), FD is 1390848
  Routing Descriptor Blocks:
  10.20.116.1 (Serial1/1), from 10.20.116.1, Send flag is 0x0
      Composite metric is (1390848/281600), Route is External
      Vector metric:
        Minimum bandwidth is 3000 Kbit
        Total delay is 21000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 10.1.1.1
        AS number of route is 0
        External protocol is Static, external metric is 0
        Administrator tag is 0 (0x00000000)
        Exterior flag is set
  192.168.116.2 (FastEthernet0/0), from 192.168.116.2, Send flag is 0x0
      Composite metric is (1390848/1388288), Route is External
      Vector metric:
        Minimum bandwidth is 3000 Kbit
        Total delay is 21000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 2
      External data:
        Originating router is 10.1.1.1
        AS number of route is 0
        External protocol is Static, external metric is 0
        Administrator tag is 0 (0x00000000)
        Exterior flag is set
R1#

R2#sh run int s1/2
Building configuration...

Current configuration : 120 bytes
!
interface Serial1/2
bandwidth 3000
ip address 10.20.116.10 255.255.255.248
delay 1990
serial restart-delay 0
end

Please note the delay is specified in tens of microsec's.

regards,

Leo

View solution in original post

10 Replies 10

rich_foster
Level 1
Level 1

Try changing the EIGRP variance under the EIGRP router process.

You could manipulate the metrics, and therefore the load distribution by changing the delay under the interfaces.

variance is 2

router eigrp 10
variance 2
redistribute connected
network 10.20.116.0 0.0.0.255
network 192.168.116.0
no auto-summary

but i think that problem is with hop count, because the metric is inside variance multiplier.

lgijssel
Level 9
Level 9

The following link describes eigrp load balancing over unequal paths.

Variance is the key:

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009437d.shtml

regards,

Leo

But variance is OK,

As you can view, in R2 that has two Dialers load balancing works well

R2#sh ip ro 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "eigrp 10", distance 170, metric 983552, candidate default path, type external
  Redistributing via eigrp 10
  Last update from 10.20.116.9 01:16:10 ago
  Routing Descriptor Blocks:
  * 10.20.116.9, from 10.20.116.9, 01:16:10 ago
      Route metric is 983552, traffic share count is 1
      Total delay is 5090 microseconds, minimum bandwidth is 3000 Kbit
      Reliability 255/255, minimum MTU 1492 bytes
      Loading 45/255, Hops 1
    10.20.116.5, from 10.20.116.5, 01:16:10 ago
      Route metric is 983552, traffic share count is 1
      Total delay is 5090 microseconds, minimum bandwidth is 3000 Kbit
      Reliability 255/255, minimum MTU 1492 bytes
      Loading 45/255, Hops 1

How are you getting the default routes into eigrp?

Looks to me as if R1 is learning the default route from R2 but is not advertising it's own in eigrp.

Please check if the command 'redistribute static' is configured on both routers.

regards,

Leo

Default route is advertised via RCentral.

RCentral#sh ip ro 0.0.0.0

Routing entry for 0.0.0.0/0, supernet

  Known via "static", distance 1, metric 0, candidate default path

  Redistributing via eigrp 10, eigrp 100

  Advertised by eigrp 10 route-map redistatic

                eigrp 100 route-map redistaticas100

  Routing Descriptor Blocks:

  MyGW_IP, via GigabitEthernet0/1

      Route metric is 0, traffic share count is 1

You are correct in that there is no alternative route on R1

R1#sh ip eigrp topology 0.0.0.0/0
IP-EIGRP (AS 10): Topology entry for 0.0.0.0/0
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 983552

This implies no other route is considered as an alternative for as long as this route is available.

This may very well be due to the hop count like you suspect.

Still an interesting question, I will do some investigations and get back if I find a solution.

regards,

Leo

It looks as if we initially missed an important detail: the feasibilty condition must be met.

This requires the reported distance of any alternative route to be lower than the FD.

Only when this requirement is met, a route is considered for load balancing. It is in the text though:

" EIGRP includes all routes that have a metric of less than or equal to X and satisfy the feasibility condition."

Knowing this, I succeeded in creating a load balanced path via R2.

To achieve this, I lowered the delay (used in metric calculation) to 19900 usec. This compensates for the 100 usec delay on the fast-ethernet link between R1 and R2 and result in a suitable metric for demonstration of the case.

R1#sh ip ro 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "eigrp 10", distance 170, metric 1390848, candidate default path, type external
  Redistributing via eigrp 10
  Last update from 192.168.116.2 on FastEthernet0/0, 00:09:45 ago
  Routing Descriptor Blocks:
    192.168.116.2, from 192.168.116.2, 00:09:45 ago, via FastEthernet0/0
      Route metric is 1390848, traffic share count is 1
      Total delay is 21000 microseconds, minimum bandwidth is 3000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2
  * 10.20.116.1, from 10.20.116.1, 00:09:45 ago, via Serial1/1
      Route metric is 1390848, traffic share count is 1
      Total delay is 21000 microseconds, minimum bandwidth is 3000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

R1#

R1#sh ip eigrp topo 0.0.0.0
IP-EIGRP (AS 10): Topology entry for 0.0.0.0/0
  State is Passive, Query origin flag is 1, 2 Successor(s), FD is 1390848
  Routing Descriptor Blocks:
  10.20.116.1 (Serial1/1), from 10.20.116.1, Send flag is 0x0
      Composite metric is (1390848/281600), Route is External
      Vector metric:
        Minimum bandwidth is 3000 Kbit
        Total delay is 21000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 10.1.1.1
        AS number of route is 0
        External protocol is Static, external metric is 0
        Administrator tag is 0 (0x00000000)
        Exterior flag is set
  192.168.116.2 (FastEthernet0/0), from 192.168.116.2, Send flag is 0x0
      Composite metric is (1390848/1388288), Route is External
      Vector metric:
        Minimum bandwidth is 3000 Kbit
        Total delay is 21000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 2
      External data:
        Originating router is 10.1.1.1
        AS number of route is 0
        External protocol is Static, external metric is 0
        Administrator tag is 0 (0x00000000)
        Exterior flag is set
R1#

R2#sh run int s1/2
Building configuration...

Current configuration : 120 bytes
!
interface Serial1/2
bandwidth 3000
ip address 10.20.116.10 255.255.255.248
delay 1990
serial restart-delay 0
end

Please note the delay is specified in tens of microsec's.

regards,

Leo

Hi

Remember one thing the Routing protocol is only used to intalled the best route.

the Load balancing is done by the switching process. if you have a multiple path

in your network it does not means that you are doing load balancing.

Also check the switching in your topolog.

check the Eigrp section on TCP/IP jeff doyle it will help you more.

Thank you lgijssel, delay was the solution!

Review Cisco Networking products for a $25 gift card