08-30-2013 02:17 AM - edited 03-07-2019 03:13 PM
Hi All,
I have encounted an problem that currently has me stumped. I am trying to configure a 3750 switch with ipservices for use as a small localised test bed for wireless. what i am planning to implement is:
1 x 3750 PoE switch with 3 vlans
1 x WLC
1 x Access Point
1 x Laptop
My problems currently are occuring on the switch with DHCP and Routing. I have tried to implement a local DHCP service on the switch for use by the access point management to obtain their IPs, for wireless data and for laptops to obtain an IP.
My problem occurs when DHCP issues a ip address. when issusing a Show ip dhcp bindings i see an IP issued to a device and MAC. but the device fails to obtain an IP address.
I am also unable to ping between vlan as well.
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
!
no aaa new-model
switch 1 provision ws-c3750x-48p
system mtu routing 1500
ip routing
!
ip dhcp excluded-address 192.168.1.1 192.168.1.10
ip dhcp excluded-address 192.168.2.1 192.168.2.10
ip dhcp excluded-address 192.168.3.1 192.168.3.10
!
ip dhcp pool wireless_management
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1 255.255.255.0
option 43 ascii 192.168.1.5
option 60 ascii Cisco AP c1550
domain-name stevenson.local
!
ip dhcp pool laptop_data
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1 255.255.255.0
domain-name stevenson.local
!
ip dhcp pool wireless_data
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
domain-name stevenson.local
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
vlan internal allocation policy ascending
interface GigabitEthernet1/0/1
description wireless controller
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/5
description laptop
switchport access vlan 30
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/11
description wireless access point
switchport access vlan 10
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/12
switchport access vlan 10
switchport mode access
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.1.2 255.255.255.0
!
interface Vlan20
ip address 192.168.2.2 255.255.255.0
!
interface Vlan30
ip address 192.168.3.2 255.255.255.0
!
router rip
version 2
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
no auto-summary
!
ip http server
ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.2.0
!
!
!
!
!
line con 0
line vty 5 15
!
end
08-30-2013 03:23 AM
Hi there.
If you look at the DHCP config for laptops you have a default router as 192.168.3.1.
Your vlan ip address is 192.168.3.2
The DHCP scope gives a default gateway for data as 192.168.3.1 rather than the VLAN IP address of 192.168.3.2
I would recommend changing the DHCP scope default router to 192.168.3.2 from 192.168.2.1 OR change your VLAN IP address to match the DHCP scope.
Sent from Cisco Technical Support iPad App
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide