07-28-2022 08:53 AM - edited 07-28-2022 09:20 AM
Good afternoon, we have a 1Gb/s internet circuit, which, for reasons we fully understand often gets fully utilised due to business need.
All switches are 9300s' running 17.6.3
We dont currently have a QoS policy on the wired network (Wireless is another matter)
During times of peak congestion, we have MS Teams Audio/Video issues, and thus was to implement a basic policy to
A) Mark traffic at the access port, only for MS Teams
B) Prioritise traffic on DSCP value at the WAN edge.
C) All other traffic will be marked down to DSCP default inbound/outbound
We dont intend to do any priority queueing upstream from access to core as links are in 20Gb/s etherchannel and utilisation never goes above 10%, plus DSCP is honoured by default on the 9300 platform.
Core switch is connected via LAG to our edge firewalls, which terminate the 1Gb/s WAN circuit.
Would anyone be able to state whether this looks reasonable please?
Access Switch - Class Maps
class-map match-any ms-teams-audio
match protocol ms-teams-audio
!
class-map match-any ms-teams-video
match protocol ms-teams-video
!
class-map match-any ms-teams-share
match protocol ms-teams-app-sharing
Access Switch - Policy Map
policy-map ms-teams-access-port
class ms-teams-audio
set dscp ef
class ms-teams-video
set dscp af41
class ms-teams-share
set dscp af21
class class-default
set dscp default
Access Switch - Interface
interface GigabitEthernet1/0/1
switchport access vlan 100
switchport mode access
spanning-tree portfast
service-policy input ms-teams-access-port
service-policy output ms-teams-access-port
Core Switch - Class Maps
class-map match-any ms-teams-audio-dscp
match dscp ef
!
class-map match-any ms-teams-video-dscp
match dscp af41
!
class-map match-any ms-teams-share-dscp
match dscp 21
Core Switch - Policy Maps
policy-map ms-teams-wan-outbound
class ms-teams-audio-dscp
priority level 1
police rate percent 10
class ms-teams-video-dscp
priority level 2
police rate percent 20
class ms-teams-share-dscp
bandwidth remaining percent 15
queue-buffers ratio 15
class class-default
bandwidth remaining percent 25
queue-buffers ratio 25
Core Switch - WAN Uplink
interface Port-channel1
switchport access vlan 4093
switchport mode access
switchport nonegotiate
service-policy output ms-teams-wan-outbound
07-28-2022 11:06 PM
07-29-2022 05:30 AM
Thank you for your completely useless answer.
I don’t wish to use AutoQos, i have no intent on classifying, marking or prioritising any other traffic apart from MS Teams, you haven’t even taken note of my comments.
02-13-2023 11:04 AM
I'm having the same issue as well, did your configurations work?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide