Showing results for 
Search instead for 
Did you mean: 

Cisco Catalyst WS-C2960S-48TD-L + SFP-10G-SR-AX issues

Daniel Boling

I ordered 2 WS-C2960S-48TD-L switches

I also ordered the Axiom equivelent to the SFP-10G-SR (SFP-10G-SR-AX) per the 10-Gigabit Ethernet Transceiver Modules Compatibility Matrix (

I have tested this issue with both the c2960s-universalk9-mz.122-55.SE5 and c2960s-universalk9-mz.150-2.SE2 (currently loading c2960s-universalk9-mz.122-55.SE5).

When inserting the SFP+ module, I am presented with the following:

*Mar  1 00:16:00.831: %GBIC_SECURITY_CRYPT-4-VN_DATA_CRC_ERROR: GBIC in port Gi1/0/49 has bad crc

*Mar  1 00:16:00.831: %PM-4-ERR_DISABLE: gbic-invalid error detected on Gi1/0/49, putting Gi1/0/49 in err-disable state

The first thing I noticed was that the output was related to Gi1/0/49, which is the other incorrect combo port for the 10GB transceiver modle.  I ran the following commands:

Switch(config)# service unsupported-transceiver
Switch(config)# no errdisable detect cause gbic-invalid

After running the commands, I am still getting the following:

*Mar  1 00:28:25.000: %GBIC_SECURITY_CRYPT-4-VN_DATA_CRC_ERROR: GBIC in port Gi1/0/49 has bad crc

With the above configurations present, or otherwise, the following is shown with the SFP+ module inserted:

Switch#sh ip int g1/0/49

GigabitEthernet1/0/49 is down, line protocol is down (notconnect)

  Hardware is Gigabit Ethernet, address is c062.6bbd.1f31 (bia c062.6bbd.1f31)

Switch#sh int t1/0/1

TenGigabitEthernet1/0/1 is down, line protocol is down (notconnect)

  Hardware is not present

Removing the SFP+ module:

Switch#sh int g1/0/49

GigabitEthernet1/0/49 is down, line protocol is down (notconnect)

  Hardware is not present

Switch#sh int t1/0/1

TenGigabitEthernet1/0/1 is down, line protocol is down (notconnect)

  Hardware is Ten Gigabit Ethernet, address is c062.6bbd.1f33 (bia c062.6bbd.1f33)

Why does the 10GB SFP+ module persuade the switch to mark the T1/0/1 interface as "Hardware Not Present", and choose the G1/0/49 port instead?


5 Replies 5

Leo Laohoo
Hall of Fame
Hall of Fame

Hi Daniel,

Sorry to say that the Axiom-branded module may not work because the IDPROM inside has a MD5 code which does not match the Cisco's code check.  This is why the port went into error-disable.  This behaviour is normal when you use a non-Cisco branded module.

I said "may not" because I've seen a post by another person who got the manufacturer of the SFP/SFP+ to reflash the module's IDPROM in order to fool the appliance.

Thanks for the reply.  I have an email out to Axiom about this, and will follow up with any information they give me. 

The description from TechData:

"...Every Axiom SFP (mini-GBIC) transceiver module is designed and tested to be 100% compatible with Cisco products and is pre-configured with Cisco specific application code required for Cisco IOS and SMARTnet compliance. Axiom transceivers are tested to perform functionally identical to the "original" transceiver..."


The reply from Axiom is a "standard" email response from a non-technical person.  I'm suspicious that Axiom is not aware of Cisco's appliance performs a MD5 hash calculation when a module is inserted.

I contacted techsupport@axiommemory.comat 4:50 CST and received an e-mail within 5 minutes about the issue.  Axiom Tech Support asked for the "lot numbers" on the SFP+ modules, and told me the ones I have might have an older firmware revision that is not compatible with the switches.  I provided shipping information and had the replacements first thing this morning for my project. 

The replacements worked.  For reference, the 5-digit number on one of the old modules is "#30638", and one of the new ones is "#30896".

I want to say the Axiom support technician almost knew exactly what the issue was, and proceeded with a sense of urgency according to my immediate project.  Because of this, I will continue to use them in the future.  I think the biggest thing to take away from this issue, is to watch out when ordering these products from distributors who purchase thousands at once, selling you equipment that is years old.

Thank you leolaohoo for your input


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: