cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
461
Views
15
Helpful
8
Replies
johnlloyd_13
Engager

Cisco N5k enable 'feature fex'

hi,

i'll be installing N2K copper modules and patch 10G fiber uplinks to a pair of parent N5K.

my question is, is it required to enable 'feature fex' just to confirm the N2K has connectivity/discovered by parent N5K?

or would it show as 'discovered' by the parent N5K even without applying 'feature fex'.

i just need to verify it's being detected/discovered by the parent N5K after installed, powered on and patched. there's no further provisioning yet.

1 ACCEPTED SOLUTION

Accepted Solutions

Hi John,

one last question, can i just patch a single fiber uplink to a single parent N5K and the N2K would still be able to download its image?

That should not be an issue. As soon as the FEX comes online, it will download the OS from the parent switch.

HTH

View solution in original post

8 REPLIES 8
marce1000
VIP Mentor

 

           >...or would it show as 'discovered' by the parent N5K even without applying 'feature fex'.

 I would simply examine the logs ( show logging)  when connecting and look for info's concerning this

 M.

Reza Sharifi
Hall of Fame Expert

Hi,

Yes, the command is feature-set fex.

Once enabled and configured, you can verify with "show fex x" and/or "show fex x details"

 

HTH

hi reza,

thanks! i believe the newer NX-OS command is 'feature fex'

does the 'fex associate' and 'vpc' number needs to be the same or not?

 

interface Eth1/30
description *** FEX100 - CORE RACK ***
switchport mode fex-fabric
fex associate 100     <<< WE WANT PORT NUMBERING STARTS WITH 100, Eth100/1/1
channel-group 111   <<< PORT-CHANNEL 100 IS ALREADY TAKEN

 

interface port-channel111
description *** FEX100 - CORE RACK ***
switchport mode fex-fabric
fex associate 100
vpc 111    <<< VPC 100 IS ALREADY TAKEN

 

Hi John,

does the 'fex associate' and 'vpc' number needs to be the same or not?

No, you can use different numbers, but for consistency and ease of management, I always use the same number for VPC, FEX, and PO where possible.

HTH

hi reza,

thanks! it's good to have consistent/same numbers but like i said port-channel 100 and VPC 100 were already taken so i need to use another number.

hi reza,

one last question, can i just patch a single fiber uplink to a single parent N5K and the N2K would still be able to download its image?

i want to upgrade the N2K while waiting for additional 10G SFP and MM fiber to arrive.

Hi John,

one last question, can i just patch a single fiber uplink to a single parent N5K and the N2K would still be able to download its image?

That should not be an issue. As soon as the FEX comes online, it will download the OS from the parent switch.

HTH

balaji.bandi
VIP Guru

Make sure you have right Nexus code to support FEX with compatable :

 

below config will help you :

 

install feature-set fex
feature-set fex
!Fex Config
fex 100
pinning max-links 1
!Fex provisioning
slot 100
provision model N2K-C2248TP-E-1GE
!Interface config
interface Ethernet1/10
switchport mode fex-fabric
fex associate 100
channel-group 100
!port channel associated with FEX
interface port-channel00
switchport mode fex-fabric
fex associate 100
vpc 100
!

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help