11-07-2016 12:17 AM - edited 03-08-2019 08:03 AM
Hi All,
i have Cisco Router 1941 connected to HP switch, all users using default vlan (Vlan1), the interface configuration between the Cisco router and HP switch as follows:
interface Gig0/0
ip address 192.168.8.1 255.255.255.0 secondary
ip address 192.168.9.1 255.255.255.0 secondary
ip address 192.168.10.1 255.255.255.0 secondary
ip address 192.168.11.1 255.255.255.0
i am planning to use router in stick feature to replace vlan 1 and configure vlan layer 2 for each subnet on HP switch for example:
Vlan 2 for this ip address 192.168.8.1 255.255.255.192 secondary
Vlan 3 for this ip address 192.168.9.1 255.255.255.192 secondary
Vlan 4 for this ip address 192.168.10.1 255.255.255.192 secondary
Vlan 5 for this ip address 192.168.11.1 255.255.255.0
how can achieve this on Cisco router and HP switch?
Thanks,
Solved! Go to Solution.
11-08-2016 09:10 AM
It should tag , what type of HP switch is it ?
you just need to set it to full trunk on HP side pure layer 2 , need to know the model first as it varys on some there switches from what I remember
11-08-2016 09:17 AM
Hi
Procurve(config)#vlan 8
Procurve(config)#name “Data”
Procurve(config)#tagged 48Procurve(config)#vlan 9
Procurve(config)#name “Voice”
Procurve(config)#tagged 48
11-07-2016 12:25 AM
Hi the vlans would just need to be created on HP switch and set the uplink to the router as a trunk , then on Cisco side follow this docs below shows example of setting up multi vlan router on stick from cisco router , as long as both sides are dot1q it should form
http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/336-cisco-router-8021q-router-stick.html
https://community.spiceworks.com/how_to/55605-how-to-configure-router-on-a-stick
11-08-2016 08:49 AM
Hi Mark,
Thanks for providing me the link, i know how do it on Router but the problem what the configuration will be in HP switch,
On the router will configure as follows:
R1(config)#int fa0/0
R1(config-if)#no ip address
R1(config-if)#no shutdown
R1(config-if)#exit
Now we can configure the sub-interfaces on the router.
We will start with VLAN 8.
R1(config)#int fa0/0.8
R1(config-subif)#encapsulation dot1q 8
R1(config-subif)#ip address 192.168.8.1 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit
Now VLAN 9
R1(config)#int fa0/0.9
R1(config-subif)#encapsulation dot1q 9
R1(config-subif)#ip address 192.168.9.1 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit
VLAN 10
R1(config)#int fa0/0.10
R1(config-subif)#encapsulation dot1q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit
Now VLAN 11
R1(config)#int fa0/0.11
R1(config-subif)#encapsulation dot1q 11
R1(config-subif)#ip address 192.168.11.1 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit
so what is the link configuration between HP switch and Cisco Router, and L2 vlan on HP switch will tag or untag?
any one can have idea how to do it on HP switch?
11-08-2016 09:10 AM
It should tag , what type of HP switch is it ?
you just need to set it to full trunk on HP side pure layer 2 , need to know the model first as it varys on some there switches from what I remember
11-14-2016 05:05 AM
Thanks it works now
11-08-2016 09:17 AM
Hi
Procurve(config)#vlan 8
Procurve(config)#name “Data”
Procurve(config)#tagged 48Procurve(config)#vlan 9
Procurve(config)#name “Voice”
Procurve(config)#tagged 48
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide