cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7658
Views
10
Helpful
12
Replies
Tommy Svensson
Beginner

Configure internal trunk from HWIC-4ESW to Cisco 1941

Hi.

First of all:
How do i configure the HWIC-4ESW module to internal trunk to one of the interfaces on the Cisco 1941 router?

Second:

I got the module today and realized it was only layer 2 funcionality. If i get this trunk to work and connect another router to the HWIC-4ESW, is it possible to do this whitout having to configure the link to router2 a trunk link to?

Just creating a subinterface on lets say interface gigabit 0/0.1
ip add 192.168.1.1 255.255.255.0

If i connect the second router to a interface on the switchmodule and not doing any trunking on that link, it should work right?
After all it is on native VLAN 1.

Hope i made myself unterstandable.

Regards Tommy Svensson

1 ACCEPTED SOLUTION

Accepted Solutions

Dear Tommy ,

Internal trunk means ,creating a trunk link between one existing interface of 1941 and WIC-4ESW card .Can you try the below config. This is how you can create an internal trunk between F0/1 interface and 4ESW card . I dont have a 1941 +4ews card otherwise i would have tested this on my lab

interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1
description vlan1
encapsulation dot1Q 1
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/1.2
description vlan 2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0

!
interface FastEthernet0/0/0
switchport access vlan 1
!
interface FastEthernet0/0/1
switchport access vlan 2
!
interface FastEthernet0/0/2
description ***TRUNK***
switchport mode trunk

View solution in original post

12 REPLIES 12
Haris P
Enthusiast

Dear Tommy ,

I have the below config . Like this you can connect VLAN 1 to Router 1 and VLAN2 to Router 2 . Is this OK with you ?

interface FastEthernet0/0/0
switchport access vlan 1
!
interface FastEthernet0/0/1
switchport access vlan 2
!
interface FastEthernet0/0/2
switchport access vlan 3
!
interface FastEthernet0/0/3
switchport access vlan 4

interface Vlan1
ip address 192.168.1.1 255.255.255.0

!

interface Vlan2
ip address 192.168.2.1 255.255.255.0
!
interface Vlan3
ip address 192.168.3.1 255.255.255.0
!
interface Vlan4
ip address 192.168.4.1 255.255.255.0

Yes that looks fine, but where does the routing between VLANs take place? I heard that the switch module have capabilities of an internal trunk link and i would like to know how to configure that so that i can route between these VLANs.

Regards Tommy Svensson

Dear Tommy ,

Internal trunk means ,creating a trunk link between one existing interface of 1941 and WIC-4ESW card .Can you try the below config. This is how you can create an internal trunk between F0/1 interface and 4ESW card . I dont have a 1941 +4ews card otherwise i would have tested this on my lab

interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1
description vlan1
encapsulation dot1Q 1
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/1.2
description vlan 2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0

!
interface FastEthernet0/0/0
switchport access vlan 1
!
interface FastEthernet0/0/1
switchport access vlan 2
!
interface FastEthernet0/0/2
description ***TRUNK***
switchport mode trunk

Thank you, that did work just fine. Just a final question. Why would anyone want to buy a module with two routerports instead of this switchmodule when it works like a charm with assigning VLAN and such?

Regards Tommy Svensson

Why would anyone want to buy a module with two routerports instead of this switchmodule

It all depends what you want to achieve and if you've already got a separate switch in your infrastructure or not.

Regards.

Alain.

Don't forget to rate helpful posts.

Dear Tommy,

I'm happy that it worked fine and thanks for rating the post

With VLAN config there are some configuration limitation including Point-to-Point Protocol over Ethernet (PPPOE) termination, Layer 2 Tunneling Protocol Version 3 (L2TPv3) termination, MAC address assignment, Layer 3 QoS, and others ..Also with the trunk config ,its like an "internal router on stick" to allow the communication between vlans (It's not like a L3 switch ) .Also the internal BUS on 4EWSW is limited to 100Mbps

I personally suggest to go for Routed ports for configurations options and performance

Just a little confused on this config. From what I understand, in order to route from the HWIC-4ESW internal 4 port switch to one of the Gigabit ports, you have to treat the internal switch like an external switch. Configure a router on a stick between one of the switch's ports and a Gigabit port.

One port on the switch is configured as a dot1q trunk and a Gigabit port is configured with subinterfaces matching the VLANs on the switch.

1. Can the switch port configured as an internal trunk still be used? Connected to another switch as a trunk? Or is it dedicated as an internal trunk?

2. If I physically connect the switch port configured as an internal trunk to another switch that is not running dot1q, will it connect using the native VLAN?

3. Can the Gigabit port configured with the sub-interfaces be connected to an external service provider?  Can I configure the main interface gi0/0 with an IP address while still having subinterfaces on it? And will this then join the Native VLAN or just ignore VLANs altogether as its part of the router?

Hi.

1. Can the switch port configured as an internal trunk still be used? Connected to another switch as a trunk? Or is it dedicated as an internal trunk?

Any of the gigabit ports can be configured with subinterfaces and such, you can then configure any of the four switchports as TRUNK to another switch or router and it will work just fine. However if the gigabitinterface goes down for some reason all the subinterfaces on that port goes down aswell. The internal trunk is not something you have to configure, it´s there when you plug in your module. Don´t ask me how but when i plugged in the module it worked kind of like i had an external switch and that the internal port is the TRUNK. No cable goes between the switchmodule and the router ports.

2. If I physically connect the switch port configured as an internal trunk to another switch that is not running dot1q, will it connect using the native VLAN?

Yes.

3. Can the Gigabit port configured with the sub-interfaces be connected to an external service provider?  Can I configure the main interface gi0/0 with an IP address while still having subinterfaces on it? And will this then join the Native VLAN or just ignore VLANs altogether as its part of the router?

I have the gigabit port connected to the WAN and it has an external IP address and i can still create sub-interfaces for local subinterfaces.

Regards

The internal trunk is not something you have to configure, it´s there when you plug in your module. Don´t ask me how but when i plugged in the module it worked kind of like i had an external switch and that the internal port is the TRUNK.

I was under the impression that you configured one of the physical ports on the switch as a trunk and by doing this, it would create the internal trunk. Is this one of those things that are so simple that it becomes complicated? Am I looking too hard at it? Is there a special interface assigned to the internal trunk?

Let's say I have fa0/0/0 assigned to VLAN 10, and a subinterface on gi0/0.10 - regular "router on a stick" stuff. Matching IP addresses on the same subnet and gi0/0.10 is the default gateway for VLAN 10. I have interface vlan10 has an IP address on the same subnet. A PC connected to fa0/0/0 would be able to ping gi0/0.10 's IP address and int vlan10? No config to do for the internal trunk?

Hi.

I have not tried that myself but that is what i believe would happen. This is what ive done on my router.

Gig0/0
ip add external IP

Gig0/1
ip add external IP

Gig0/1.1
ip add 192.168.1.1 255.255.255.0

Then i connected a host to Fa0/0/0 and set a static IP address of 192.168.1.50 and it worked like a charm. Got through to my default gateway 192.168.1.1 and through to the Internet without having to configure an internal trunk.

For more than one subinterface i did turn a port on the switchmodule into a TRUNK port and have not tested without turning it into TRUNK mode.

Regards

That's too simple - are you sure this is a Cisco product? LOL!  I'll test out the box this week and report back what I find.

Thanks for your help.

Successful - very simple:

Gi0/0 - external ISP1

Gi0/1 - external ISP2

VLAN 10 - Internal IP gateway.

Worked fine. No router on a stick to do. Auto routed between all three. Did have to set the normal default routes and static routes to get to the ISPs. Here's an example of auto failover between the ISPs. I haven't tested it completely but it gets you going in the right direction.

interface Gi0/1

Description Primary link ISP1

ip address 10.0.0.2 255.255.255.0

ip nat outside

interface Gi0/0

Description Secondary link ISP2

ip address 172.16.10.3 255.255.255.0

ip nat outside

interface VLAN 10

Description Inside LAN segment

ip address 192.168.121.1 255.255.255.0

ip nat inside

access-list 100 permit ip 192.168.121.0 0.0.0.255 any

route-map ISP1 permit 10

match ip address 100

match interface Gi0/1

route-map ISP2 permit 10

match ip address 100

match interface Gi0/0

ip nat inside source route-map ISP1 interface Gi0/1 overload

ip nat inside source route-map ISP2 interface Gi0/0 overload

! Primary Default route pointing towards Next hop ip of ISP1

ip route 0.0.0.0 0.0.0.0 10.0.0.1

!Backup Default route with higher AD (10) pointing towards Next hop ip of ISP2

ip route 0.0.0.0 0.0.0.0 172.16.10.1 10

! the above example shows how we can perform Failover for PAT

! (Port Address Translation) for the traffic going out to Internet.

! By using route-maps and "match interface" option, we can

! achieve failover for Static NAT translation as well which

! is generally configured when services are hosted out

! to the internet like webserver or exchange server hosted inside accessible from Internet

route-map ISP1static permit 10

match interface Gi0/1

route-map ISP2static permit 10

match interface Gi0/0

! Server IP address 192.168.121.2 in following example

ip nat inside source static 192.168.121.2 172.16.10.3 route-map ISP1static

ip nat inside source static 192.168.121.2 172.16.10.3 route-map ISP2static

For some reason this message forum keeps wrapping the command lines in the above config.. Sorry