ā12-22-2012 10:49 PM - edited ā03-07-2019 10:44 AM
Hi
I need to configure auto-failover for a link. That link provided by single ISP but via 2 POPs as primary and secondary link.
So if Primary POP link went down, the traffic should pass to the secondary link. I don't know the exact configurations to configure this.
The network topology is like below.
I NEED TO CONFIGURE THIS AS AUTO FAILOVER, USING IP SLA.
Can any one help me to conigure this ? PLEASE SEE the attach graph for the network topology.
I would be glad anyone can help me
Solved! Go to Solution.
ā12-23-2012 12:53 AM
Hi,
Here is simple config:
ip sla 1
icmp-echo 45.45.45.1 source-interface s0/0
timeout 500
frequency 1
ip sla schedule 1 life forever start-time now
track 10 rtr 1 reachability
delay down 1 up 1
ip route 0.0.0.0 0.0.0.0 45.45.45.1 track 10
ip route 0.0.0.0 0.0.0.0 14.100.100.1 10
I assumed 45.45.45.1 is ISPs address. If link goes down first default static route is removed from ip routing table table and second static is placed into routing table.
This technology with very good explanation:
http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/813-cisco-router-ipsla-basic.html
Hope it will help.
ā12-23-2012 05:50 AM
It means not immediately only after 1 second tracking objects is reported as down (or up) and in our situation ip route is removed (or again added) from routing table. Because sometimes a link might be flapping.
http://www.cisco.com/en/US/docs/ios/12_2t/12_2t15/feature/guide/fthsrptk.html#wp1027187
ā12-23-2012 12:53 AM
Hi,
Here is simple config:
ip sla 1
icmp-echo 45.45.45.1 source-interface s0/0
timeout 500
frequency 1
ip sla schedule 1 life forever start-time now
track 10 rtr 1 reachability
delay down 1 up 1
ip route 0.0.0.0 0.0.0.0 45.45.45.1 track 10
ip route 0.0.0.0 0.0.0.0 14.100.100.1 10
I assumed 45.45.45.1 is ISPs address. If link goes down first default static route is removed from ip routing table table and second static is placed into routing table.
This technology with very good explanation:
http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/813-cisco-router-ipsla-basic.html
Hope it will help.
ā12-23-2012 05:02 AM
Thank you for your sample.
I refer the link and got a clear idea about the configuration.
in your example i saw below lines
track 10 rtr 1 reachability
delay down 1 up 1
Can you explain it. because i got confused with this one. your referance link example shows different configuration for configuration for track statement.
ā12-23-2012 05:50 AM
It means not immediately only after 1 second tracking objects is reported as down (or up) and in our situation ip route is removed (or again added) from routing table. Because sometimes a link might be flapping.
http://www.cisco.com/en/US/docs/ios/12_2t/12_2t15/feature/guide/fthsrptk.html#wp1027187
ā12-24-2012 04:11 AM
Hi
I do the configuration using GNS3 and worked perfectly.
Final thing is do the NAT configuration for customer router.
i have configure it for one link, but i hanen't any idea to configure for two links. In my network topology i configure NAT for primary link. But how do i configure backup link also in NAT.
here access list same for both link (primary and backup)
access-list 1 permit 192.168.1.0 0.0.0.255
NAT configuration for the primary link as
ip nat pool NATPOOL 45.45.45.2 45.45.45.2 netmask 255.255.255.252
ip nat inside source list 1 pool NATPOOL overload
So how do i configure NAT for backup link ?
ā12-24-2012 04:22 AM
Hi,
You can do it very simple by creating another pool for second link or just configuring PAT:
First option:
ip nat inside source list 1 interface s0/1 overload
Second:
ip nat pool NATPOOL_SECONDARY 14.100.100.x 14.100.100.x netmask 255.255.255.252
ip nat inside source list 1 pool NATPOOL_SECONDARY overload
Hope it will help.
ā12-24-2012 08:05 AM
Hi,
I configure NAT as below bu createing 2 access list for same subnet.
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 2 permit 192.168.1.0 0.0.0.255
ip nat pool PRIMARYNAT 45.45.45.1 45.45.45.1 netmask 255.255.255.252
ip nat pool SECONDARYNAT 14.100.100.1 14.100.100.1 netmask 255.255.255.252
ip nat inside source list 1 pool PRIMARYNAT
ip nat inside source list 2 pool SECONDARYNAT
I have tested and worked perfectly for both primary and secondary link (When failover happens)
Thank you very much for you kind help !
ā12-24-2012 08:10 AM
I'm glad that it helped you!
Sent from Cisco Technical Support iPhone App
ā12-28-2012 01:02 AM
Hi Abzal,
Can i configure this network toplology as for load balancing. That means if want to use these two links working and if one (primary) goes down all traffic moved to the other (secondary) link.
Can i configure my requirement using IP-SLA ?
Or are there any other method to do my requirement ?
I have another question, that is as per this topology it use serial interfaces to connect customer router. but if one of thses link connect via ethernet (i,e : that ethernet termination means from pop to customet there is fiber connectivity, so that there is a vlan connectivity between pop router and customer router), how to configure auto-failover for this scenario.
ā12-28-2012 01:14 AM
Hi,
Yes, you can do it either. You can achieve it using IP SLA by doing the same steps like the first one and just add ip route:
ip route 0.0.0.0 0.0.0.0 x.x.x.x track 20
When one of the link goes down second will take over. And the route will be removed from routing table.
I think you are able to do it with fiber link as well because it just another Layer2 link. So it should be just fine. The failover scenario can be the same.
Hope it will help.
ā12-28-2012 01:30 AM
In my previous configuration i add ip route as below.
ip route 0.0.0.0 0.0.0.0 45.45.45.1 track 10
ip route 0.0.0.0 0.0.0.0 14.100.100.1 10
So you asked me to add track 20 for 14.100.100.1 ip address ? like below
ip route 0.0.0.0 0.0.0.0 45.45.45.1 track 10
ip route 0.0.0.0 0.0.0.0 14.100.100.1 track 20
ip route 0.0.0.0 0.0.0.0 14.100.100.1 10
and i have to set up a another sla to track 14.100.100.1 ?
So how both links up ? Can you explain it, I can't understand how both links active ?
ā12-28-2012 01:47 AM
Sorry for confusion
Yes, you need to track both links with IP SLA. And remove ip route:
no ip route 0.0.0.0 0.0.0.0 14.100.100.1 10
In addition for first track
ip sla 2
icmp-echo 14.100.100.1 source-interface s0/1
timeout 500
frequency 1
ip sla schedule 2 life forever start-time now
track 20 rtr 2 reachability
delay down 1 up 1
ip route 0.0.0.0 0.0.0.0 45.45.45.1 track 10
ip route 0.0.0.0 0.0.0.0 14.100.100.1 track 20
Then you can check routing table there should be two default routes. Because both routes have the same AD (administrative distance) you will see both routes. But you need to configure NAT for second link as for primary link.
show ip route
show ip cef 0.0.0.0/0
IP CEF should take of load-balancing. It should be by default enabled otherwise:
ip cef
Then tell me the status. If it works out for you.
Abzal
ā12-28-2012 02:32 AM
Earlier i configure NAT as below
R1(config)# access-list 1 permit 192.168.1.0 0.0.0.255
R1(config)# route-map PRIMARY_MAP permit 10
R1(config-route-map)#match ip address 1
R1(config-route-map)#match interface Serial0/0
R1(config)# route-map SECONDARY_MAP permit 10
R1(config-route-map)#match ip address 1
R1(config-route-map)#match interface Serial0/1
R1(config)# ip nat inside source route-map PRIMARY_MAP interface Serial0/0 overload
R1(config)# ip nat inside source route-map SECONDARY_MAP interface Serial0/1 overload
So how could i configure NAT for load balancing as you mentioned in previous replay for secondary link ?
ā12-28-2012 02:41 AM
Your NAT configuration should be OK.
ā12-28-2012 02:53 AM
ok i'll check and let you know
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide