cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1321
Views
5
Helpful
8
Replies
Highlighted
Beginner

Configuring Etherchannel on a Stackwise Stack

Hi, new on here, so please take it easy on me..

I am looking for some ideas regarding a config I have been having issues with today.

A site that i am responsible for has the following equipment installed:

2 x 3750G Switches configured as a stack using Stackwise - Collapsed Core/Distribution Layer

5 x 2960G Switches as Access Layer switches

WAN connections into the Core/Distribution Layer are all Gigabit Ethernet over Fibre.

This is a dedicated CCTV Network with 50 Cameras all streaming video into the Core (decoders connected to access switches)

Each 2960G has 2 links to the Core/Distribution 3750G Switches, 1 to each switch - Gigabit

I'm running rapid-pvst on all switches, so spanning tree is blocking one of the ports and effectively halving the 2 gig bandwidth. Next year our customer is going to add in a further 50 - 60 cameras.

After monitoring the current loading on the ports in use, we have suggested to the customer that the 2 connections to each should be Ether-channeled together.

The documentation for the Stackwise feature says the following:

Cross-Stack EtherChannel Connections

Because all the ports in a stack behave as one logical unit, EtherChannel technology can operate across multiple physical devices in the stack. Cisco IOS Software can aggregate up to eight separate physical ports from any switches in the stack into one logical channel uplink. Up to 48 EtherChannel groups are supported on a stack.

Great!

Until I try to configure it!!!!!!!!!!!!

on the 3750G Stack

interface GigabitEthernet1/0/19

description 1ASW1_23

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-group 1 mode on

interface GigabitEthernet2/0/19

description 1ASW1_24

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-group 1 mode on

First interface takes commands no problem, keep getting the message that etherchannel cannot be configured across different switches in a stack when i try to put the second interface commands on.

Anybody else had this problem?

Any ideas would be welcome.

Thanks

Mark.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Expert

Hi Mark,

Do you get the same error when you configure the link with LACP?

channel-group 1 mode active

Also, what version of IOS are you running.  A code upgrade may fix this issue.

For cross-stack EtherChannel configurations,  ensure that all ports targeted for the EtherChannel are either  configured for LACP or are manually configured to be in the channel  group using the

channel-group

channel-group-number

mode on

interface configuration command. The PAgP protocol is not supported on cross- stack EtherChannels.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750x_3560x/software/release/12.2_55_se/configuration/guide/swethchl.html

HTH

View solution in original post

8 REPLIES 8
Highlighted
Hall of Fame Expert

Hi Mark,

Do you get the same error when you configure the link with LACP?

channel-group 1 mode active

Also, what version of IOS are you running.  A code upgrade may fix this issue.

For cross-stack EtherChannel configurations,  ensure that all ports targeted for the EtherChannel are either  configured for LACP or are manually configured to be in the channel  group using the

channel-group

channel-group-number

mode on

interface configuration command. The PAgP protocol is not supported on cross- stack EtherChannels.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750x_3560x/software/release/12.2_55_se/configuration/guide/swethchl.html

HTH

View solution in original post

Highlighted

Hi Reza and Thank You,

That answers my question, I had 2 ports in Port Channel 1 (ports 1 and 2) using channel-group 1 mode desirable, and I was trying to set these ports up, so I could migrate to the new ports, and disconnect the current ports after the new ports were up (having a network re-config and tidy up). This answers my question perfectly. You truly are a star!!

Cheers

Mark

Highlighted

Mark,

Glad to help, and thanks for the kind words and rating!!

Reza

Highlighted
Frequent Contributor

hello, i suppose that you will use vlan with SVIs for intervlan routing on the core 3750G stackwise. you will use etherchannel uplink to connct each access switchs with the core. you have a possibility to use LACP or PAGnP for link bundling. 2960 are L2 switch else you need to use 802.1q trunk to transport each Vlan for access to core layer. you need to configure on the core the loadsharing mecanisme accross each etherchannel like mac-src-des or mac-src or mac-des only.

good luk

---

Posted by WebUser Adil Taleb from Cisco Support Community App

Highlighted

you have a possibility to use LACP or PAGnP for link bundling

This is actally not the case.  Cross stack 3750s do not support PAGP.

auto

Places a port into a passive negotiating state, in which the port  responds to PAgP packets it receives but does not start PAgP packet  negotiation. This setting minimizes the transmission of PAgP packets.

desirable
This mode is not supported when the EtherChannel members are from  different switches in the switch stack (cross-stack EtherChannel).

Places a port into an active negotiating state, in which the port starts negotiations with other ports by sending PAgP packets.

This mode is not supported when the EtherChannel members are from  different switches in the switch stack (cross-stack EtherChannel).

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/15.0_1_se/configuration/guide/swethchl.html#wpmkr1454199

HTH

Highlighted
Beginner

Hi Reza,

Just a quick reply to say that I have configured this today, 5 cross stack Etherchannels from core 3750 stack, one to each access switch. Once I took off the PAgP, configuring was a breeze.

Many thanks again for your quick reply, saved me a whole lot of grief.

Cheers

Mark

Sent from Cisco Technical Support iPhone App

Highlighted

Hi Mark,

Glad to help

Good Luck!!

Reza

Highlighted
VIP Expert

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

If you believe you need to have a dual Etherchannel to handle additional cameras, will one gig link provide enough bandwidth if there's a link failure or 3750 stack member failure?

BTW, you may need to change the load balancing algorithm to optimally use multiple links.

Content for Community-Ad