cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5684
Views
0
Helpful
4
Replies

Configuring intervlan routing between 2801 and HP switches

churchillma
Level 1
Level 1

So I'm stuck on something.  I'm trying to configure intervlan routing between a cisco 2801 router and HP/Amer switches.  Using int fa0/1 and subinterfaces I was sure I had it configured correctly, but I cannot ping the default gateways when I place a host in a particular vlan.  Below is what I have configured.

HP switch - port 9 connects to fa0/1 on 2801

ip default-gateway 10.1.100.1

trunk 9 Trk1 trunk

trunk 10 Trk2 trunk - to another switch

vlan 1

mgmt

ip add 10.1.100.2 255.255.255.0

tagged Trk1-Trk2

vlan 2

data

tagged Trk1-Trk2

vlan 4

servers

tagged Trk1-Trk2

untagged 2 - as example

and so on....

Basically the only vlan that seems to work is 1.  I can assign myself an IP in that range and get to the internet so I know it's not a NAT issue or anything.  When I assign or "untag" a port on a particular vlan, say 4 and assign myself an IP in that range, I can't ping the D.G.  Is it something to do with the native vlan or something?

The router 2801's code is 15.1 ipbase, if that matters.

Any help would be great, i'm sure it' something small

2801 config below -

interface Loopback0

no ip address

!

interface FastEthernet0/0

description link to Mediacom

ip address 97.64.232.206 255.255.255.240

ip access-group 102 in

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

description Management

encapsulation dot1Q 1 native

ip address 10.1.100.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/1.2

description HS Upper Classmen Wireless

encapsulation dot1Q 2

ip address 10.1.2.1 255.255.254.0

ip helper-address 10.5.0.9

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/1.4

description HS Lower Classmen Wireless

encapsulation dot1Q 4

ip address 10.1.4.1 255.255.254.0

ip helper-address 10.5.0.9

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/1.6

description HS Staff Wireless

encapsulation dot1Q 6

ip address 10.1.6.1 255.255.255.0

ip helper-address 10.5.0.9

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/1.8

description HS Wired Data

encapsulation dot1Q 8

ip address 10.1.8.1 255.255.255.0

ip helper-address 10.5.0.9

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/1.200

description Servers

encapsulation dot1Q 200

ip address 10.5.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/1.250

description Old-Net

encapsulation dot1Q 250

ip address 10.10.0.1 255.255.0.0

ip helper-address 10.5.0.9

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

!

!

ip http server

ip nat pool ghs 97.64.232.206 97.64.232.206 netmask 255.255.255.240

ip nat inside source list 101 pool ghs overload

ip route 0.0.0.0 0.0.0.0 97.64.232.193

!

logging history notifications

access-list 1 permit 207.28.243.115

access-list 1 permit 10.5.0.105

access-list 1 permit 10.5.0.115

access-list 101 permit ip any any

4 Replies 4

Sandeep Choudhary
VIP Alumni
VIP Alumni

Hi,

Here is the simple and clear example of inter vlan routing, please check it and correct it.

InterVLAN_configuration_topology.jpg

To help you understand more clearly about InterVLAN, the main configuration of router & switch are shown below:

Configure trunk port on switch:

Switch(config)#interface f0/0
Switch(config-if)#no shutdown
Switch(config-if)#switchport mode trunk

Create sub-interfaces, set 802.1Q trunking protocol and ip address on each sub-interface

Router(config)#interface f0/0
Router(config-if)#no shutdown

(Note: The main interface f0/0 doesn’t need an IP address but it must be turned on)

Router(config)#interface f0/0.0
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#interface f0/0.1
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 192.168.2.1 255.255.255.0

(Note: In the “encapsulation dot1q 10″ command, 10 is the VLAN ID this interface operates in)

I also list the full configuration of the above topology for your reference:

Configure VLAN


Switch(config)#vlan 10
Switch(config-vlan)#name SALES
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name TECH

Set ports to access mode & assign ports to VLAN

Switch(config)#interface range fa0/1-2
Switch(config-if)#no shutdown
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10
Switch(config-if)#interface range fa0/3-4
Switch(config-if)#no shutdown
Switch(config-if)#switchport mode access
Switch(config-if)# switchport access vlan 20

as I am not aware about the HP Switches. Use this simple config and try .

Regards

please rate if it helps.

As stated I have HP switches. No help

thomas1337
Level 1
Level 1

Hi,

on your Router sub-interface Fa0/1.1 you configure

encapsulation dot1q 1 nativ

The Keyword "nativ" means, that all incomming traffic on IF Fa0/1 which is not tagged going to sub-if fa0/1.1 and outgoing traffic from fa0/1.1 are untagged to, because the other end (the trunk of your switch) handles it like the same.

So i think the poblem is the trunk of your Switch.

I am not aware of HP Switch configuration, but at HP a trunk is the same as a Port Channel at Cisco.

Test the following:

delete your statements "trunk 9 Trk1 trunk" "trunk 10 Trk1 trunk" and add to your vlans "tagged 9,10"

Please find out how HP Swicthes handles nativ vlans to know if it is required to configure the nativ vlan on your Routers sub-if fa0/1.1

Thomas

Well I added those ports as tagged on the vlans, no luck. I have all ports untagged on default vlan 1 and on the router the native vlan is on 1 as well.  I'm stumped.

Review Cisco Networking products for a $25 gift card