cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
37920
Views
20
Helpful
19
Replies

Configuring OSPF on a layer 3 switch 3560G

asencalar
Beginner
Beginner

Configuring OSPF on a catalyst 3560G Switch to connect to our building next door by way of fiber.  The other two switches in the other building are running OSPF, I am trying to connect to the other building and access a server which is on a switch running OSPF.  I am trying to configure the switch here to run OSPF and be able to see the neighbor, but currently can't although I've identified the networks.  Maybe I'm missing something, I've followed the instructions but  something is not right.  Can anyone help in possibly identifying or certain things that I need to look no matter how basic it may be.                    

19 REPLIES 19

Muhammad Thanveer
Contributor
Contributor

Can you please post some configuration like

Sh ip ospf neighbors

This is to identify the neighbor state.....

sh run par router ospf(process id) or sh run | sec router ospf  ( this is for all the switches)

Also provide the topology

Topology as per the above comments what I have assumed is

SW1----> SW2

|

|

SW3(new 3560 SW) is this correct..

Regards
Thanveer
"Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."

paul driver
VIP Expert VIP Expert
VIP Expert

Hello

How are you connecting to the neighbor ( what physical interface - I guess gigabit/fastethernet-  which in ospf terms is a broadcast link)

From the switch-

sh ip ospf interface xxx

sh ip ospf neigbours

sh run | sec router ospf

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

This was very helpful.  I had configured wrong and found this post, got it all fixed up now.

use ipv6

asencalar
Beginner
Beginner

SwitchR4S1#show run | sec router ospf

router ospf 110

router-id 10.12.0.12

area 0 authentication message-digest

passive-interface default

no passive-interface Vlan804

no passive-interface Vlan1000

network 10.12.0.12 0.0.0.0 area 0

network 10.12.255.1 0.0.0.0 area 0

network 148.32.14.253 0.0.0.0 area 0

SwitchR4S1#

SwitchR4S1#sh ip ospf neighbor

SwitchR4S1#

SwitchR4S1#sh ip ospf interface

Vlan804 is up, line protocol is up

  Internet Address 148.32.14.253/24, Area 0, Attached via Network Statement

  Process ID 110, Router ID 10.12.0.12, Network Type BROADCAST, Cost: 1

  Topology-MTID    Cost    Disabled    Shutdown      Topology Name

        0           1         no          no            Base

  Transmit Delay is 1 sec, State DR, Priority 1

  Designated Router (ID) 10.12.0.12, Interface address 148.32.14.253

  No backup designated router on this network

  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

    oob-resync timeout 40

    Hello due in 00:00:03

  Supports Link-local Signaling (LLS)

  Cisco NSF helper support enabled

  IETF NSF helper support enabled

  Index 2/2, flood queue length 0

  Next 0x0(0)/0x0(0)

  Last flood scan length is 0, maximum is 0

  Last flood scan time is 0 msec, maximum is 0 msec

  Neighbor Count is 0, Adjacent neighbor count is 0

  Suppress hello for 0 neighbor(s)

  Message digest authentication enabled

      No key configured, using default key id 0

Vlan1000 is up, line protocol is up

  Internet Address 10.12.0.12/24, Area 0, Attached via Network Statement

  Process ID 110, Router ID 10.12.0.12, Network Type BROADCAST, Cost: 1

  Topology-MTID    Cost    Disabled    Shutdown      Topology Name

        0           1         no          no            Base

  Transmit Delay is 1 sec, State DR, Priority 255

  Designated Router (ID) 10.12.0.12, Interface address 10.12.0.12

  No backup designated router on this network

  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

    oob-resync timeout 40

    Hello due in 00:00:03

  Supports Link-local Signaling (LLS)

  Cisco NSF helper support enabled

  IETF NSF helper support enabled

  Index 1/1, flood queue length 0

  Next 0x0(0)/0x0(0)

  Last flood scan length is 0, maximum is 0

  Last flood scan time is 0 msec, maximum is 0 msec

  Neighbor Count is 0, Adjacent neighbor count is 0

  Suppress hello for 0 neighbor(s)

  Message digest authentication enabled

      No key configured, using default key id 0

SwitchR4S1#

SwitchR4S1#show run | sec router ospf
router ospf 110
router-id 10.12.0.12
area 0 authentication message-digest
passive-interface default
no passive-interface Vlan804
no passive-interface Vlan1000
network 10.12.0.12 0.0.0.0 area 0
network 10.12.255.1 0.0.0.0 area 0
network 148.32.14.253 0.0.0.0 area 0
SwitchR4S1#

SwitchR4S1#sh ip ospf neighbor
SwitchR4S1#

SwitchR4S1#sh ip ospf interface
Vlan804 is up, line protocol is up
  Internet Address 148.32.14.253/24, Area 0, Attached via Network Statement
  Process ID 110, Router ID 10.12.0.12, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 10.12.0.12, Interface address 148.32.14.253
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
  Message digest authentication enabled
      No key configured, using default key id 0
Vlan1000 is up, line protocol is up
  Internet Address 10.12.0.12/24, Area 0, Attached via Network Statement
  Process ID 110, Router ID 10.12.0.12, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 255
  Designated Router (ID) 10.12.0.12, Interface address 10.12.0.12
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
  Message digest authentication enabled
      No key configured, using default key id 0
SwitchR4S1#

OK so this is what I have, it is a closed network so we don't touch anything like the internet.  The fiber is ran between the two buildings with two switches on one end and the switch I'm trying to configure on this end (10.12.0.12).  The other end is 10.12.0.1 

Sorry for the delay in the response.

Hello,

As per the above output the switch you are trying to configure also has neighbors other than the one which you are configuring..

are you able to reach the other end switch which you are trying to configure. Please provide the ping status...

I am a bit worried with the below output, I have highlighted the output which I am worried about..

Vlan1000 is up, line protocol is up

  Internet Address 10.12.0.12/24, Area 0, Attached via Network Statement

  Process ID 110, Router ID 10.12.0.12, Network Type BROADCAST, Cost: 1

  Topology-MTID    Cost    Disabled    Shutdown      Topology Name

        0           1         no          no            Base

Transmit Delay is 1 sec, State DR, Priority 1

  Designated Router (ID) 10.12.0.12, Interface address 148.32.14.253

No backup designated router on this network

can you post the config for the below

sh run int (interface connecting with the other switch)

Is the port you are trying to connect is L3, or L2?

If L2 then the interface must be accessing the vlan 1000

example

interface GigabitEthernet0/1

switchport access vlan 1000

switchport mode access
!

you should get the output for sh ip ospf neighbor

example

Switch#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.2           1   FULL/BDR        00:00:32    1.1.1.2         Vlan1000

Please rate the helpful posts

Regards
Thanveer
"Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."

Both switches are L3. The other side is connected internally, I'm trying to establish connection into the ospf neighborhood from this building across the street. I am actually at the switch working with it to get it to work


Sent from Cisco Technical Support iPad App

What should the router-id be, when I put 10.12.255.1 which is the configuration on the switch which works and is the other building, I get a duplicate router-id message?


Sent from Cisco Technical Support iPad App

What networks should I put in the configuration of the ospf, the ip of the switches that I want to add and/or what else?

Sent from Cisco Technical Support iPad App

Ping works

Sent from Cisco Technical Support iPad App

Unable to trace route

Sent from Cisco Technical Support iPad App

Hello Ates,

router-id can be any loopback address or the add which you want, there will be no issue.

prerequisties

you must be able to ping the neighbor switch ip address.

for (IGP/ospf) to get configured the other switch must be a directly connected neighbor only then you will be able form a adjacency relation ship.

Switches for which you need to form a neighbor relationship must be in a single broadcast domain. 

If your switch  port is L2 then it must be accessing the vlan 1000 as per your requirement.

The other side switch ospf process also should have area 0 configured on the interfeace with which you need to form adjacency  (If you need area 0 to be configured in your switch)

configuration part:

Router ospf 110

network 10.12.0.12 0.0.0.0 area 0 (this is the vlan interface ip address of the local switch, if your intentions is to make the neighbor relationship based on the vlans)

network 20.1.1.0 0.0.0.255 area 0 (I assumed 20.1.1.0/24 as your local LAN, It can be any network which is down to your switch and you wanted to advertise it into ospf process).

OR

router ospf 110

network 20.1.1.0 0.0.0.255 area 0

int vlan 1000

ip ospf 110 area 0

Please rate the helpful posts

Regards
Thanveer
"Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."

I will let you know on Monday as to how it goes. Thanks for the help!

Sent from Cisco Technical Support iPad App

Hello,

Any luck?

Regards
Thanveer
"Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: