cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

205
Views
15
Helpful
4
Replies
Highlighted
Beginner

Connecting a Cisco Lab to a Home Router

I am working on a project for my college course. I live with several roommates and am looking for a way to connect my Cisco Lab to the internet through the Home Router. I will attach a picture of my topology. While practicing tonight, I was able to get the Cisco 2811 to ping the Home Network as well as Google. However, everything else from the L3 Switch and down was not even able to ping the Home Router. Everything from the L3 switch down is able to ping up to the Cisco 2811 Router's exit interface towards the ISP though.

 

Since all equipment before the Home Router is reachable to each other, I am unsure why the L3 Switch cannot reach the Home Router. I have added the default route from the Cisco 2811 Router to the Home Router (192.168.1.1). I advertised the connected 192.168.1.0 255.255.255.0 route via OSPF on the Cisco 2811 Router. I don't know what I am missing, but I feel the issue is likely something simple.

 

Any help is greatly appreciated!Capture.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: Connecting a Cisco Lab to a Home Router

Hello,

 

in addition to the other posts, here is what you would need to configure on the 2811 (interfaces are arbitrary since I don't know which ones you are really using):

 

2811
!
interface FastEthernet0/0
description Link to ASUS RT-AC88U
ip address dhcp
ip nat outside
!
interface FastEthernet0/1
description Link to L3 Switch
ip address 10.55.100.x 255.255.255.0
ip nat inside
!
ip nat inside source list 1 interface FastEthernet0/0 overload
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 dhcp
!
access-list 1 permit 10.55.0.0 0.0.255.255

4 REPLIES 4
VIP Advisor

Re: Connecting a Cisco Lab to a Home Router

Hi there,

 

Is the 2811 performing NAT for all of your lab kit? If not then does the ISP modem have a route installed for the lab subnets (10.55.x.0/24) ?

 

Given the limitations of cheap ISP routers, the path of least resistance will be to NAT the lab subnets and overload the 2811 'outside' interface connected to the ISP router.

 

cheers,

Seb.

Collaborator

Re: Connecting a Cisco Lab to a Home Router

Hi,

You need to tell the Home router how to get back to the Lab. You need  static routes on the Home router for the 10.551.0/24, 10.55.0.0/24 and 10.55.55.0/0 pointing to the 2811 router.

 

Thanks

John

**Please rate posts you find helpful**
VIP Mentor

Re: Connecting a Cisco Lab to a Home Router

Hello,

 

in addition to the other posts, here is what you would need to configure on the 2811 (interfaces are arbitrary since I don't know which ones you are really using):

 

2811
!
interface FastEthernet0/0
description Link to ASUS RT-AC88U
ip address dhcp
ip nat outside
!
interface FastEthernet0/1
description Link to L3 Switch
ip address 10.55.100.x 255.255.255.0
ip nat inside
!
ip nat inside source list 1 interface FastEthernet0/0 overload
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 dhcp
!
access-list 1 permit 10.55.0.0 0.0.255.255

Beginner

Re: Connecting a Cisco Lab to a Home Router

Thanks for the valuable input, all! I've tried a hodge podge of all your responses and I am now online and internet accessible with all equipment.

 

Thanks again for all your help!

 

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards