cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
935
Views
0
Helpful
11
Replies
Highlighted
Beginner

connectivity between networks problem

Network setup:

Router has four interface each connected to a different network ( in this 4 different PCs, each of which is 137.80.xxx.2)

Each router interface is configured as the default gateway with IP addresses of 137.80.xxx.1)

This is as simple a network as it gets but The computers can only ping to the interfaces of the router.  They cannot ping each other.  Additionally, when you turn on debug for icmp, the router never sees the packets when pinging from PC to PC, only when there is a successful ping (such as when a PC pings a router interface.  issue.png

This is also a problem when using these same computers on a switch with IP routing enabled.

This configuration works, of course, in Cisco packet tracer with no issues.  I suspected the computers were the issue, but they can ping their default gateways and the default gateways (interface) of the other networks.

 

Any insight is greatly appreciated.

 

 

Andy

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Guru

Re: connectivity between networks problem

From each PC can you ping all other interface IPs on the router ?

 

If you can then check all PCs for firewalls. 

 

Jon

11 REPLIES 11
VIP Expert

Re: connectivity between networks problem

What  type of switch are you using and what is the license level ("show license" and/or "sh ver")

Also, can you post "sh run" from the switch?

HTH

Beginner

Re: connectivity between networks problem

Here is the info:

3925 ipbasek9 (universalk9-m)

and

c2960c universalk9

 

===--- config ---===

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

interface Loopback1

ip address 137.80.104.1 255.255.255.255

!

interface FastEthernet0/0

ip address 137.80.100.1 255.255.254.0

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 137.80.101.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet2/0

ip address 137.80.102.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet3/0

ip address 137.80.103.1 255.255.255.0

duplex auto

speed auto

!

ip classless

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

end

Beginner

Re: connectivity between networks problem

Anyone?

VIP Expert

Re: connectivity between networks problem

Are these the built in interfaces on the 3925 router or are you using a switch module?

When you are on the router, can you ping all the IPs?

Can you post "sh ver"from the router?

Beginner

Re: connectivity between networks problem

 All interfaces are internal interfaces and not the switch card.  Also, I can ping all configured interfaces, just not the computers that are attached.  The router is not on a network so getting the config will take a bit.  

 

Addition... One of the computers can ping another computer.  This is very confusing.

Beginner

Re: connectivity between networks problem

Here is the configuration:

 

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname acrtr
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$AOaw$nGua3KFXy7Mdh6oOl9c0S1
!
no aaa new-model
ethernet lmi ce
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!

!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
license udi pid C3900-SPE100/K9 sn FOC183669WR
hw-module sm 1
!
!
!
!
redundancy
!
!
!
!
!
!
interface Loopback1
ip address 137.80.104.1 255.255.255.255
!
interface Embedded-Service-Engine0/0
no ip address
!
interface GigabitEthernet0/0
description OpsFloor interface
ip address 137.80.100.1 255.255.255.0
duplex full
speed auto
!
interface GigabitEthernet0/1
description Programmers
ip address 137.80.101.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
Shop 2nd
ip address 137.80.102.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0/0
description Configuration Man
ip address 137.80.103.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet1/0
no ip address
shutdown
!
interface GigabitEthernet1/1
no ip address
!
interface Vlan1
no ip address
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 100 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
flowcontrol software
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

VIP Expert

Re: connectivity between networks problem

Can you ping from PC wiith IP 137.80.100.2 to PC with IP 137.80.101.2?

 

interface GigabitEthernet0/0
description OpsFloor interface
ip address 137.80.100.1 255.255.255.0
duplex full
speed auto
!
interface GigabitEthernet0/1
description Programmers
ip address 137.80.101.1 255.255.255.0
duplex auto
speed auto

Beginner

Re: connectivity between networks problem


@Reza Sharifi wrote:

Can you ping from PC wiith IP 137.80.100.2 to PC with IP 137.80.101.2?

 

interface GigabitEthernet0/0
description OpsFloor interface
ip address 137.80.100.1 255.255.255.0
duplex full
speed auto
!
interface GigabitEthernet0/1
description Programmers
ip address 137.80.101.1 255.255.255.0
duplex auto
speed auto


 

No, but I can ping from PC with IP 137.80.100.2 to PC with IP 137.8.103.2.  The odd part is I cannot ping the other way...from 137.8.103.2 to 137.80.100.2

 

 

interface GigabitEthernet0/0
description OpsFloor interface
ip address 137.80.100.1 255.255.255.0
duplex full
speed auto

!

 

to:

interface FastEthernet0/0/0
description Configuration Man
ip address 137.80.103.1 255.255.255.0
duplex auto
speed auto

 

Hall of Fame Guru

Re: connectivity between networks problem

From each PC can you ping all other interface IPs on the router ?

 

If you can then check all PCs for firewalls. 

 

Jon

Beginner

Re: connectivity between networks problem

Yes. All firewalls have been turned off. Will re-check them all next week.


Beginner

Re: connectivity between networks problem

Was told the F/Ws were turned off... they were not. Thanks for your help.
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards