cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2133
Views
0
Helpful
10
Replies
Beginner

CRC Errors on Cat 2950

I have a Catalyst 2950 access switch with lots of CRC errors on multiple ports with multiple computers.  Of all the ports that are connected, all but two have thousands of CRC errors.  On the ports I've investigated in depth, about 1 in 6 frames has a CRC error when transferring large files (using 1500 byte packets).  Everytime I try to move a file larger than about 100MB, the transfer fails because too many TCP packets are dropped and eventually the OS just gives up.  I even tried using a short shielded cable, thinking that maybe something in the room was putting out a lot of EMI, but that has not helped.  The log doesn't show anything unusual and except for the CRC errors, the ports seem to be fine, i.e. no flapping, collisions, duplex mismatches,err-disables, etc.

My question is this: do I just have a bad switch or is there something else that could be causing these CRC errors?  The switch essentially has the default config except I have used the access port macro to lock down my ports and I have enabled SMTP, NTP, and telnet.  Any help would be appreciated, although I'm fairly certain this is just a bad switch.

1 ACCEPTED SOLUTION

Accepted Solutions
Participant

Re: CRC Errors on Cat 2950

Hi,

I see where you have your switchport hard set for speed and duplex.  Have you checked the PC to make sure it is also hard set for 100/full?

I have seen this type of thing a lot with one side being speed locked and the other side isn't.  This will cause these types of issues.  If you cannot hard set the speed and duplex of the systems, then I would recommend leaving both sides at auto-negotiate.  All the Cisco docs say to either speed lock both sides or leave both sides at auto.

Just additional food for thought.

Cheers,

Kimberly

Thanks and Cheers! Kimberly Please remember to rate helpful posts.
10 REPLIES 10

Re: CRC Errors on Cat 2950

CRC errors are most likely due to a physical issue (layer 1). Check your cables, SFPs, other side of the network.

Move your connection to another port, see if the CRC errors follow the port, this will help you identify where your physical issue is.

Beginner

Re: CRC Errors on Cat 2950

Thank you for your reply.  Please re-read the first two sentences from my original question.  Multiple computers, multiple ports, multiple cables - all have the same problem.  I've already tried the standard stuff, that's why I asked my question.  I've temporarily moved my workstation to a different switch which cleared up the problem on my computer.  Six other users with six other computers (all different models, too) with six other cables on six other ports are all having this same problem.  Only two active ports are not showing CRC errors - one access port and the uplink port.

Cisco Employee

Re: CRC Errors on Cat 2950

Could be a problem with one of the port asics on the switch itself.  You've eliminated PC and cable.  As long as you can move a pc and the same cable to another device most likely the problem is that switch itself.

Hall of Fame Community Legend

Re: CRC Errors on Cat 2950

1.  What IOS are you running?

2.  Do this command "sh controller ethernet ", "sh int " and post the config of the interface.

Beginner

Re: CRC Errors on Cat 2950

Have you tried disconnecting every device except the uplink and one computer?

If you disconnect the uplink and do a computer to computer file transfer on the same switch do you have the same problem?

Beginner

Re: CRC Errors on Cat 2950

I haven't tried disconnecting everything, but I have tried computer to computer transfers on this switch with the same results.  If

I can get some downtime this afternoon, I will try your suggestion.

Beginner

Re: CRC Errors on Cat 2950

I'm running IOS version 12.1(22).  Here's requested info on one of my problem ports:

switchX#show controllers ethernet-controller fa 0/10

  Transmit                                Receive
1120975175 Bytes                         89117596 Bytes
  83913178 Frames                          476272 Frames
  49606345 Multicast frames                  7168 FCS errors
  33831800 Broadcast frames                  5055 Multicast frames
         0 Pause frames                      2902 Broadcast frames
         0 Single defer frames                  0 Control frames
         0 Multiple defer frames                0 Pause frames
         0 1 collision frames                   0 Unknown opcode frames
         0 2-15 collisions                      0 Alignment errors
         0 Late collisions                      0 Length out of range
         0 Excessive collisions                 0 Symbol error frames
         0 Total collisions                    15 False carrier errors
         0 Control frames                       0 Valid frames, too small
         0 VLAN discard frames                  0 Valid frames, too large
         0 Too old frames                   71342 Invalid frames, too small
         6 Tagged frames                        0 Invalid frames, too large
         0 Aborted Tx frames                    0 Discarded frames

  Transmit and Receive
    603103 Minimum size frames
   8982405 65 to 127 byte frames
   6189615 128 to 255 byte frames
  30621373 256 to 511 byte frames
  36932819 512 to 1023 byte frames
    988793 1024 to 1518 byte frames
         0 1519 to 1522 byte frames

switchx#show int fa 0/10
FastEthernet0/10 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0017.5abf.f70a (bia 0017.5abf.f70a)
  Description: my switchport
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 216/255, txload 1/255, rxload 2/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 100BaseTX
  input flow-control is unsupported output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 6w6d, output 00:00:01, output hang never
  Last clearing of "show interface" counters 4w6d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 824000 bits/sec, 87 packets/sec
  5 minute output rate 58000 bits/sec, 84 packets/sec
     301625 packets input, 124557749 bytes, 0 no buffer
     Received 7264 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     17491 input errors, 17491 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 4528 multicast, 0 pause input
     0 input packets with dribble condition detected
     83573743 packets output, 890196916 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

switchX#show run int fa 0/10
Building configuration...

Current configuration : 396 bytes
!
interface FastEthernet0/10
switchport access vlan 70
switchport mode access
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
speed 100
duplex full
mls qos cos override
macro description cisco-desktop
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
end

I suppose I have to take the switch at its word when it says it is getting a bunch of too small frames, but for what it's worth Wireshark doesn't show any problem on this computer except for tons of duplicate ACKs and retransmissions.

Participant

Re: CRC Errors on Cat 2950

Hi,

I see where you have your switchport hard set for speed and duplex.  Have you checked the PC to make sure it is also hard set for 100/full?

I have seen this type of thing a lot with one side being speed locked and the other side isn't.  This will cause these types of issues.  If you cannot hard set the speed and duplex of the systems, then I would recommend leaving both sides at auto-negotiate.  All the Cisco docs say to either speed lock both sides or leave both sides at auto.

Just additional food for thought.

Cheers,

Kimberly

Thanks and Cheers! Kimberly Please remember to rate helpful posts.
Beginner

Re: CRC Errors on Cat 2950

That was it.  It never even occurred to me that I might have problems with speed and duplex since all the computers were auto-detecting fine and the switch wasn't explicitly complaining about speed/duplex mismatch.  I think I set up my ports that way a long time ago because I had a couple of old laptops that always auto-configured as 100Mb/half duplex even though they would work at 100/full when hard configured.  Instead of applying speed/duplex just to those ports, I must have done it to the whole switch.  Thanks for your help, I'll definitely keep this in mind in the future.

Participant

Re: CRC Errors on Cat 2950

Patrick,

I am glad to hear that this helped. 

This is something good to keep in mind for the speed and duplex issues, auto for both or speed lock for both.  My rule of thumb is to leave the workstations/PCs at auto and speed lock down uplinks, servers, and other critical devices.

Have a good day!

Kimberly

Thanks and Cheers! Kimberly Please remember to rate helpful posts.
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards