cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2808
Views
0
Helpful
8
Replies

need help: Issue with 2950 acting as a DHCP-Client

alexander76
Beginner
Beginner

Hello Community,

i have a little problem since we installed a spare 2950 Catalyst running IOS: c2950-i6q4l2-mz.121-14.EA1a.bin.

I have configured a static IP Adress on interface VLAN 1.

I assume that a switch with a configured static IP-Address does not participate or act as DHCP-Client.

When i use a show dhcp server, the switch returns:

DHCP server: ANY (255.255.255.255)
Leases:   10
Offers:   1      Requests: 14     Acks: 10     Naks: 0
Declines: 0      Releases: 0     Bad:  0
DNS0:   172.16.10.20,   DNS1:  172.16.10.21
Subnet: 255.255.255.0

When i use a show dhcp lease, the switch returns:

Temp IP addr: 10.111.172.105  for peer on Interface: Vlan1
Temp  sub net mask: 0.0.0.0
   DHCP Lease server: 10.111.172.254, state: 3 Bound
   DHCP transaction id: 1868
   Lease: 86400 secs,  Renewal: 43200 secs,  Rebind: 75600 secs
   Next timer fires after: 11:24:49
   Retry count: 0   Client-ID: cisco-000e.d757.0c80-Vl1

Obviously the Switch gets an IP Address of the DHCP Server listed above although it is not supposed to!

The  Switch changes its IP Address every 12 hours even when a static IP has  been configured and the config including the static IP has been saved.

Is this probably an Issue with the old 12.1(14) IOS?

How can I completely turn off the Switchs behaviour as acting like a DHCP-Client?

Has anybody had this problem before?

Any Idea???

Thanks for your help in advance.

Greetings from Germany,

Alexander

8 Replies 8

jack
Beginner
Beginner

Hi Alexander,

Can you please post your config?  Especially the config concerning the port that you use to connect your switch into the network.  I don't think it's an issue with the old IOS.

Jack

Hi Jack,

as this is a spare switch, we only have a little and very easy config running on that switch.

All the other switches don´t have problems with that configuration. Only this one running 12.1(14).

Especially the ports connected to the network have no config:

Building configuration...

Current configuration : 1798 bytes
!
! Last configuration change at 14:35:26 MEZ Wed Jan 26 2011
! NVRAM config last updated at 10:40:10 MEZ Wed Jan 26 2011
!
version 12.1
no service pad
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
no service dhcp
!
hostname xxx
!
enable password xxx
!
clock timezone MEZ 1
clock summer-time MESZ recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
!
no ip domain-lookup
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24   // --> this one is the Uplink port
!
interface Vlan1
description xxx
ip address 1xxx
no ip route-cache
!
ip default-gateway xxx
no ip http server
...

Alexander,

Try the standard commands to clear old dhcp info:

2950> en

2950# clear ip dhcp binding *

2950# clear ip dhcp server statistics

Then check to see if there is any change.

Jack

Hi Jack,

i get nuts about this issue...

I followed your suggestion and cleard the "ip dhcp bindings" and "ip dhcp server statistics".


But i think both of these commands relate to the situation when my Switch is acting as a DHCP-Server.

My problem is that the switch (and only this one 2950...) is acting as a DHCP-Client, although it has been given a static IP.

Unfortunately there is noch change after the commands have been entered:

DE172SW01#sh dhcp server
   DHCP server: ANY (255.255.255.255)
    Leases:   10
    Offers:   1      Requests: 14     Acks: 10     Naks: 0
    Declines: 0      Releases: 0     Bad:  0
    DNS0:   172.16.10.20,   DNS1:  172.16.10.21
    Subnet: 255.255.255.0

DE172SW01#sh dhcp lease
DE172SW01#sh dhcp lease
Temp IP addr: 10.111.172.105  for peer on Interface: Vlan1
Temp  sub net mask: 0.0.0.0
   DHCP Lease server: 10.111.172.254, state: 3 Bound
   DHCP transaction id: 1868
   Lease: 86400 secs,  Renewal: 43200 secs,  Rebind: 75600 secs
   Next timer fires after: 06:35:56
   Retry count: 0   Client-ID: cisco-000e.d757.0c80-Vl1

How can i clear these informations from the switch??? I have never had this before...when a switch has static IP´s.

Thank you for your support on this case,

Alexander

Alexander,

Try this:

DE172SW01# release dhcp vlan 1

Jack

Hi Jack,

no chance. The used Version 12.1(14) unfortunately doesn´t support this command.

I can´t find the reason why this switch gets and takes an IP from the DHCP.

Thank you for your help.

Alexander,

3 things:

1.  Can you confirm that 10.111.172.105 is being passed out by your CURRENT DHCP server?  Or, it is possible that this is old information?

2.  Can you ping 10.111.172.105 from outside this switch?

3. You might try the following:

SW# conf t

SW(config)# int vlan 1

SW(config-if)# no ip address

SW(config-if)# ip address dhcp client-id Vlan 1 hostname cisco-000e.d757.0c80-Vl1 (if IOS allows this)

               If not just try --> SW(config-if)# ip address dhcp

Then get out, and check your statistics and your pings.

After you see what is going on, go back into interface and do a "no ip address dhcp" and then set it back to static to see if the information is removed.

Jack

varunagni
Beginner
Beginner

Hi Alex,

Do you intend to provide the switch an ip address with the DHCP config or do you want to provide hosts connected to the switch with ip addresses?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers