cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1410
Views
4
Helpful
5
Replies

Data and Voice Vlan

sushil
Beginner
Beginner

Hi,

We are going to use CUE and CME on cisco 2900 series router.

We would be using 24 port L2 POE switch as well.

Our Ip phone going to be have switch port so that cable from POE goes to Phone and from from Phone to desktop.Means vlan should sense the device and route accordingly.

I have few question on voice and data vlans;

Where should we need to create the vlans?Is it using subinterfaces on router and trunking with router or on the switch?

What is the best practivce on this and advantage of each?

Reg,

Sushil

5 Replies 5

Hi,

    I think this link will explain what you asked for and give you a good example too.

    Ref: http://www.cisco.com/en/US/products/sw/voicesw/ps5520/products_configuration_example09186a008037f2a9.shtml

HTH,

Toshi

I already checked that link.

Would like to know if possible to have VLAN on 2960 Switch?

If yes,any configuration example for that?

Reg,

Sushil

Hi,

Any inputs on this?

What Toshi has shared is router on stick configuration.That will allow intervlan routing?Do we really need to do routing among Vlans?

Would like to know can't we create vlans on 2960 itself ?Add all ports except one (for trunking with router) on both the vlans and all traffic leave the trunk link to router.

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_25_see/configuration/guide/swvoip.html

Will this work instead of router on stick config?

Reg,

Sushil

Peter Paluch
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

Sushil,

I am not sure if I fully understand what is your goal. You are saying that you will have a couple of IP phones connected to a L2 switch for PoE, and that switch in turni is connected to a 2900 series router. Is that correct?

If yes then creating both data and voice VLANs on the switch and connecting that switch using a trunk switchport to the router with subinterfaces for both VLANs is the easiest way of configuring things. Yes, this is exactly a router-on-stick scenario. This will allow interVLAN routing but we do this not primarily because of interVLAN routing but mostly because both the data and voice VLAN need to have access to other networks, internet. If their mutual communication is not appropriate then it can be prevented using ACLs.

The VLANs will be created on the 2960, correctly, and each port towards the IP phone will be configured as an access port with two VLANs:

interface FastEthernet0/1

switchport mode access

switchport access vlan 100 ! VLAN 100 is the data VLAN

switchport voice vlan 200  ! VLAN 200 is the voice VLAN

mls qos trust dscp

mls qos trust device cisco-phone

switchport priority extend cos 3

The port towards router will be a trunk port:

interface FastEthernet0/24

switchport mode trunk

mls qos trust dscp

The router itself will have two subinterfaces created (note, on a router, VLANs are actually not created, only used directly):

interface GigabitEthernet0/0

no shutdown

interface GigabitEthernet0/0.100

encapsulation dot1q 100

ip address ...

! Remaining configuration for the data VLAN

interface GigabitEthernet0/0.200

encapsulation dot1q 200

ip address ...

! Remaining configuration for the voice VLAN

Please feel free to ask further.

Best regards,

Peter

Thanks Peter.

Router on stick is quite understandable.Thanks for that.

I wanted to understand why to have router on stick configuration?

If we go plane configuration,with ip on physical interface of router and connect to trunk port of switch.

Now on switch we create two diffirent vlans on L2 i.e data and voice with diffirent subnet.

1. Can't we send both the Vlans to internet?

2. Can't both the vlans be added to same interface i.e say FE0/1?

Reg,

Sushil

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers