05-27-2016 02:04 AM - edited 03-08-2019 05:58 AM
I got three router R1, R3,and R2, R2 is hub, R1 can ping R2 through f0/0, now R3 can't ping R2. but in R3 it can show nhs and nhrp.
since f0/0 in R2 is used for R1 connection, how should I do? I can't draw a line between R3 (spoke)and R2(hub)pls see attached GNS3 screen
if I don't draw a line between R2 and R3, in R3 I can't ping R2 10.1.0.2
R3:
interface Loopback0
ip address 150.1.0.3 255.255.255.0
!
interface Tunnel0
ip address 10.1.0.3 255.255.255.0
ip nhrp authentication cisco123
ip nhrp map multicast 169.254.100.2
ip nhrp map 10.1.0.2 169.254.100.2
ip nhrp network-id 99
ip nhrp nhs 10.1.0.2
tunnel source FastEthernet0/0
tunnel destination 169.254.100.2
!
interface FastEthernet0/0
ip address 169.254.100.3 255.255.255.0
duplex auto
speed auto
++++++++++++++
R2:
interface Loopback0
ip address 150.1.0.2 255.255.255.0
!
interface Tunnel0
ip address 10.1.0.2 255.255.255.0
no ip redirects
ip nhrp authentication cisco123
ip nhrp map multicast dynamic
ip nhrp network-id 99
tunnel source FastEthernet0/0
tunnel mode gre multipoint
!
interface FastEthernet0/0
ip address 169.254.100.2 255.255.255.0
duplex auto
speed auto
05-27-2016 01:46 PM
Hi,
You can't jam two cables into one interface in real life, and you won't be able to do that in GNS3 either.
You need to emulate a WAN network with full connectivity between all nodes, because that's the kind of WAN connectivity (like the Internet) you would use for a DMVPN.
Instead of the routers connecting to each other directly, they should all connect to either a:
L3 switch
L2 switch
Regards,
Tim
05-29-2016 11:14 PM
No, we use cloud instead, but my machine is forbidden to run VMWare, I create three null port R1. R2 and R3 in the cloud to connect to R1, R2, R3 's f0/0 interface, but not working, is any expert in GNS3 can give some advice how to configure cloud for DMVPN, now in R3, I can't ping to R(hub)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide