cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1412
Views
0
Helpful
3
Replies

EIGRP - how to manipulate Feasible Distance

earteaga1
Level 1
Level 1

Hello, I'm looking to implement EIGRP on a network with 3 routers - R1 to R2 has a direct 1GB point-to-point link on TenGigabit Ethernet 1/0/1, R2 would be directly linked to R3. R1 also has a path to R3 through an MPLS connection which is about 6 hops away.

 

All routers are subnetted from a 10.0.0.0/8 network into /16's.

 

I'd like to have the ability to have R1 pick the direct path to R2 through the Point to Point (fastest) for 2 specific Subnets: 10.175.0.0/16 and 10.174.0.0/16 while routing the rest of the 10.0.0.0/8 network destinations through the slower link on the MPLS (its 3 more subnets to be exact 10.176.0.0/16, 10.177.0.0/16 and 10.178.0.0/16 which reside on R3)


I've been looking into manipulating the feasible distance of each link - this is done at the interface level by altering the bandwidth or delay parameters.

This would help If I'm simply looking to manipulate one link or the other for all of the 10.0.0.0/8 subnet however because the way things are addressed I'm looking to manipulate the FD on specific subnets.

 

They way things are, the successor route I'm assuming is going to be the Point-toPoint since it has more bandwidth and its 1 hop away. It will learn the routes from R3, and route to the destinations subnets in R3 (10.176.0.0/16, 10.177.0.0/16 and 10.178.0.0/16 ) through R2 instead of R3 directly through the P2P.

 

Should I be looking to manipulate the Link between R2 and R3?

or what's the best way to achieve this?

My goal is to have the ability to fail-over routes from each path (p2p and MPLS links on R1) and have the P2P link used only by certain subnets while both paths are up and running.

here's what I'm thinking:

 

on R1:

router eigrp 10

network 10.0.0.0

no auto summary

 

on R2

router eigrp 10

network 10.0.0.0

no auto summary

interface TenGigabitEthernet 1/0/1

descript link to R3

delay 20

 

interface TenGigabitEthernet 1/0/2

description link to R1 through P2P

delay 5

 

on R3

router eigrp

network 10.0.0.0

no auto summary

interface TenGigabitEthernet 1/0/1

description link to R2 through MPLS

delay 10

3 Replies 3

Paul Chapman
Level 4
Level 4

Hi -

You can manipulate the metric on EIGRP routes using route maps and distribute lists.  For example:

! ## Install on R1 ##
ip prefix-list PL-FAST-ROUTE seq 10 permit 10.174.0.0/16
ip prefix-list PL-FAST-ROUTE seq 20 permit 10.175.0.0/16
!
route-map RM-CHANGE-METRIC permit 10
 match ip address prefix-list PL-FAST-ROUTE
 set metric 10000000 1000 255 1 1500
route-map RM-CHANGE-METRIC permit 100
 set metric 1000000 3000 255 1 1500
!
router eigrp 10
 distribute-list route-map RM-CHANGE-METRIC in Te1/0/1
!

This basically tells the router to set a high bandwidth and low delay for the P2P routes, then set a low bandwidth and higher delay for all other routes coming in on interface Te1/0/1.  This means that routes coming from the MPLS are more likely to preferred if they don't match the prefix list.

PSC

Thanks Paul! this sounds good, I'm thinking I might need to do the same but on R2 to have symetrical routing:

ip prefix-list PL-FAST-ROUTE seq 10 permit 10.8.32.0/20 
ip prefix-list PL-FAST-ROUTE seq 20 permit 10.11.0.0/16 
ip prefix-list PL-FAST-ROUTE seq 30 permit 10.16.0.0/16 
ip prefix-list PL-FAST-ROUTE seq 40 permit 10.18.0.0/16 
ip prefix-list PL-FAST-ROUTE seq 50 permit 10.20.0.0/16 

!
route-map RM-CHANGE-METRIC permit 10
 match ip address prefix-list PL-FAST-ROUTE
 set metric 10000000 1000 255 1 1500
route-map RM-CHANGE-METRIC permit 100
 set metric 1000000 3000 255 1 1500

router eigrp 10

network 10.0.0.0

no auto summary

 distribute-list route-map RM-CHANGE-METRIC in TenGigabitEthernet 1/0/1

Once I've implemented I'll report back and let you know how things went. 

Hi -

Yes.  Assuming that all the routes in your prefix list are behind R1.

PSC

Review Cisco Networking for a $25 gift card