03-13-2013 01:53 PM - edited 03-07-2019 12:13 PM
In my production enviornment the commands:
router eigrp 500
redistribute static
and
ip route 0.0.0.0 0.0.0.0 192.168.1.1
seem to be enough to distribute this default gateway link to 4 other routes on my network. I setup a lab with this information and cannot get the default gateway distributed by EIGRP. I've looked over my production configs all day and do not see any other command on the router that would send out an advertisement of the 0.0.0.0 network to the other 4 routers besides what I just posted here.
With the Redistibute Static command should all static routes configured on the router be advertises to other routers with EIGRP? If the link is down or the route doesn't actually exist, should it still redistribute the static route information that you configured? Thanks for any help, -Mark
Solved! Go to Solution.
03-18-2013 11:22 AM
Here's both configs, I just found that the protocol is down on my interfaces connecting R1 and R2, not sure why this is, both have an IP and the no shut command.
R1#show run
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
multilink bundle-name authenticated
!
!
redundancy
!
interface Loopback1
ip address 97.56.2.1 255.255.255.0
!
interface GigabitEthernet0/0
description $ETH-LAN$
ip address 10.202.1.1 255.255.0.0
ip nbar protocol-discovery
ip flow ingress
ip flow egress
delay 5600
duplex full
speed auto
!
interface GigabitEthernet0/1
description Goes to R2
ip address 192.168.130.1 255.255.255.128
delay 1
duplex full
speed auto
!
!
router eigrp 550
network 10.202.0.0 0.0.255.255
network 172.30.1.0 0.0.0.3
network 192.168.20.60 0.0.0.3
network 192.168.20.76 0.0.0.3
network 192.168.20.84 0.0.0.3
network 192.168.130.252 0.0.0.3
redistribute static
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
ip route x.x.x.x 255.255.0.0 x.x.x.x
list continues...
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
end
___________________________
R2#show run
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
multilink bundle-name authenticated
!
interface FastEthernet0/0
description Goes to R1
ip address 192.168.130.2 255.255.255.128
delay 1
duplex full
speed 100
!
interface FastEthernet0/1
ip address 10.1.0.1 255.255.0.0
duplex auto
speed auto
!
interface Serial0/0/0
no ip address shutdown
no fair-queue
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
router eigrp 550
redistribute static
network 10.1.0.0 0.0.255.255
network 172.30.1.0 0.0.0.3
network 192.168.20.56 0.0.0.3
network 192.168.20.60 0.0.0.3
network 192.168.20.84 0.0.0.3
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.0.110
ip route x.x.x.x 255.255.0.0 x.x.x.x
list continues...
!
ip http server
ip http authentication local
ip http secure-server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end
03-18-2013 11:55 AM
Try changing R1 interface to:
speed 100
duplex full
I've started lab-ing up with your config and this needs correct first.
R1#ping
*Mar 1 00:04:22.695: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet0/1 (not full duplex), with R2 FastEthernet0/1 (full dup
R1#
R1#
R1#show run int fa0/1
Building configuration...
Current configuration : 109 bytes
!
interface FastEthernet0/1
ip address 192.168.130.1 255.255.255.128
delay 1
speed auto
full-duplex
end
==============================================
R2#
R2#show run int fa0/1
Building configuration...
Current configuration : 108 bytes
!
interface FastEthernet0/1
ip address 192.168.130.2 255.255.255.128
delay 1
speed 100
full-duplex
end
-------------------------------------------------------------------------------
R1#
*Mar 1 00:04:39.947: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet0/1 (not half duplex), with R2 FastEthernet0/1 (half duplex).
R1(config-if)# speed 100
R1(config-if)# duplex full
*Mar 1 00:08:55.679: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
I think you are missing the network statements on R1 and R2 as below:
R1
network 192.168.130.1 0.0.0.0
R2
network 192.168.130.2 0.0.0.0
Please see below:
R1(config)#router eigrp 550
R1(config-router)#
R1(config-router)#network 192.168.130.1 0.0.0.0
R1(config-router)#end
R1#
*Mar 1 00:16:18.375: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 550: Neighbor 192.168.130.2 (FastEthernet0/1) is up: new adjacency
*Mar 1 00:16:19.495: %SYS-5-CONFIG_I: Configured from console by console
R1#
=====================================
R2(config-router)#network 192.168.130.2 0.0.0.0
R2(config-router)#
*Mar 1 00:16:18.347: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 550: Neighbor 192.168.130.1 (FastEthernet0/1) is up: new adjacency
03-18-2013 12:03 PM
Ah, I overlooked that speed command. making both 100 solved the issue of the protocol being down but eigrp still doesn't seem to be redistributing the static 0.0.0.0 route.
03-18-2013 12:08 PM
See in my previous post the network statement to enable EIGRP on those interfaces that connect R1 and R2 together.
After this....
Please do a show ip eigrp neighbors.... what do you see?
Should be a little like this:
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 550
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.130.2 Fa0/1 11 00:03:34 1267 5000 0 3
R1#
R1#
======================================================
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.130.2 to network 0.0.0.0
192.168.130.0/25 is subnetted, 1 subnets
C 192.168.130.0 is directly connected, FastEthernet0/1
D*EX 0.0.0.0/0 [170/25856] via 192.168.130.2, 00:04:24, FastEthernet0/1
03-18-2013 12:13 PM
This is the output:
R1#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(550)
R1#
03-18-2013 12:15 PM
Please see my previous post
I think you are missing the network statements on R1 and R2 as below:
R1
network 192.168.130.1 0.0.0.0
R2
network 192.168.130.2 0.0.0.0
Please see below:
R1(config)#router eigrp 550
R1(config-router)#
R1(config-router)#network 192.168.130.1 0.0.0.0
R1(config-router)#end
R1#
*Mar 1 00:16:18.375: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 550: Neighbor 192.168.130.2 (FastEthernet0/1) is up: new adjacency
*Mar 1 00:16:19.495: %SYS-5-CONFIG_I: Configured from console by console
R1#
=====================================
R2(config-router)#network 192.168.130.2 0.0.0.0
R2(config-router)#
*Mar 1 00:16:18.347: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 550: Neighbor 192.168.130.1 (FastEthernet0/1) is up: new adjacency
03-18-2013 12:14 PM
Bilal, did you use that exact configuration I sent you and it's working?
03-18-2013 12:18 PM
Yes, apart from the network statements above to bring the adjacency 'up'.
EIGRP needs to be enabled on the interfaces that connect R1 and R2 together.
Let me know if this works in your lab too
03-18-2013 01:04 PM
Thank you! I was wondering how this could be the case because my production enviornment isn't configured with the 192 network statements, now I realized that's because I'm using a VPN and the network is a 172 on the tunnel which my process of eigrp is configured with.
Thank you for your help Bilal and Peter, hope I didn't waste your time with something as simple as this. It was a great learning experience for me though! Thanks!!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide