Showing results for 
Search instead for 
Did you mean: 


Re: I had a same scenario just an

ip tftp source-interface gig0/0/0 was very helpful,

it fixed my problem.



Solved for me. I had this

Solved for me. 

I had this same problem.  I use a Linux tftp server with owner and group with same name as the username from the switch/ router I upload and download configs / images with.

Since the switch was not configured with username and I was not logged in with username, I was getting the timeout error. 

I changed the permissions on the file on the Linux box to allow others read access to the bin file in question and voilà I stopped receiving these errors.


I had the same problem. The

I had the same problem. The fix for me was Windows Firewall. I allowed my TFTP Server app on both Private and Public and afterward the transfer worked first try.


Had timeout problem using

Had timeout problem using Solarwinds TFTP on Windows 10.    The fix was to add Solarwinds TFTP Server to the allowed apps.  Only added it on the Private network. 

Had to browse to the folder the file was in to add it. 

"C:\Program Files (x86)\SolarWinds\TFTP Server\SolarWinds TFTP Server.exe".  

Works great now.


Thanks Yes,

Thanks Yes, it works great for me as well by follow your steps here. 




we had the same problem also after installing a new router, my colleague fixed by adding the following config line:

ip tftp source-interface interface_from_where_you_manage_router  (in our case it is a Loopback).



Thank you for this.

Thank you for this. Specifying the correct source interface worked for me:

RT01(config)#ip tftp source-interface GigabitEthernet0/0.1
RT01#copy startup-config tftp
Address or name of remote host []? 
Destination filename [rt01confg]?
19118 bytes copied in 1.040 secs (18383 bytes/sec)



I had similar issue .I have

I had similar issue .I have done two things one is disabling firewall service another i noticed that  the tftp server(mine solarwind) using binding x.x.x.x/32 as the mask.

So i put x.x.x.253/32 as the tftp server ip and router interface ip as x.x.x.254

It worked and  i was able to copy files .

Reply if it fix your case too..




I found that my file was

I found that my file was larger than the TFTP server could handle. It could only handle 32MG and my file was 200MG. I had to get another TFTP server.

i am facing issue copy ios cisco switch 3650 tftp servers


Please help me , i am facing issue cisco switch ws-c3850-24xs ,  need for ios backup plz help .


Re: Error opening tftp (Timed out)

I tried all those suggestions w/o any luck... I found out (the hard way lol) that from an isr, I had to increase the block size: ip tftp blocksize ,  default is ~512, make it 8k,


Re: Error opening tftp (Timed out)

1. Go to Windows Firewall with Advanced Security on the TFTP/FTP Server

2. Add New Inbound Rule.

3. Specify IP/UDP/TCP Protocol and the specific port to allow (e.g If you are using SolarWinds TFTP Server Software, It works on UDP Port 69).

It worked for me. Hope it works for others if there is no other Firewall/ACL Rule implemented.

Yev Beginner

Re: Error opening tftp (Timed out)

I was having this issue with a new switch and this fixed it for me


conf t
no service config


Sometimes when switch first boots it may try to load a config from a tftp server and never stops thus the socket timeout


Re: Error opening tftp (Timed out)

Hello Dear if you want to solve this solution you have to watch the following video:

How to FIX : %Error opening tftp:// (Socket error) | Urdu 2019 Please Subscribe my Channel for more informative videos also like the video and share with your friends.... Please Visit our Website: Please Like our Facebook Page also: ...

Re: Error opening tftp (Timed out)

We have the problem too with a Catalyst 9300 access switch and a Catalyst 9500 distribution, with vrf.

We testing with a catalyst 3850 and even these switch gives the error.


The solution we found, and works:


ip tftp blocksize 512


In an other situation we used 8192.

It works but we don't no why. Someone an explanation?


Best Regards, Harrie


CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards