03-04-2009 12:02 PM - edited 03-06-2019 04:23 AM
can someone please tell me the config commands to set up ether channeling between 2 multimode fiber connection on a cisco switch. when i initial configured and plugged in my fiber there was traffic then it stopped and the ports shut down. no link lights at all. when i remove ether channel groups traffic resumes. i've editing the config so much i'm not sure what i changed and should keep at this point. thanks for any help.
current config
switchport trunk encapsulation dot1q
switchport mode trunk
switchport non negotiate
spanning tree port fast trunk
i'm getting this when i do a show ether channel "port state down - not in bndl" what bundle?
03-04-2009 12:20 PM
Is this a layer 2 etherchannel ? if so then you need a channel-group command ie.
assuming your 2 fibre ports are gi1/3 & gi1/4
6500(config)# int range gi1/3 - 4
6500(config-if-range)# channel-group 1 mode on
this then creates a port-channel interface for you. Note i have used channel-group 1 in the above, you need to use an unused number for the channel-group as 1 may already be in use.
So you have a port-channel interface. Configure it as follows
int po1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport non negotiate
Make sure the speed/duplex settings are same on both gi ports.
Attached is a link to configuring etherchannel on 6500, principles are same for most switches -
Jon
03-04-2009 01:45 PM
your config is what i had originally but the connectivity dropped. we're configuring 2 ether channels from a stand alone switch to our core stack and whenever i put it in a port group the connection shuts down completely. read the article and still doesn't tell me much about what could be wrong with the config.
03-04-2009 02:56 PM
Could this be because the config is different on the physical interface and the Port Channel. Default the config on the physical interface using the default interface command. Then just make the physical interface a switchport and a trunk, then add it to the port-channel with the 'channel-group x mode on command' and add all the needed details to the Port-channel and see if that helps.
03-05-2009 07:24 AM
CORE Stack Switch
interface Port-channel10
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
end
interface GigabitEthernet4/0/49
description Fiber connection to IT switch port 26
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 10 mode on
spanning-tree portfast trunk
end
!
interface GigabitEthernet5/0/50
description to IT Switch port 25
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 10 mode on
spanning-tree portfast trunk
end
Stand alone switch
interface GigabitEthernet1/0/26
description Fiber connection to Data Center port 49
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast trunk
end
interface GigabitEthernet1/0/25
description Fiber connnection to Data Center port 50
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
end
03-05-2009 07:45 AM
You haven't assigned the Stand alone switch interfaces to a Port-channel.
Both ends need to be configured as a port-channel for it to work.
03-06-2009 07:08 AM
It was configured in the same port channel group on the stand alone side but when i do that it brings both connections down so i removed it.
03-06-2009 07:22 AM
Hi
Put the config back is it should be, (ie the Port-channel on both switches) then re post your configuration.
03-06-2009 07:26 AM
CORE Stack Switch
interface Port-channel10
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
end
interface GigabitEthernet4/0/49
description Fiber connection to IT switch port 26
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 10 mode on
spanning-tree portfast trunk
end
!
interface GigabitEthernet5/0/50
description to IT Switch port 25
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 10 mode on
spanning-tree portfast trunk
end
Stand alone switch
interface Port-channel10
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
end
interface GigabitEthernet1/0/26
description Fiber connection to Data Center port 49
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 10 mode on
spanning-tree portfast trunk
end
interface GigabitEthernet1/0/25
description Fiber connnection to Data Center port 50
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 10 mode on
spanning-tree portfast trunk
end
03-06-2009 08:20 AM
If you are using CDP, issue the command 'show cdp neighbors' to make sure you have the right interfaces connected and configured as he config looks good.
03-06-2009 09:01 AM
ran a cdp neighbors and it shows correct connections but something has to be wrong why it shuts donw both connections when i add the port channel group.
CS1_ITSwitch Gig 5/0/50
CS1_ITSwitch Gig 4/0/49
03-04-2009 05:38 PM
Your best bet is to post both sides of the configs so we can see each end .
03-06-2009 10:59 AM
i posted both sides. any ideas
03-06-2009 11:23 AM
Can you add one interface both sides to the Port Channel then post the output of :-
show interface x etherchannel
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide