cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
430
Views
0
Helpful
1
Replies

Failover problem in 6509 switches

sunil-koul
Beginner
Beginner

We have connected 2 sql servers (one to primary switch 6509 and one to secondary switch 6509).Once we are doing failover of secondary switch just disabling port of secondary switch where Sql server is connected.It fails but if both servers are connected to 2 different ports on same switch (primary switch) it works.Can anyone guide what may be the problem here.

1 Reply 1

Sandeep Choudhary
VIP Alumni
VIP Alumni

HI Sunil,

Have you done with these steps??

1) Connect the 2 switches with a Layer 2 etherchannel trunk

2) Create your server vlans on the switches

3) Create the L3 interfaces for your vlans and use HSRP to have a virtual IP.

4) Set the default gateway of the servers to be the virtual IP of their relevant vlan.

5) Dual connect your router to both switches

or

Or if the switch have 2 diff ip address then....use this example

Switch1:

interface Port-channel29

description *** Po29, 2 CU Etherchannel 9/15-9/16, Server Name ***

switchport

switchport access vlan 10

switchport mode access

no ip address

Switch 2:

interface Port-channel29

description *** Po29, 2 Port CU Etherchannel 10/9-10/10 Server name ***

switchport

switchport access vlan 10

switchport mode access

no ip address

Port config:

Intrface GigabitEthernet9/16

description *** Gi9/15, Server name***
switchport
switchport access vlan 10
switchport mode access
no ip address
speed 1000
duplex full
no cdp enable
spanning-tree portfast
spanning-tree bpdufilter enable
channel-group 29 mode active
!
interface GigabitEthernet9/16
description *** Gi9/16, Server name ***
switchport
switchport access vlan 10
switchport mode access
no ip address
speed 1000
duplex full
no cdp enable
spanning-tree portfast
spanning-tree bpdufilter enable
channel-group 29 mode active

Regards

Please rate if it helps.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: